aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2007-08-05 17:17:42 +0800
committerskv <skv@FreeBSD.org>2007-08-05 17:17:42 +0800
commit2475053640ca53af0c7fe452c3635a6ffd8ddc26 (patch)
tree7d428e07d17b16dfde554396b811b2a32938fd95
parentc19ad3a3a9208b96e62e372b82e5254a580e19f7 (diff)
downloadfreebsd-ports-gnome-2475053640ca53af0c7fe452c3635a6ffd8ddc26.tar.gz
freebsd-ports-gnome-2475053640ca53af0c7fe452c3635a6ffd8ddc26.tar.zst
freebsd-ports-gnome-2475053640ca53af0c7fe452c3635a6ffd8ddc26.zip
Add p5-Catalyst-Plugin-Captcha 0.03, create and validate Captcha for
Catalyst.
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-Captcha/Makefile28
-rw-r--r--www/p5-Catalyst-Plugin-Captcha/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-Captcha/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-Captcha/pkg-plist7
5 files changed, 42 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 0a347086ed15..be38fd32576d 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -627,6 +627,7 @@
SUBDIR += p5-Catalyst-Plugin-Cache-FileCache
SUBDIR += p5-Catalyst-Plugin-Cache-Memcached
SUBDIR += p5-Catalyst-Plugin-Cache-Store-FastMmap
+ SUBDIR += p5-Catalyst-Plugin-Captcha
SUBDIR += p5-Catalyst-Plugin-ConfigLoader
SUBDIR += p5-Catalyst-Plugin-ConfigLoader-Environment
SUBDIR += p5-Catalyst-Plugin-DefaultEnd
diff --git a/www/p5-Catalyst-Plugin-Captcha/Makefile b/www/p5-Catalyst-Plugin-Captcha/Makefile
new file mode 100644
index 000000000000..e450df11374f
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Captcha/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Catalyst-Plugin-Captcha
+# Date created: 05 August 2007
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-Captcha
+PORTVERSION= 0.03
+CATEGORIES= www security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Create and validate Captcha for Catalyst
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.7000:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ ${SITE_PERL}/Catalyst/Plugin/Session.pm:${PORTSDIR}/www/p5-Catalyst-Plugin-Session \
+ ${SITE_PERL}/HTTP/Date.pm:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/GD/SecurityImage.pm:${PORTSDIR}/security/p5-GD-SecurityImage
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::Captcha.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-Captcha/distinfo b/www/p5-Catalyst-Plugin-Captcha/distinfo
new file mode 100644
index 000000000000..5d5507263b81
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Captcha/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-Captcha-0.03.tar.gz) = c64ebc9c77503902c3c418908acd027a
+SHA256 (Catalyst-Plugin-Captcha-0.03.tar.gz) = 97487e631d621875f8b941e17cc5a3ca62442da2d196b7197eae8b91d2d123dd
+SIZE (Catalyst-Plugin-Captcha-0.03.tar.gz) = 2958
diff --git a/www/p5-Catalyst-Plugin-Captcha/pkg-descr b/www/p5-Catalyst-Plugin-Captcha/pkg-descr
new file mode 100644
index 000000000000..5df9263d1926
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Captcha/pkg-descr
@@ -0,0 +1,3 @@
+This plugin for Catalyst creates and validates Captcha.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-Captcha/
diff --git a/www/p5-Catalyst-Plugin-Captcha/pkg-plist b/www/p5-Catalyst-Plugin-Captcha/pkg-plist
new file mode 100644
index 000000000000..072823e0cf6e
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-Captcha/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Captcha/.packlist
+%%SITE_PERL%%/Catalyst/Plugin/Captcha.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/Captcha
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/Catalyst