aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoreadler <eadler@FreeBSD.org>2013-12-02 13:42:56 +0800
committereadler <eadler@FreeBSD.org>2013-12-02 13:42:56 +0800
commit247cfb4f7c40f2c55ae286789afc74688b5ba9f3 (patch)
treec2f1e1b41581824f9c4283cec88cad2511551cd7
parentcb69fc62f1eb22f7d948e223f0ba40e49b9775ff (diff)
downloadfreebsd-ports-gnome-247cfb4f7c40f2c55ae286789afc74688b5ba9f3.tar.gz
freebsd-ports-gnome-247cfb4f7c40f2c55ae286789afc74688b5ba9f3.tar.zst
freebsd-ports-gnome-247cfb4f7c40f2c55ae286789afc74688b5ba9f3.zip
- Modernize the port: uses USES, etc.
- Stagify the port Submitted by: Brian Callahan <bcallah@cvs.openbsd.org> Approved by: maintainer timeout (> 1 month)
-rw-r--r--comms/picocom/Makefile9
-rw-r--r--comms/picocom/files/patch-Makefile23
2 files changed, 5 insertions, 27 deletions
diff --git a/comms/picocom/Makefile b/comms/picocom/Makefile
index 861f61a0843d..d74cffaca5d1 100644
--- a/comms/picocom/Makefile
+++ b/comms/picocom/Makefile
@@ -10,10 +10,11 @@ MAINTAINER= dhn@FreeBSD.org
COMMENT= Dumb Terminal Emulator
ALL_TARGET= picocom
-USE_GMAKE= yes
+USES= gmake
-PLIST_FILES= bin/picocom
-MAN8= picocom.8
+PLIST_FILES= bin/picocom man/man8/picocom.8.gz
-NO_STAGE= yes
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.8 ${STAGEDIR}${MAN8PREFIX}/man/man8/
.include <bsd.port.mk>
diff --git a/comms/picocom/files/patch-Makefile b/comms/picocom/files/patch-Makefile
deleted file mode 100644
index cc4eaa015614..000000000000
--- a/comms/picocom/files/patch-Makefile
+++ /dev/null
@@ -1,23 +0,0 @@
---- ./Makefile.orig 2010-05-29 00:39:52.000000000 +0200
-+++ ./Makefile 2011-03-30 22:23:36.000000000 +0200
-@@ -1,6 +1,9 @@
-
- VERSION=1.6
-
-+BIN = $(PREFIX)/bin
-+MAN8 = $(PREFIX)/man/man8
-+
- # CC = gcc
- CPPFLAGS=-DVERSION_STR=\"$(VERSION)\" -DUUCP_LOCK_DIR=\"/var/lock\" \
- -DHIGH_BAUD
-@@ -43,3 +46,10 @@
- rm -f picocom.8.html
- rm -f picocom.8.ps
- rm -f CHANGES
-+
-+install:
-+ install -d $(BIN)
-+ install -o root picocom $(BIN)
-+ install -d $(MAN8)
-+ install -o root picocom.8 $(MAN8)
-+