aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2011-06-24 01:33:51 +0800
committerpgollucci <pgollucci@FreeBSD.org>2011-06-24 01:33:51 +0800
commit2485c087258337c63e185b415cc385b5473fe64f (patch)
treef0fcf05fad84678a66d23cc5ab362d6eb011d372
parent2055548d5349b20c8f178f23b2b878b5e0d39774 (diff)
downloadfreebsd-ports-gnome-2485c087258337c63e185b415cc385b5473fe64f.tar.gz
freebsd-ports-gnome-2485c087258337c63e185b415cc385b5473fe64f.tar.zst
freebsd-ports-gnome-2485c087258337c63e185b415cc385b5473fe64f.zip
There is a disconnect in the ruby/rails/dm community over whether api compatible
json 1.4.6 vs 1.5.x should be used. Half use one, Half use the other. This library can parse JSON texts and generate them from ruby data structures. This port implemented in C and comes with its own unicode conversion functions and a parser generated by the Ragel State Machine Compiler. WWW: http://json-jruby.rubyforge.org/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-json146/Makefile23
-rw-r--r--devel/rubygem-json146/distinfo2
-rw-r--r--devel/rubygem-json146/pkg-descr5
4 files changed, 31 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index a7989025bb94..0b3194e370cd 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3264,6 +3264,7 @@
SUBDIR += rubygem-jammit
SUBDIR += rubygem-jruby-jars
SUBDIR += rubygem-json
+ SUBDIR += rubygem-json146
SUBDIR += rubygem-json_pure
SUBDIR += rubygem-launchy
SUBDIR += rubygem-linecache
diff --git a/devel/rubygem-json146/Makefile b/devel/rubygem-json146/Makefile
new file mode 100644
index 000000000000..be2797772d8e
--- /dev/null
+++ b/devel/rubygem-json146/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Ruby replacement for json
+# Date created: June 23, 2011
+# Whom: Philip M. Gollucci <pgollucci@p6m7g8.com>
+#
+# $FreeBSD$
+#
+
+## XXX: Legacy for rubygem DM ports
+
+PORTNAME= json
+PORTVERSION= 1.4.6
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Parse JSON texts and generate them from ruby data structures
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+PLIST_FILES= bin/edit_json.rb bin/prettify_json.rb
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-json146/distinfo b/devel/rubygem-json146/distinfo
new file mode 100644
index 000000000000..3fb7c2f1e000
--- /dev/null
+++ b/devel/rubygem-json146/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/json-1.4.6.gem) = d3241a141c6da5963e59bf75a91d832d13e7ec6793b8e48465395216a1e17ec5
+SIZE (rubygem/json-1.4.6.gem) = 398848
diff --git a/devel/rubygem-json146/pkg-descr b/devel/rubygem-json146/pkg-descr
new file mode 100644
index 000000000000..2a3eace4f61b
--- /dev/null
+++ b/devel/rubygem-json146/pkg-descr
@@ -0,0 +1,5 @@
+This library can parse JSON texts and generate them from ruby data structures.
+This port implemented in C and comes with its own unicode conversion functions
+and a parser generated by the Ragel State Machine Compiler.
+
+WWW: http://json-jruby.rubyforge.org/