aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvs <vs@FreeBSD.org>2004-05-10 04:17:15 +0800
committervs <vs@FreeBSD.org>2004-05-10 04:17:15 +0800
commit2593869b34e0a0fc049bfa41b33e991418947a76 (patch)
treeee71f0abbfaca9d1e83982a2f13bf9ac1edbd12a
parent7c7cc428008905bc7effdc90982ec552a76ddeb6 (diff)
downloadfreebsd-ports-gnome-2593869b34e0a0fc049bfa41b33e991418947a76.tar.gz
freebsd-ports-gnome-2593869b34e0a0fc049bfa41b33e991418947a76.tar.zst
freebsd-ports-gnome-2593869b34e0a0fc049bfa41b33e991418947a76.zip
Unbreak on -STABLE (no stdint.h).
PR: ports/65850 Approved by: maintainer silence
-rw-r--r--textproc/iiimf-protocol-lib/Makefile8
-rw-r--r--textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h13
2 files changed, 9 insertions, 12 deletions
diff --git a/textproc/iiimf-protocol-lib/Makefile b/textproc/iiimf-protocol-lib/Makefile
index 4c0e1d390071..e8cea2eea1fc 100644
--- a/textproc/iiimf-protocol-lib/Makefile
+++ b/textproc/iiimf-protocol-lib/Makefile
@@ -27,12 +27,6 @@ HAS_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
--includedir=${PREFIX}/include/iiimf/iiimp
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on 4.x"
-.endif
-
post-patch:
${REINPLACE_CMD} -e "s,-lpthread,-pthread,g" \
-e "s,-D_POSIX_C_SOURCE=199506L,,g" \
@@ -40,4 +34,4 @@ post-patch:
-e "s,/usr/lib/im,${PREFIX}/lib/im,g" \
${WRKSRC}/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h b/textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h
index b3a187bf353c..ed6d5e70cb79 100644
--- a/textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h
+++ b/textproc/iiimf-protocol-lib/files/patch-include_iiimp_iiimp-data.h
@@ -1,11 +1,14 @@
---- include/iiimp/iiimp-data.h.orig Sat Dec 6 02:19:44 2003
-+++ include/iiimp/iiimp-data.h Sat Dec 6 02:18:15 2003
-@@ -7,7 +7,7 @@
+--- include/iiimp/iiimp-data.h.orig Wed Apr 21 16:01:34 2004
++++ include/iiimp/iiimp-data.h Wed Apr 21 16:01:45 2004
+@@ -7,11 +7,8 @@
#include <stdio.h>
#include <sys/types.h>
-#if defined(linux)
-+#if defined(linux) || defined(__FreeBSD__)
- #include <stdint.h>
+-#include <stdint.h>
typedef unsigned char uchar_t;
typedef unsigned int uint_t;
+-#endif /* linux */
+
+ #include <iiimp-opcode.h>
+