diff options
author | amdmi3 <amdmi3@FreeBSD.org> | 2009-08-14 07:45:26 +0800 |
---|---|---|
committer | amdmi3 <amdmi3@FreeBSD.org> | 2009-08-14 07:45:26 +0800 |
commit | 2647e08e7421e334c7438580ea5e66b328466d35 (patch) | |
tree | 09e8618bb31cc401bfa80e51e547c015d072c4ff | |
parent | 1f1c483db0e2359ba8f7cbd7d7c5ea7bae963e3c (diff) | |
download | freebsd-ports-gnome-2647e08e7421e334c7438580ea5e66b328466d35.tar.gz freebsd-ports-gnome-2647e08e7421e334c7438580ea5e66b328466d35.tar.zst freebsd-ports-gnome-2647e08e7421e334c7438580ea5e66b328466d35.zip |
- Update to 0.36.2
20 files changed, 283 insertions, 190 deletions
diff --git a/games/rigsofrods/Makefile b/games/rigsofrods/Makefile index 793c863ab711..9cf29993f396 100644 --- a/games/rigsofrods/Makefile +++ b/games/rigsofrods/Makefile @@ -6,15 +6,12 @@ # PORTNAME= rigsofrods -PORTVERSION= 0.36.1 -PORTREVISION= 3 +PORTVERSION= 0.36.2 CATEGORIES= games -# I've trimmed source tarball by around 10x and bundled rorserver -MASTER_SITES= SF:contents \ - http://mirror.amdmi3.ru/distfiles/:game -DISTFILES= ${PORTNAME}-source-${PORTVERSION}-trimmed${EXTRACT_SUFX}:game \ - ${PORTNAME}-contents-${PORTVERSION}.zip:contents -EXTRACT_ONLY= ${PORTNAME}-source-${PORTVERSION}-trimmed${EXTRACT_SUFX} +MASTER_SITES= SF +DISTFILES= ${PORTNAME}-source-${PORTVERSION}${EXTRACT_SUFX} \ + ${PORTNAME}-contents-${PORTVERSION}${EXTRACT_SUFX} +EXTRACT_ONLY= ${PORTNAME}-source-${PORTVERSION}${EXTRACT_SUFX} MAINTAINER= amdmi3@FreeBSD.org COMMENT= Truck, car, airplane and boat simulator with advanced physics @@ -29,16 +26,17 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois \ RUN_DEPENDS= ${LOCALBASE}/lib/libOIS.so:${PORTSDIR}/devel/ois \ xset:${PORTSDIR}/x11/xset +USE_ZIP= yes USE_XORG= x11 xt xaw sm ice xext -WRKSRC= ${WRKDIR}/${PORTVERSION}/build +WRKSRC= ${WRKDIR}/${PORTNAME}-source-${PORTVERSION}/build USE_WX= 2.6+ WX_UNICODE= yes MAKE_JOBS_SAFE= yes USE_CMAKE= yes -# CG unavailable for FreeBSD; paged also requires CG +# CG unavailable for FreeBSD CMAKE_ARGS= -DROR_BUILD_HYDRAX=TRUE \ - -DROR_BUILD_PAGED=FALSE \ + -DROR_BUILD_PAGED=TRUE \ -DROR_BUILD_LUASCRIPT=TRUE \ -DROR_BUILD_CONFIGURATOR=TRUE \ -DOGRE_BUILD_PLUGIN_CG=FALSE \ @@ -73,6 +71,11 @@ post-patch: s|%%PREFIX%%|${PREFIX}|' \ ${WRKSRC}/main/source/Settings.cpp \ ${WRKSRC}/configurator/source/configurator.cpp +.if ${OSVERSION} >= 800067 +# after strnlen was introduced, use it + @${REINPLACE_CMD} -e '/strnlen/ d' ${WRKSRC}/main/CMakeLists.txt \ + ${WRKSRC}/configurator/CMakeLists.txt +.endif do-install: # libs @@ -91,7 +94,7 @@ do-install: ${SED} -e '/Plugin_CgProgramManager/ s|^|#|' \ < ${WRKSRC}/bin/release/linux/plugins.cfg \ > ${DATADIR}/plugins.cfg - unzip -qq -o -d ${DATADIR} ${DISTDIR}/${PORTNAME}-contents-${PORTVERSION}.zip \ + ${UNZIP_CMD} -qq -o -d ${DATADIR} ${DISTDIR}/${PORTNAME}-contents-${PORTVERSION}.zip \ languages/\* resources/\* skeleton/\* streams/\* # wrappers @@ -101,7 +104,7 @@ do-install: #docs .if !defined(NOPORTDOCS) ${MKDIR} ${DOCSDIR} - unzip -qq -o -d ${DOCSDIR} ${DISTDIR}/${PORTNAME}-contents-${PORTVERSION}.zip \ + ${UNZIP_CMD} -qq -o -d ${DOCSDIR} ${DISTDIR}/${PORTNAME}-contents-${PORTVERSION}.zip \ \*.pdf .endif diff --git a/games/rigsofrods/distinfo b/games/rigsofrods/distinfo index df22dc9b02db..716a088b8d55 100644 --- a/games/rigsofrods/distinfo +++ b/games/rigsofrods/distinfo @@ -1,6 +1,6 @@ -MD5 (rigsofrods-source-0.36.1-trimmed.tar.gz) = ae4d305535c780c271da375b2fd42f5c -SHA256 (rigsofrods-source-0.36.1-trimmed.tar.gz) = 4a923bfd652bd8398aa2f21022fe72a083905d1ee7696bf10e3b781478d9b7ed -SIZE (rigsofrods-source-0.36.1-trimmed.tar.gz) = 21781314 -MD5 (rigsofrods-contents-0.36.1.zip) = bfa066124b7e8ca48bc0dce45149c886 -SHA256 (rigsofrods-contents-0.36.1.zip) = c3fe969f67cea9a8b2750271fe2b03f6f522dda9f07bc1a47cb9dda8e95c09e9 -SIZE (rigsofrods-contents-0.36.1.zip) = 122490754 +MD5 (rigsofrods-source-0.36.2.zip) = 5757df333b7db220caaf487e93e1190c +SHA256 (rigsofrods-source-0.36.2.zip) = 26da5eaceb600391f239da8f31a43d01637947ef2c1c361df000b9805acd2913 +SIZE (rigsofrods-source-0.36.2.zip) = 65538193 +MD5 (rigsofrods-contents-0.36.2.zip) = 9e4dbf302e30351caecd44a6de4fca3a +SHA256 (rigsofrods-contents-0.36.2.zip) = 88c23e55c17fa4afb32a2733b3483da43585cb293bc8f0ea1629df435f8db02d +SIZE (rigsofrods-contents-0.36.2.zip) = 140682319 diff --git a/games/rigsofrods/files/patch-CMakeLists.txt b/games/rigsofrods/files/patch-CMakeLists.txt index 8568c1382702..f01f3c560a8b 100644 --- a/games/rigsofrods/files/patch-CMakeLists.txt +++ b/games/rigsofrods/files/patch-CMakeLists.txt @@ -1,19 +1,16 @@ ---- CMakeLists.txt.orig 2009-02-22 20:59:55.000000000 +0300 -+++ CMakeLists.txt 2009-03-05 04:01:24.000000000 +0300 -@@ -3,11 +3,11 @@ +--- CMakeLists.txt.orig 2009-06-28 01:07:12.000000000 +0400 ++++ CMakeLists.txt 2009-08-12 23:48:27.000000000 +0400 +@@ -2,13 +2,6 @@ +
project(RoR)
- #detup the default build mode
+-#detup the default build mode
-IF(NOT CMAKE_BUILD_TYPE)
- SET(CMAKE_BUILD_TYPE RelWithDebInfo CACHE STRING
- "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel."
- FORCE)
-ENDIF(NOT CMAKE_BUILD_TYPE)
-+#IF(NOT CMAKE_BUILD_TYPE)
-+# SET(CMAKE_BUILD_TYPE RelWithDebInfo CACHE STRING
-+# "Choose the type of build, options are: None Debug Release RelWithDebInfo MinSizeRel."
-+# FORCE)
-+#ENDIF(NOT CMAKE_BUILD_TYPE)
-
+-
# setup path for cmake add-ons
SET(RoR_Dependencies_CMAKE_DIR "${RoR_SOURCE_DIR}/dependencies/cmake")
+ SET(BUILD_SHARED_LIBS ON)
diff --git a/games/rigsofrods/files/patch-configurator-CMakeLists.txt b/games/rigsofrods/files/patch-configurator-CMakeLists.txt index 7f5ca51b8264..d7aa182f214b 100644 --- a/games/rigsofrods/files/patch-configurator-CMakeLists.txt +++ b/games/rigsofrods/files/patch-configurator-CMakeLists.txt @@ -1,13 +1,11 @@ ---- configurator/CMakeLists.txt.orig 2009-02-22 20:59:55.000000000 +0300 -+++ configurator/CMakeLists.txt 2009-03-07 03:57:31.000000000 +0300 -@@ -22,9 +22,12 @@ +--- configurator/CMakeLists.txt.orig 2009-06-25 22:30:12.000000000 +0400 ++++ configurator/CMakeLists.txt 2009-08-13 19:19:37.000000000 +0400 +@@ -27,9 +27,10 @@ link_directories (${wxWidgets_LIB_DIR}) include_directories (${RoR_Dependencies_SOURCE_DIR}/rorserver-sf/source) include_directories (${RoR_Dependencies_SOURCE_DIR}/ogrenew/OgreMain/include) - include_directories (${RoR_Dependencies_SOURCE_DIR}/ogrenew/Dependencies/include) - include_directories (${RoR_Dependencies_SOURCE_DIR}/OIS-HEAD/ois/includes) -+ # include_directories (${RoR_Dependencies_SOURCE_DIR}/ogrenew/Dependencies/include) -+ # include_directories (${RoR_Dependencies_SOURCE_DIR}/OIS-HEAD/ois/includes) include_directories (${RoR_Main_SOURCE_DIR}/source) + include_directories (${LOCALBASE}/include/OIS) + @@ -15,7 +13,7 @@ SET(config_source ${config_source} ${RoR_SOURCE_DIR}/main/source/InputEngine.cpp) -@@ -43,7 +46,7 @@ +@@ -48,7 +49,7 @@ add_executable(rorconfig ${config_source} ${config_headers} ${config_res}) TARGET_LINK_LIBRARIES(rorconfig ${wxWidgets_LIBRARIES} ) diff --git a/games/rigsofrods/files/patch-configurator-source-configurator.cpp b/games/rigsofrods/files/patch-configurator-source-configurator.cpp index 5bf3db1d82fb..8bf8e1280420 100644 --- a/games/rigsofrods/files/patch-configurator-source-configurator.cpp +++ b/games/rigsofrods/files/patch-configurator-source-configurator.cpp @@ -1,6 +1,6 @@ ---- configurator/source/configurator.cpp.orig 2009-02-22 20:59:55.000000000 +0300 -+++ configurator/source/configurator.cpp 2009-04-09 07:25:25.000000000 +0400 -@@ -1109,17 +1109,12 @@ +--- configurator/source/configurator.cpp.orig 2009-06-28 04:44:14.000000000 +0400 ++++ configurator/source/configurator.cpp 2009-08-13 04:09:42.000000000 +0400 +@@ -1330,17 +1330,12 @@ char procpath[256];
char user_path[1024];
char program_path[1024];
@@ -20,7 +20,7 @@ UserPath=tfn.GetPath();
#endif
#if OGRE_PLATFORM == OGRE_PLATFORM_APPLE
-@@ -2692,7 +2687,7 @@ +@@ -3031,7 +3026,7 @@ CreateProcess(NULL, wpath, NULL, NULL, false, NORMAL_PRIORITY_CLASS, NULL, NULL, &si, &pi);
#endif
#if OGRE_PLATFORM == OGRE_PLATFORM_LINUX
diff --git a/games/rigsofrods/files/patch-dependencies-CMakeLists.txt b/games/rigsofrods/files/patch-dependencies-CMakeLists.txt index 53c2fbfe7662..2a7701a79790 100644 --- a/games/rigsofrods/files/patch-dependencies-CMakeLists.txt +++ b/games/rigsofrods/files/patch-dependencies-CMakeLists.txt @@ -1,20 +1,18 @@ ---- dependencies/CMakeLists.txt.orig 2009-02-22 20:59:55.000000000 +0300 -+++ dependencies/CMakeLists.txt 2009-03-05 03:49:28.000000000 +0300 -@@ -6,9 +6,9 @@ +--- dependencies/CMakeLists.txt.orig 2009-06-28 01:05:16.000000000 +0400 ++++ dependencies/CMakeLists.txt 2009-08-12 23:52:12.000000000 +0400 +@@ -6,9 +6,7 @@ endif(ROR_BUILD_LUASCRIPT)
add_subdirectory("mysocketw")
-add_subdirectory("OIS-HEAD")
-+#add_subdirectory("OIS-HEAD")
#add_subdirectory("openal-soft-1.5.304")
-add_subdirectory("openal-soft-1.6.372")
-+#add_subdirectory("openal-soft-1.6.372")
set(OGRE_SET_DISABLE_FREEIMAGE 1)
add_subdirectory("ogrenew")
-@@ -34,4 +34,4 @@ - add_subdirectory("raknet")
- endif(ROR_BUILD_NEWNET)
+@@ -30,4 +28,4 @@ +
+ add_subdirectory("moFileReader")
-add_subdirectory("mygui") \ No newline at end of file diff --git a/games/rigsofrods/files/patch-dependencies-angelscript-source-as_config.h b/games/rigsofrods/files/patch-dependencies-angelscript-source-as_config.h new file mode 100644 index 000000000000..fbd407c5e80d --- /dev/null +++ b/games/rigsofrods/files/patch-dependencies-angelscript-source-as_config.h @@ -0,0 +1,10 @@ +--- dependencies/angelscript/source/as_config.h.orig 2009-08-13 00:22:24.000000000 +0400 ++++ dependencies/angelscript/source/as_config.h 2009-08-13 00:22:44.000000000 +0400 +@@ -470,6 +470,7 @@ + #define AS_MAX_PORTABILITY
+ #endif
+ #define AS_POSIX_THREADS
++ #define AS_NO_ATOMIC
+
+ // PSP and PS2
+ #elif defined(__PSP__) || defined(__psp__) || defined(_EE_) || defined(_PSP) || defined(_PS2)
diff --git a/games/rigsofrods/files/patch-dependencies-angelscript-source-as_thread.cpp b/games/rigsofrods/files/patch-dependencies-angelscript-source-as_thread.cpp new file mode 100644 index 000000000000..2de6b7babff3 --- /dev/null +++ b/games/rigsofrods/files/patch-dependencies-angelscript-source-as_thread.cpp @@ -0,0 +1,62 @@ +--- dependencies/angelscript/source/as_thread.cpp.orig 2008-11-20 00:40:26.000000000 +0300 ++++ dependencies/angelscript/source/as_thread.cpp 2009-08-13 07:15:41.000000000 +0400 +@@ -94,7 +94,7 @@ + ENTERCRITICALSECTION(criticalSection);
+
+ // Delete all thread local datas
+- asSMapNode<asDWORD,asCThreadLocalData*> *cursor = 0;
++ asSMapNode<pthread_t,asCThreadLocalData*> *cursor = 0;
+ if( tldMap.MoveFirst(&cursor) )
+ {
+ do
+@@ -121,14 +121,14 @@ + #ifndef AS_NO_THREADS
+ int r = 0;
+ #if defined AS_POSIX_THREADS
+- asDWORD id = (asDWORD)pthread_self();
++ pthread_t id = pthread_self();
+ #elif defined AS_WINDOWS_THREADS
+ asDWORD id = GetCurrentThreadId();
+ #endif
+
+ ENTERCRITICALSECTION(criticalSection);
+
+- asSMapNode<asDWORD,asCThreadLocalData*> *cursor = 0;
++ asSMapNode<pthread_t,asCThreadLocalData*> *cursor = 0;
+ if( tldMap.MoveTo(&cursor, id) )
+ {
+ asCThreadLocalData *tld = tldMap.GetValue(cursor);
+@@ -163,13 +163,13 @@ + }
+
+ #ifndef AS_NO_THREADS
+-asCThreadLocalData *asCThreadManager::GetLocalData(asDWORD threadId)
++asCThreadLocalData *asCThreadManager::GetLocalData(pthread_t threadId)
+ {
+ asCThreadLocalData *tld = 0;
+
+ ENTERCRITICALSECTION(criticalSection);
+
+- asSMapNode<asDWORD,asCThreadLocalData*> *cursor = 0;
++ asSMapNode<pthread_t,asCThreadLocalData*> *cursor = 0;
+ if( tldMap.MoveTo(&cursor, threadId) )
+ tld = tldMap.GetValue(cursor);
+
+@@ -178,7 +178,7 @@ + return tld;
+ }
+
+-void asCThreadManager::SetLocalData(asDWORD threadId, asCThreadLocalData *tld)
++void asCThreadManager::SetLocalData(pthread_t threadId, asCThreadLocalData *tld)
+ {
+ ENTERCRITICALSECTION(criticalSection);
+
+@@ -192,7 +192,7 @@ + {
+ #ifndef AS_NO_THREADS
+ #if defined AS_POSIX_THREADS
+- asDWORD id = (asDWORD)pthread_self();
++ pthread_t id = pthread_self();
+ #elif defined AS_WINDOWS_THREADS
+ asDWORD id = GetCurrentThreadId();
+ #endif
diff --git a/games/rigsofrods/files/patch-dependencies-angelscript-source-as_thread.h b/games/rigsofrods/files/patch-dependencies-angelscript-source-as_thread.h new file mode 100644 index 000000000000..8d6a3a33a944 --- /dev/null +++ b/games/rigsofrods/files/patch-dependencies-angelscript-source-as_thread.h @@ -0,0 +1,16 @@ +--- dependencies/angelscript/source/as_thread.h.orig 2008-11-20 00:40:34.000000000 +0300 ++++ dependencies/angelscript/source/as_thread.h 2009-08-13 07:12:32.000000000 +0400 +@@ -66,10 +66,10 @@ + asCAtomic refCount;
+
+ #ifndef AS_NO_THREADS
+- asCThreadLocalData *GetLocalData(asDWORD threadId);
+- void SetLocalData(asDWORD threadId, asCThreadLocalData *tld);
++ asCThreadLocalData *GetLocalData(pthread_t threadId);
++ void SetLocalData(pthread_t threadId, asCThreadLocalData *tld);
+
+- asCMap<asDWORD,asCThreadLocalData*> tldMap;
++ asCMap<pthread_t,asCThreadLocalData*> tldMap;
+ DECLARECRITICALSECTION(criticalSection);
+ #else
+ asCThreadLocalData *tld;
diff --git a/games/rigsofrods/files/patch-dependencies-mygui-CMakeLists.txt b/games/rigsofrods/files/patch-dependencies-mygui-CMakeLists.txt index 28cb009312a6..637f60acbccf 100644 --- a/games/rigsofrods/files/patch-dependencies-mygui-CMakeLists.txt +++ b/games/rigsofrods/files/patch-dependencies-mygui-CMakeLists.txt @@ -1,5 +1,5 @@ ---- dependencies/mygui/CMakeLists.txt.orig 2009-02-22 20:59:55.000000000 +0300 -+++ dependencies/mygui/CMakeLists.txt 2009-03-05 05:39:37.000000000 +0300 +--- dependencies/mygui/CMakeLists.txt.orig 2009-02-09 02:31:54.000000000 +0300 ++++ dependencies/mygui/CMakeLists.txt 2009-08-12 23:54:50.000000000 +0400 @@ -4,8 +4,9 @@ include_directories (include)
diff --git a/games/rigsofrods/files/patch-dependencies-ogrenew-OgreMain-CMakeLists.txt b/games/rigsofrods/files/patch-dependencies-ogrenew-OgreMain-CMakeLists.txt index fdee2df2b828..ac4f33475f64 100644 --- a/games/rigsofrods/files/patch-dependencies-ogrenew-OgreMain-CMakeLists.txt +++ b/games/rigsofrods/files/patch-dependencies-ogrenew-OgreMain-CMakeLists.txt @@ -1,5 +1,5 @@ ---- dependencies/ogrenew/OgreMain/CMakeLists.txt.orig 2009-02-22 20:59:55.000000000 +0300 -+++ dependencies/ogrenew/OgreMain/CMakeLists.txt 2009-03-05 05:36:44.000000000 +0300 +--- dependencies/ogrenew/OgreMain/CMakeLists.txt.orig 2009-02-19 19:05:28.000000000 +0300 ++++ dependencies/ogrenew/OgreMain/CMakeLists.txt 2009-08-12 23:55:37.000000000 +0400 @@ -449,7 +449,7 @@ set(PLATFORM_LIBS ${X11_LIBRARIES} ${X11_Xt_LIB} ${XAW_LIBRARY})
set(PLATFORM_HEADER_INSTALL "GLX")
diff --git a/games/rigsofrods/files/patch-dependencies-ogrenew-OgreMain-include-OgreAxisAlignedBox.h b/games/rigsofrods/files/patch-dependencies-ogrenew-OgreMain-include-OgreAxisAlignedBox.h index 2561f354cd3c..e73ca0e86ae8 100644 --- a/games/rigsofrods/files/patch-dependencies-ogrenew-OgreMain-include-OgreAxisAlignedBox.h +++ b/games/rigsofrods/files/patch-dependencies-ogrenew-OgreMain-include-OgreAxisAlignedBox.h @@ -1,13 +1,12 @@ ---- dependencies/ogrenew/OgreMain/include/OgreAxisAlignedBox.h.orig 2009-02-22 20:59:55.000000000 +0300 -+++ dependencies/ogrenew/OgreMain/include/OgreAxisAlignedBox.h 2009-04-08 05:57:39.000000000 +0400 -@@ -235,8 +235,8 @@ +--- dependencies/ogrenew/OgreMain/include/OgreAxisAlignedBox.h.orig 2009-02-09 02:40:02.000000000 +0300 ++++ dependencies/ogrenew/OgreMain/include/OgreAxisAlignedBox.h 2009-08-13 04:16:09.000000000 +0400 +@@ -235,9 +235,6 @@ */ inline void setExtents( const Vector3& min, const Vector3& max ) { - assert( (min.x <= max.x && min.y <= max.y && min.z <= max.z) && - "The minimum corner of the box must be less than or equal to maximum corner" ); -+// assert( (min.x <= max.x && min.y <= max.y && min.z <= max.z) && -+// "The minimum corner of the box must be less than or equal to maximum corner" ); - +- mExtent = EXTENT_FINITE; mMinimum = min; + mMaximum = max; diff --git a/games/rigsofrods/files/patch-dependencies-ogrenew-RenderSystems-GL-CMakeLists.txt b/games/rigsofrods/files/patch-dependencies-ogrenew-RenderSystems-GL-CMakeLists.txt index 2ba581700064..7c2f8c7ddf35 100644 --- a/games/rigsofrods/files/patch-dependencies-ogrenew-RenderSystems-GL-CMakeLists.txt +++ b/games/rigsofrods/files/patch-dependencies-ogrenew-RenderSystems-GL-CMakeLists.txt @@ -1,5 +1,5 @@ ---- dependencies/ogrenew/RenderSystems/GL/CMakeLists.txt.orig 2009-02-22 20:59:55.000000000 +0300 -+++ dependencies/ogrenew/RenderSystems/GL/CMakeLists.txt 2009-03-05 04:57:40.000000000 +0300 +--- dependencies/ogrenew/RenderSystems/GL/CMakeLists.txt.orig 2009-02-09 02:40:28.000000000 +0300 ++++ dependencies/ogrenew/RenderSystems/GL/CMakeLists.txt 2009-08-12 23:57:24.000000000 +0400 @@ -157,16 +157,19 @@ src/GLX/OgreGLXWindow.cpp src/GLX/OgreGLXUtils.cpp diff --git a/games/rigsofrods/files/patch-dependencies-ogrenew-RenderSystems-GL-src-GLX-OgreGLXGLSupport.cpp b/games/rigsofrods/files/patch-dependencies-ogrenew-RenderSystems-GL-src-GLX-OgreGLXGLSupport.cpp new file mode 100644 index 000000000000..b5e4fb3a15b6 --- /dev/null +++ b/games/rigsofrods/files/patch-dependencies-ogrenew-RenderSystems-GL-src-GLX-OgreGLXGLSupport.cpp @@ -0,0 +1,10 @@ +--- dependencies/ogrenew/RenderSystems/GL/src/GLX/OgreGLXGLSupport.cpp.orig 2009-02-09 02:40:24.000000000 +0300 ++++ dependencies/ogrenew/RenderSystems/GL/src/GLX/OgreGLXGLSupport.cpp 2009-08-13 06:36:28.000000000 +0400 +@@ -73,6 +73,7 @@ + optVideoMode.possibleValues.push_back("1280 x 960"); + optVideoMode.possibleValues.push_back("1280 x 1024"); + optVideoMode.possibleValues.push_back("1600 x 1200"); ++ optVideoMode.possibleValues.push_back("1920 x 1080"); + + optVideoMode.currentValue = "800 x 600"; + diff --git a/games/rigsofrods/files/patch-main-CMakeLists.txt b/games/rigsofrods/files/patch-main-CMakeLists.txt index 792e0782bf7e..bb705c0ef8ff 100644 --- a/games/rigsofrods/files/patch-main-CMakeLists.txt +++ b/games/rigsofrods/files/patch-main-CMakeLists.txt @@ -1,6 +1,6 @@ ---- main/CMakeLists.txt.orig 2009-02-22 20:59:55.000000000 +0300 -+++ main/CMakeLists.txt 2009-03-06 03:01:23.000000000 +0300 -@@ -12,12 +12,13 @@ +--- main/CMakeLists.txt.orig 2009-06-28 01:01:10.000000000 +0400 ++++ main/CMakeLists.txt 2009-08-13 19:20:44.000000000 +0400 +@@ -170,11 +170,12 @@ include_directories (${RoR_Dependencies_SOURCE_DIR}/Caelum-2006-11-09/include)
endif(CAELUM_BUILD_NEW)
@@ -8,7 +8,6 @@ -include_directories (${RoR_Dependencies_SOURCE_DIR}/openal-soft-1.6.372/include)
-include_directories (${RoR_Dependencies_SOURCE_DIR}/OIS-HEAD/ois/includes)
include_directories (${RoR_Dependencies_SOURCE_DIR}/moFileReader/include)
- include_directories (${RoR_Dependencies_SOURCE_DIR}/rorserver-sf/source)
include_directories (${RoR_Dependencies_SOURCE_DIR}/mygui/include)
+include_directories (${LOCALBASE}/include/OIS)
+include_directories (${LOCALBASE}/include/AL)
@@ -17,8 +16,8 @@ IF(WIN32)
add_definitions("-D_CRT_SECURE_NO_WARNINGS")
-@@ -98,7 +99,7 @@ - add_executable(RoR ${ror_src} source/icon.rc)
+@@ -269,7 +270,7 @@ + add_executable(RoR ${ror_src})
# add dependencies
-add_dependencies(RoR OgreMain caelum mysocketw ois mygui mofilereader)
@@ -26,7 +25,7 @@ # optional features
if(ROR_BUILD_HYDRAX)
-@@ -132,7 +133,6 @@ +@@ -299,7 +300,6 @@ caelum
mysocketw
OgreMain
@@ -34,35 +33,21 @@ mygui
mofilereader
)
-@@ -152,9 +152,8 @@ -
+@@ -317,7 +317,7 @@ target_link_libraries(RoR openal32)
ELSEIF(UNIX)
-- SET_TARGET_PROPERTIES(RoR PROPERTIES COMPILE_FLAGS "-msse2 -msse2 -mmmx -msse -msse3 -mssse3 -m3dnow")
-+ SET_TARGET_PROPERTIES(RoR PROPERTIES COMPILE_FLAGS "-msse2 -msse2 -mmmx -msse -msse3 -m3dnow")
- SET_TARGET_PROPERTIES(RoR PROPERTIES LINK_FLAGS "")
-- target_link_libraries(RoR openal)
+ SET_TARGET_PROPERTIES(RoR PROPERTIES COMPILE_FLAGS "-msse2 -msse2 -mmmx -msse -msse3 -m3dnow")
+- SET_TARGET_PROPERTIES(RoR PROPERTIES LINK_FLAGS "")
++ SET_TARGET_PROPERTIES(RoR PROPERTIES LINK_FLAGS "-L${LOCALBASE}/lib")
+ target_link_libraries(RoR openal)
ELSEIF(APPLE)
ENDIF(WIN32)
-
-@@ -191,12 +190,14 @@ - ELSEIF(UNIX)
- target_link_libraries(RoR
- # /usr/lib/libossp-uuid_dce.so
-- /usr/lib/libzzip.so
-- /usr/lib/libfreetype.so
-- /usr/lib/libX11.so
-- /usr/lib/libXt.so
--
-- /usr/lib/libXaw.so
-+ ${LOCALBASE}/lib/libzzip.so
-+ ${LOCALBASE}/lib/libfreetype.so
-+ ${LOCALBASE}/lib/libX11.so
-+ ${LOCALBASE}/lib/libXt.so
-+
-+ ${LOCALBASE}/lib/libXaw.so
-+ ${LOCALBASE}/lib/libOIS.so
-+ ${LOCALBASE}/lib/libopenal.so
+@@ -369,6 +369,8 @@ + X11
+ Xt
+ Xaw
++ OIS
++ openal
)
ELSEIF(APPLE)
ENDIF(WIN32)
diff --git a/games/rigsofrods/files/patch-main-source-Beam.cpp b/games/rigsofrods/files/patch-main-source-Beam.cpp index e12ab89b74af..25504ca697b7 100644 --- a/games/rigsofrods/files/patch-main-source-Beam.cpp +++ b/games/rigsofrods/files/patch-main-source-Beam.cpp @@ -1,10 +1,16 @@ ---- main/source/Beam.cpp.orig 2009-02-22 20:59:55.000000000 +0300 -+++ main/source/Beam.cpp 2009-03-07 17:36:32.000000000 +0300 -@@ -293,6 +293,7 @@ - - } - #endif -+ skidNode = 0; - - collisions=icollisions; - +--- main/source/Beam.cpp.orig 2009-06-28 04:39:08.000000000 +0400 ++++ main/source/Beam.cpp 2009-08-13 06:02:41.000000000 +0400 +@@ -425,11 +425,8 @@ +
+ // skidmark stuff
+ useSkidmarks = (SETTINGS.getSetting("Skidmarks") == "Yes");
+- if (useSkidmarks)
+- {
+- for(int i=0; i<MAX_WHEELS*2; i++)
+- skidtrails[i] = 0;
+- }
++ for(int i=0; i<MAX_WHEELS*2; i++)
++ skidtrails[i] = 0;
+
+ collisions=icollisions;
+
diff --git a/games/rigsofrods/files/patch-main-source-InputEngine.cpp b/games/rigsofrods/files/patch-main-source-InputEngine.cpp index 54f6515f0658..17b845af45eb 100644 --- a/games/rigsofrods/files/patch-main-source-InputEngine.cpp +++ b/games/rigsofrods/files/patch-main-source-InputEngine.cpp @@ -1,35 +1,43 @@ ---- main/source/InputEngine.cpp.orig 2009-02-22 20:59:55.000000000 +0300 -+++ main/source/InputEngine.cpp 2009-03-06 02:56:37.000000000 +0300 -@@ -46,10 +46,10 @@ - #define OIS_DYNAMIC_LIB - #include <OIS.h> - --#if OGRE_PLATFORM == OGRE_PLATFORM_LINUX --#include <X11/Xlib.h> --#include <linux/LinuxMouse.h> --#endif -+//#if OGRE_PLATFORM == OGRE_PLATFORM_LINUX -+//#include <X11/Xlib.h> -+//#include <linux/LinuxMouse.h> -+//#endif - - using namespace std; - using namespace Ogre; -@@ -204,7 +204,7 @@ - if((enable && lastmode == 0) || (!enable && lastmode == 1) || (lastmode == -1)) - { - LogManager::getSingleton().logMessage("*** mouse grab: " + StringConverter::toString(enable)); -- ((LinuxMouse *)mMouse)->grab(enable); -+ //((LinuxMouse *)mMouse)->grab(enable); - lastmode = enable?1:0; - } - #endif -@@ -218,7 +218,7 @@ - #if OGRE_PLATFORM == OGRE_PLATFORM_LINUX - if((visible && mode == 0) || (!visible && mode == 1) || mode == -1) - { -- ((LinuxMouse *)mMouse)->hide(visible); -+ //((LinuxMouse *)mMouse)->hide(visible); - mode = visible?1:0; - } - #endif +--- main/source/InputEngine.cpp.orig 2009-06-20 11:17:44.000000000 +0400 ++++ main/source/InputEngine.cpp 2009-08-13 00:37:23.000000000 +0400 +@@ -1408,11 +1408,6 @@ + #define OIS_DYNAMIC_LIB
+ #include <OIS.h>
+
+-#if OGRE_PLATFORM == OGRE_PLATFORM_LINUX
+-#include <X11/Xlib.h>
+-#include <linux/LinuxMouse.h>
+-#endif
+-
+ #ifndef NOOGRE
+ #include "ogreconsole.h"
+ #endif
+@@ -1615,14 +1610,6 @@ + static int lastmode = -1;
+ if(!mMouse)
+ return;
+-#if OGRE_PLATFORM == OGRE_PLATFORM_LINUX
+- if((enable && lastmode == 0) || (!enable && lastmode == 1) || (lastmode == -1))
+- {
+- LogManager::getSingleton().logMessage("*** mouse grab: " + StringConverter::toString(enable));
+- ((LinuxMouse *)mMouse)->grab(enable);
+- lastmode = enable?1:0;
+- }
+-#endif
+ }
+
+ void InputEngine::hideMouse(bool visible)
+@@ -1630,13 +1617,6 @@ + static int mode = -1;
+ if(!mMouse)
+ return;
+-#if OGRE_PLATFORM == OGRE_PLATFORM_LINUX
+- if((visible && mode == 0) || (!visible && mode == 1) || mode == -1)
+- {
+- ((LinuxMouse *)mMouse)->hide(visible);
+- mode = visible?1:0;
+- }
+-#endif
+ }
+
+ void InputEngine::setMousePosition(int x, int y, bool padding)
diff --git a/games/rigsofrods/files/patch-main-source-Settings.cpp b/games/rigsofrods/files/patch-main-source-Settings.cpp index 50c6c9a5a671..6b557a701c58 100644 --- a/games/rigsofrods/files/patch-main-source-Settings.cpp +++ b/games/rigsofrods/files/patch-main-source-Settings.cpp @@ -1,22 +1,22 @@ ---- main/source/Settings.cpp.orig 2009-02-22 20:59:55.000000000 +0300 -+++ main/source/Settings.cpp 2009-04-09 07:24:33.000000000 +0400 -@@ -123,17 +123,10 @@ - //true program path is impossible to get from POSIX functions - //lets hack! - pid_t pid = getpid(); -- char procpath[256]; -- sprintf(procpath, "/proc/%d/exe", pid); -- int ch = readlink(procpath,program_path,240); -- if (ch != -1) -- { -- program_path[ch] = 0; -- path_descend(program_path); -- } else return false; -+ strcpy(program_path, "%%DATADIR%%/"); - //user path is easy - strncpy(user_path, getenv ("HOME"), 240); -- sprintf(user_path, "%s/RigsOfRods/", user_path); -+ sprintf(user_path, "%s/.RigsOfRods/", user_path); - #elif OGRE_PLATFORM == OGRE_PLATFORM_APPLE - //found this code, will look later - std::string path = "./"; +--- main/source/Settings.cpp.orig 2009-06-17 00:15:08.000000000 +0400 ++++ main/source/Settings.cpp 2009-08-13 04:10:33.000000000 +0400 +@@ -132,17 +132,10 @@ + //true program path is impossible to get from POSIX functions
+ //lets hack!
+ pid_t pid = getpid();
+- char procpath[256];
+- sprintf(procpath, "/proc/%d/exe", pid);
+- int ch = readlink(procpath,program_path,240);
+- if (ch != -1)
+- {
+- program_path[ch] = 0;
+- path_descend(program_path);
+- } else return false;
++ strcpy(program_path, "%%DATADIR%%/");
+ //user path is easy
+ strncpy(user_path, getenv ("HOME"), 240);
+- sprintf(user_path, "%s/RigsOfRods/", user_path);
++ sprintf(user_path, "%s/.RigsOfRods/", user_path);
+ #elif OGRE_PLATFORM == OGRE_PLATFORM_APPLE
+ //found this code, will look later
+ std::string path = "./";
diff --git a/games/rigsofrods/files/patch-main-source-pstdint.h b/games/rigsofrods/files/patch-main-source-pstdint.h new file mode 100644 index 000000000000..96c3f9569a7f --- /dev/null +++ b/games/rigsofrods/files/patch-main-source-pstdint.h @@ -0,0 +1,11 @@ +--- main/source/pstdint.h.orig 2009-08-13 00:27:11.000000000 +0400 ++++ main/source/pstdint.h 2009-08-13 00:27:29.000000000 +0400 +@@ -199,7 +199,7 @@ + * do nothing else. On the Mac OS X version of gcc this is _STDINT_H_.
+ */
+
+-#if ((defined(__STDC__) && __STDC__ && __STDC_VERSION__ >= 199901L) || (defined (__WATCOMC__) && (defined (_STDINT_H_INCLUDED) || __WATCOMC__ >= 1250)) || (defined(__GNUC__) && (defined(_STDINT_H) || defined(_STDINT_H_)) )) && !defined (_PSTDINT_H_INCLUDED)
++#if !defined (_PSTDINT_H_INCLUDED)
+ #include <stdint.h>
+ #define _PSTDINT_H_INCLUDED
+ # ifndef PRINTF_INT64_MODIFIER
diff --git a/games/rigsofrods/pkg-plist b/games/rigsofrods/pkg-plist index b52fa3fc6e12..886addcb72a2 100644 --- a/games/rigsofrods/pkg-plist +++ b/games/rigsofrods/pkg-plist @@ -12,99 +12,78 @@ libexec/rigsofrods/RoR libexec/rigsofrods/rorconfig %%DATADIR%%/languages/ar/codes.txt %%DATADIR%%/languages/ar/ror.mo -%%DATADIR%%/languages/ar/ror.po %%DATADIR%%/languages/bg/codes.txt %%DATADIR%%/languages/bg/ror.mo -%%DATADIR%%/languages/bg/ror.po %%DATADIR%%/languages/bn/codes.txt %%DATADIR%%/languages/bn/ror.mo -%%DATADIR%%/languages/bn/ror.po +%%DATADIR%%/languages/ca/codes.txt +%%DATADIR%%/languages/ca/ror.mo %%DATADIR%%/languages/cs/codes.txt %%DATADIR%%/languages/cs/ror.mo -%%DATADIR%%/languages/cs/ror.po %%DATADIR%%/languages/da/codes.txt %%DATADIR%%/languages/da/ror.mo -%%DATADIR%%/languages/da/ror.po %%DATADIR%%/languages/de/codes.txt %%DATADIR%%/languages/de/ror.mo -%%DATADIR%%/languages/de/ror.po %%DATADIR%%/languages/el/codes.txt %%DATADIR%%/languages/el/ror.mo -%%DATADIR%%/languages/el/ror.po %%DATADIR%%/languages/en/codes.txt %%DATADIR%%/languages/en/ror.mo -%%DATADIR%%/languages/en/ror.po %%DATADIR%%/languages/es/codes.txt %%DATADIR%%/languages/es/ror.mo -%%DATADIR%%/languages/es/ror.po %%DATADIR%%/languages/et/codes.txt %%DATADIR%%/languages/et/ror.mo -%%DATADIR%%/languages/et/ror.po %%DATADIR%%/languages/fi/codes.txt %%DATADIR%%/languages/fi/ror.mo -%%DATADIR%%/languages/fi/ror.po %%DATADIR%%/languages/fr/codes.txt %%DATADIR%%/languages/fr/ror.mo -%%DATADIR%%/languages/fr/ror.po +%%DATADIR%%/languages/he/codes.txt +%%DATADIR%%/languages/he/ror.mo %%DATADIR%%/languages/hi/codes.txt %%DATADIR%%/languages/hi/ror.mo -%%DATADIR%%/languages/hi/ror.po %%DATADIR%%/languages/hu/codes.txt %%DATADIR%%/languages/hu/ror.mo -%%DATADIR%%/languages/hu/ror.po %%DATADIR%%/languages/id/codes.txt %%DATADIR%%/languages/id/ror.mo -%%DATADIR%%/languages/id/ror.po %%DATADIR%%/languages/is/codes.txt %%DATADIR%%/languages/is/ror.mo -%%DATADIR%%/languages/is/ror.po %%DATADIR%%/languages/it/codes.txt %%DATADIR%%/languages/it/ror.mo -%%DATADIR%%/languages/it/ror.po %%DATADIR%%/languages/ja/codes.txt -%%DATADIR%%/languages/ja/ror.po +%%DATADIR%%/languages/ja/ror.mo %%DATADIR%%/languages/la/codes.txt %%DATADIR%%/languages/la/ror.mo -%%DATADIR%%/languages/la/ror.po %%DATADIR%%/languages/lt/codes.txt %%DATADIR%%/languages/lt/ror.mo -%%DATADIR%%/languages/lt/ror.po +%%DATADIR%%/languages/lv/codes.txt +%%DATADIR%%/languages/lv/ror.mo +%%DATADIR%%/languages/nb/codes.txt +%%DATADIR%%/languages/nb/ror.mo %%DATADIR%%/languages/nl/codes.txt %%DATADIR%%/languages/nl/ror.mo -%%DATADIR%%/languages/nl/ror.po %%DATADIR%%/languages/nn/codes.txt %%DATADIR%%/languages/nn/ror.mo -%%DATADIR%%/languages/nn/ror.po +%%DATADIR%%/languages/no/codes.txt +%%DATADIR%%/languages/no/ror.mo %%DATADIR%%/languages/pl/codes.txt %%DATADIR%%/languages/pl/ror.mo -%%DATADIR%%/languages/pl/ror.po %%DATADIR%%/languages/pt/codes.txt %%DATADIR%%/languages/pt/ror.mo -%%DATADIR%%/languages/pt/ror.po %%DATADIR%%/languages/ro/codes.txt %%DATADIR%%/languages/ro/ror.mo -%%DATADIR%%/languages/ro/ror.po %%DATADIR%%/languages/ru/codes.txt %%DATADIR%%/languages/ru/ror.mo -%%DATADIR%%/languages/ru/ror.po %%DATADIR%%/languages/sk/codes.txt %%DATADIR%%/languages/sk/ror.mo -%%DATADIR%%/languages/sk/ror.po %%DATADIR%%/languages/sl/codes.txt %%DATADIR%%/languages/sl/ror.mo -%%DATADIR%%/languages/sl/ror.po %%DATADIR%%/languages/sv/codes.txt %%DATADIR%%/languages/sv/ror.mo -%%DATADIR%%/languages/sv/ror.po %%DATADIR%%/languages/tr/codes.txt %%DATADIR%%/languages/tr/ror.mo -%%DATADIR%%/languages/tr/ror.po %%DATADIR%%/languages/ur/codes.txt %%DATADIR%%/languages/ur/ror.mo -%%DATADIR%%/languages/ur/ror.po %%DATADIR%%/languages/zh/codes.txt %%DATADIR%%/languages/zh/ror.mo -%%DATADIR%%/languages/zh/ror.po %%DATADIR%%/plugins.cfg %%DATADIR%%/resources/OgreCore.zip %%DATADIR%%/resources/airfoils.zip @@ -118,6 +97,7 @@ libexec/rigsofrods/rorconfig %%DATADIR%%/resources/scripts.zip %%DATADIR%%/resources/sounds.zip %%DATADIR%%/resources/textures.zip +%%DATADIR%%/skeleton/cache/.do.not.delete %%DATADIR%%/skeleton/config/RoR.cfg %%DATADIR%%/skeleton/config/categories.cfg %%DATADIR%%/skeleton/config/editor.cfg @@ -125,7 +105,12 @@ libexec/rigsofrods/rorconfig %%DATADIR%%/skeleton/config/input.map %%DATADIR%%/skeleton/config/inputevents.cfg %%DATADIR%%/skeleton/config/ogre.cfg +%%DATADIR%%/skeleton/config/torque_models.cfg %%DATADIR%%/skeleton/config/wavefield.cfg +%%DATADIR%%/skeleton/logs/.do.not.delete +%%DATADIR%%/skeleton/packs/.do.not.delete +%%DATADIR%%/skeleton/terrains/.do.not.delete +%%DATADIR%%/skeleton/vehicles/.do.not.delete %%DATADIR%%/streams/final/terrains/BajaTrack.zip %%DATADIR%%/streams/final/terrains/BakersRanch.zip %%DATADIR%%/streams/final/terrains/Flatmap.zip @@ -201,8 +186,11 @@ libexec/rigsofrods/rorconfig @dirrm %%DATADIR%%/languages/ro @dirrm %%DATADIR%%/languages/pt @dirrm %%DATADIR%%/languages/pl +@dirrm %%DATADIR%%/languages/no @dirrm %%DATADIR%%/languages/nn @dirrm %%DATADIR%%/languages/nl +@dirrm %%DATADIR%%/languages/nb +@dirrm %%DATADIR%%/languages/lv @dirrm %%DATADIR%%/languages/lt @dirrm %%DATADIR%%/languages/la @dirrm %%DATADIR%%/languages/ja @@ -211,6 +199,7 @@ libexec/rigsofrods/rorconfig @dirrm %%DATADIR%%/languages/id @dirrm %%DATADIR%%/languages/hu @dirrm %%DATADIR%%/languages/hi +@dirrm %%DATADIR%%/languages/he @dirrm %%DATADIR%%/languages/fr @dirrm %%DATADIR%%/languages/fi @dirrm %%DATADIR%%/languages/et @@ -220,6 +209,7 @@ libexec/rigsofrods/rorconfig @dirrm %%DATADIR%%/languages/de @dirrm %%DATADIR%%/languages/da @dirrm %%DATADIR%%/languages/cs +@dirrm %%DATADIR%%/languages/ca @dirrm %%DATADIR%%/languages/bn @dirrm %%DATADIR%%/languages/bg @dirrm %%DATADIR%%/languages/ar |