aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2017-03-01 02:02:59 +0800
committeracm <acm@FreeBSD.org>2017-03-01 02:02:59 +0800
commit26c991af69c3659a3988ea9e252bd131811577ed (patch)
tree653144e0451ec8e490e7e1751aaea6ad5746d4cc
parent2bfddf207c3db16a62dd6668f2320512d6f87893 (diff)
downloadfreebsd-ports-gnome-26c991af69c3659a3988ea9e252bd131811577ed.tar.gz
freebsd-ports-gnome-26c991af69c3659a3988ea9e252bd131811577ed.tar.zst
freebsd-ports-gnome-26c991af69c3659a3988ea9e252bd131811577ed.zip
- New port: devel/dub
DUB emerged as a more general replacement for vibe.d's package manager. It does not imply a dependency to vibe.d for packages and was extended to not only directly build projects, but also to generate project files (currently VisualD). Mono-D also supports the use of dub.json (dub's package description) as the project file. The project's philosophy is to keep things as simple as possible. All that is needed to make a project a dub package is to write a short dub.json file and put the source code into a source subfolder. It can then be registered on the public package registry to be made available for everyone. Any dependencies specified in dub.json are automatically downloaded and made available to the project during the build process. WWW: https://github.com/dlang/dub
-rw-r--r--devel/Makefile1
-rw-r--r--devel/dub/Makefile29
-rw-r--r--devel/dub/distinfo3
-rw-r--r--devel/dub/pkg-descr15
4 files changed, 48 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 69672b50eaff..40c40630205f 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -426,6 +426,7 @@
SUBDIR += dreampie
SUBDIR += drpython
SUBDIR += ds2
+ SUBDIR += dub
SUBDIR += dulwich
SUBDIR += duplo
SUBDIR += dwarfdump
diff --git a/devel/dub/Makefile b/devel/dub/Makefile
new file mode 100644
index 000000000000..3af2e61a93d3
--- /dev/null
+++ b/devel/dub/Makefile
@@ -0,0 +1,29 @@
+# $FreeBSD$
+
+PORTNAME= dub
+PORTVERSION= 1.2.1
+CATEGORIES= devel
+MASTER_SITES= https://github.com/dlang/dub/archive/
+DISTFILES= v${PORTVERSION}.tar.gz
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Package and build manager for D applications and libraries
+
+BUILD_DEPENDS= ldmd2:lang/ldc
+LIB_DEPENDS= libcurl.so:ftp/curl
+
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+PLIST_FILES= bin/${PORTNAME} \
+ %%DATADIR%%/LICENSE
+
+do-build:
+ @cd ${WRKSRC} && ${SH} build.sh
+
+do-install:
+ @${MKDIR} ${STAGEDIR}/${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${STAGEDIR}/${PREFIX}/bin/${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/LICENSE.txt ${STAGEDIR}/${DATADIR}/LICENSE
+
+.include <bsd.port.mk>
diff --git a/devel/dub/distinfo b/devel/dub/distinfo
new file mode 100644
index 000000000000..e84c534afc46
--- /dev/null
+++ b/devel/dub/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1488296336
+SHA256 (dub/v1.2.1.tar.gz) = e880cf9ca6234f751a53a427eba71b8d5585b6b660d6a489458f638d2ff60554
+SIZE (dub/v1.2.1.tar.gz) = 1139223
diff --git a/devel/dub/pkg-descr b/devel/dub/pkg-descr
new file mode 100644
index 000000000000..f5573c94ab3d
--- /dev/null
+++ b/devel/dub/pkg-descr
@@ -0,0 +1,15 @@
+DUB emerged as a more general replacement for vibe.d's package manager. It does
+not imply a dependency to vibe.d for packages and was extended to not only
+directly build projects, but also to generate project files (currently VisualD).
+
+Mono-D also supports the use of dub.json (dub's package description) as the
+project file.
+
+The project's philosophy is to keep things as simple as possible. All that is
+needed to make a project a dub package is to write a short dub.json file and
+put the source code into a source subfolder. It can then be registered on the
+public package registry to be made available for everyone. Any dependencies
+specified in dub.json are automatically downloaded and made available to the
+project during the build process.
+
+WWW: https://github.com/dlang/dub