aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjmz <jmz@FreeBSD.org>1999-09-21 22:29:02 +0800
committerjmz <jmz@FreeBSD.org>1999-09-21 22:29:02 +0800
commit27de2e1f306057c54b0fd702e120c5a6da40fefb (patch)
treeccd155b6a269c2b401795620dcfe8ce4ec5d4fc7
parent792211724d058eecef35a858acc7de9e50e4aa17 (diff)
downloadfreebsd-ports-gnome-27de2e1f306057c54b0fd702e120c5a6da40fefb.tar.gz
freebsd-ports-gnome-27de2e1f306057c54b0fd702e120c5a6da40fefb.tar.zst
freebsd-ports-gnome-27de2e1f306057c54b0fd702e120c5a6da40fefb.zip
Use @exec/@unexec pairs for symlinks to directories. This should fix
errors with pkg_delete.
-rw-r--r--x11-servers/XFree86-4-Server-snap/pkg-plist6
-rw-r--r--x11-servers/XFree86-4-Server/pkg-plist6
-rw-r--r--x11/XFree86-4-clients/pkg-plist6
-rw-r--r--x11/XFree86-4-libraries/pkg-plist6
-rw-r--r--x11/XFree86-4/pkg-plist6
-rw-r--r--x11/XFree86/pkg-plist6
-rw-r--r--x11/XFree86/pkg-plist.pc986
7 files changed, 28 insertions, 14 deletions
diff --git a/x11-servers/XFree86-4-Server-snap/pkg-plist b/x11-servers/XFree86-4-Server-snap/pkg-plist
index 49015328cae5..8f6cf79a7a3d 100644
--- a/x11-servers/XFree86-4-Server-snap/pkg-plist
+++ b/x11-servers/XFree86-4-Server-snap/pkg-plist
@@ -1269,8 +1269,10 @@ lib/X11/rgb.txt
lib/X11/rstart/commands/@List
lib/X11/rstart/commands/ListContexts
lib/X11/rstart/commands/ListGenericCommands
-lib/X11/rstart/commands/x
-lib/X11/rstart/commands/x11
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x11
+@unexec rm -f %D/lib/X11/rstart/commands/x
+@unexec rm -f %D/lib/X11/rstart/commands/x11
lib/X11/rstart/commands/x11r6/@List
lib/X11/rstart/commands/x11r6/LoadMonitor
lib/X11/rstart/commands/x11r6/Terminal
diff --git a/x11-servers/XFree86-4-Server/pkg-plist b/x11-servers/XFree86-4-Server/pkg-plist
index 49015328cae5..8f6cf79a7a3d 100644
--- a/x11-servers/XFree86-4-Server/pkg-plist
+++ b/x11-servers/XFree86-4-Server/pkg-plist
@@ -1269,8 +1269,10 @@ lib/X11/rgb.txt
lib/X11/rstart/commands/@List
lib/X11/rstart/commands/ListContexts
lib/X11/rstart/commands/ListGenericCommands
-lib/X11/rstart/commands/x
-lib/X11/rstart/commands/x11
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x11
+@unexec rm -f %D/lib/X11/rstart/commands/x
+@unexec rm -f %D/lib/X11/rstart/commands/x11
lib/X11/rstart/commands/x11r6/@List
lib/X11/rstart/commands/x11r6/LoadMonitor
lib/X11/rstart/commands/x11r6/Terminal
diff --git a/x11/XFree86-4-clients/pkg-plist b/x11/XFree86-4-clients/pkg-plist
index 49015328cae5..8f6cf79a7a3d 100644
--- a/x11/XFree86-4-clients/pkg-plist
+++ b/x11/XFree86-4-clients/pkg-plist
@@ -1269,8 +1269,10 @@ lib/X11/rgb.txt
lib/X11/rstart/commands/@List
lib/X11/rstart/commands/ListContexts
lib/X11/rstart/commands/ListGenericCommands
-lib/X11/rstart/commands/x
-lib/X11/rstart/commands/x11
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x11
+@unexec rm -f %D/lib/X11/rstart/commands/x
+@unexec rm -f %D/lib/X11/rstart/commands/x11
lib/X11/rstart/commands/x11r6/@List
lib/X11/rstart/commands/x11r6/LoadMonitor
lib/X11/rstart/commands/x11r6/Terminal
diff --git a/x11/XFree86-4-libraries/pkg-plist b/x11/XFree86-4-libraries/pkg-plist
index 49015328cae5..8f6cf79a7a3d 100644
--- a/x11/XFree86-4-libraries/pkg-plist
+++ b/x11/XFree86-4-libraries/pkg-plist
@@ -1269,8 +1269,10 @@ lib/X11/rgb.txt
lib/X11/rstart/commands/@List
lib/X11/rstart/commands/ListContexts
lib/X11/rstart/commands/ListGenericCommands
-lib/X11/rstart/commands/x
-lib/X11/rstart/commands/x11
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x11
+@unexec rm -f %D/lib/X11/rstart/commands/x
+@unexec rm -f %D/lib/X11/rstart/commands/x11
lib/X11/rstart/commands/x11r6/@List
lib/X11/rstart/commands/x11r6/LoadMonitor
lib/X11/rstart/commands/x11r6/Terminal
diff --git a/x11/XFree86-4/pkg-plist b/x11/XFree86-4/pkg-plist
index 49015328cae5..8f6cf79a7a3d 100644
--- a/x11/XFree86-4/pkg-plist
+++ b/x11/XFree86-4/pkg-plist
@@ -1269,8 +1269,10 @@ lib/X11/rgb.txt
lib/X11/rstart/commands/@List
lib/X11/rstart/commands/ListContexts
lib/X11/rstart/commands/ListGenericCommands
-lib/X11/rstart/commands/x
-lib/X11/rstart/commands/x11
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x11
+@unexec rm -f %D/lib/X11/rstart/commands/x
+@unexec rm -f %D/lib/X11/rstart/commands/x11
lib/X11/rstart/commands/x11r6/@List
lib/X11/rstart/commands/x11r6/LoadMonitor
lib/X11/rstart/commands/x11r6/Terminal
diff --git a/x11/XFree86/pkg-plist b/x11/XFree86/pkg-plist
index 49015328cae5..8f6cf79a7a3d 100644
--- a/x11/XFree86/pkg-plist
+++ b/x11/XFree86/pkg-plist
@@ -1269,8 +1269,10 @@ lib/X11/rgb.txt
lib/X11/rstart/commands/@List
lib/X11/rstart/commands/ListContexts
lib/X11/rstart/commands/ListGenericCommands
-lib/X11/rstart/commands/x
-lib/X11/rstart/commands/x11
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x11
+@unexec rm -f %D/lib/X11/rstart/commands/x
+@unexec rm -f %D/lib/X11/rstart/commands/x11
lib/X11/rstart/commands/x11r6/@List
lib/X11/rstart/commands/x11r6/LoadMonitor
lib/X11/rstart/commands/x11r6/Terminal
diff --git a/x11/XFree86/pkg-plist.pc98 b/x11/XFree86/pkg-plist.pc98
index 35e0ba8052ab..7cd03774c2b0 100644
--- a/x11/XFree86/pkg-plist.pc98
+++ b/x11/XFree86/pkg-plist.pc98
@@ -1272,8 +1272,10 @@ lib/X11/rgb.txt
lib/X11/rstart/commands/@List
lib/X11/rstart/commands/ListContexts
lib/X11/rstart/commands/ListGenericCommands
-lib/X11/rstart/commands/x
-lib/X11/rstart/commands/x11
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x
+@exec ln -fs %D/lib/X11/rstart/commands/x11r6 %D/lib/X11/rstart/commands/x11
+@unexec rm -f %D/lib/X11/rstart/commands/x
+@unexec rm -f %D/lib/X11/rstart/commands/x11
lib/X11/rstart/commands/x11r6/@List
lib/X11/rstart/commands/x11r6/LoadMonitor
lib/X11/rstart/commands/x11r6/Terminal