aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2011-01-02 02:36:01 +0800
committerbf <bf@FreeBSD.org>2011-01-02 02:36:01 +0800
commit280c25fc1590198821dc9ac1876e2a834d58a59b (patch)
treefc91717159bc91ac6d5f3ac744b7a84b1cc331cc
parent15805276133c59ffc5ef8109856c2043a1122e33 (diff)
downloadfreebsd-ports-gnome-280c25fc1590198821dc9ac1876e2a834d58a59b.tar.gz
freebsd-ports-gnome-280c25fc1590198821dc9ac1876e2a834d58a59b.tar.zst
freebsd-ports-gnome-280c25fc1590198821dc9ac1876e2a834d58a59b.zip
- update MASTER_SITES on the basis of distilator results and:
http://www.torproject.org/getinvolved/mirrors.html.en - fix conditional openssl requirements [1] (thanks to Pascal Stumpf for raising this issue, and that of CVE 2010-1676) PR: 151181 [1] Approved by: makc, miwi (mentors, implicit)
-rw-r--r--security/tor/Makefile27
1 files changed, 22 insertions, 5 deletions
diff --git a/security/tor/Makefile b/security/tor/Makefile
index bd19c2cd26ef..5db885b4fe70 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -7,12 +7,24 @@
PORTNAME= tor
DISTVERSION= 0.2.1.28
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= http://www.torproject.org/dist/ \
- http://tor.cypherpunks.at/dist/ \
- http://tor.depthstrike.com/dist/ \
+ ftp://tor.tomyn.com/pub/mirrors/tor/ \
+ ftp://ftp.bit.nl/mirror/tor/ \
+ http://tor-www.5coluna.com/dist/ \
+ http://tor.amorphis.eu/dist/ \
+ http://tor.askapache.com/dist/ \
+ http://tor.beme-it.de/dist/ \
http://tor.boinc.ch/dist/ \
- http://tor.anonymity.cn/dist/
+ http://tor.ccc.de/dist/ \
+ http://tor.idnr.ws/dist/ \
+ http://tor.kamagurka.org/dist/ \
+ http://torproj.xpdm.us/dist/ \
+ http://www.oignon.net/dist/ \
+ http://www.theonionrouter.com/dist/ \
+ http://www.torproject.org.nyud.net/dist/ \
+ http://www.torproject.us/dist/
MAINTAINER= miwi@FreeBSD.org
COMMENT= An anonymizing overlay network for TCP
@@ -22,8 +34,6 @@ LIB_DEPENDS= event-1.4:${PORTSDIR}/devel/libevent
GNU_CONFIGURE= yes
CPPFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"
-USE_OPENSSL= yes
-WITH_OPENSSL_PORT= yes
CONFIGURE_ARGS+= --with-openssl-dir="${OPENSSLBASE}"
OPTIONS= BUFFREELISTS "freelists for buffer RAM" on \
@@ -46,6 +56,13 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
.include <bsd.port.pre.mk>
+.if ( ${OSVERSION} < 704000 || \
+(${OSVERSION} >= 800000 && ${OSVERSION} < 801500) || \
+(${OSVERSION} >= 900000 && ${OSVERSION} < 900011) )
+WITH_OPENSSL_PORT= yes
+.endif
+.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+
.if defined(WITH_BUFFREELISTS)
CONFIGURE_ARGS+= --enable-buf-freelists
.else