aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2015-09-08 01:51:34 +0800
committersunpoet <sunpoet@FreeBSD.org>2015-09-08 01:51:34 +0800
commit28d15466ecb04dd03d30e52d3d974b34b80da033 (patch)
tree8f91d05e80e5ea9ed1c067572c994b6c33947caa
parent06eb2acd1a2425eeefb18781d6835c78bbc30c4d (diff)
downloadfreebsd-ports-gnome-28d15466ecb04dd03d30e52d3d974b34b80da033.tar.gz
freebsd-ports-gnome-28d15466ecb04dd03d30e52d3d974b34b80da033.tar.zst
freebsd-ports-gnome-28d15466ecb04dd03d30e52d3d974b34b80da033.zip
- Add VALA option
- Bump PORTREVISION for package change
-rw-r--r--net/gupnp/Makefile10
-rw-r--r--net/gupnp/pkg-plist2
2 files changed, 11 insertions, 1 deletions
diff --git a/net/gupnp/Makefile b/net/gupnp/Makefile
index 3b0f7ddf6146..c79ab436324f 100644
--- a/net/gupnp/Makefile
+++ b/net/gupnp/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gupnp
PORTVERSION= 0.20.14
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= GNOME
@@ -16,8 +17,11 @@ LIB_DEPENDS= libgssdp-1.0.so:${PORTSDIR}/net/gssdp \
libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
libuuid.so:${PORTSDIR}/misc/e2fsprogs-libuuid
+OPTIONS_DEFINE= VALA
+OPTIONS_SUB= yes
+VALA_DESC= Vala binding (requires net/gssdp with VALA enabled)
+
CONFIGURE_ARGS= --enable-introspection=yes
-CONFIGURE_ENV= VAPIGEN="" ac_cv_path_VAPIGEN=""
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_GNOME= glib20 introspection:build
@@ -27,6 +31,10 @@ USES= compiler:c11 gmake libtool pathfix pkgconfig python:run shebangfix tar:xz
SHEBANG_FILES= tools/gupnp-binding-tool
+VALA_BUILD_DEPENDS= vala>=0.20:${PORTSDIR}/lang/vala
+VALA_CONFIGURE_ENV= ac_cv_path_VAPIGEN=${LOCALBASE}/bin/vapigen
+VALA_CONFIGURE_ENV_OFF= ac_cv_path_VAPIGEN=""
+
.include <bsd.port.pre.mk>
.if ${CHOSEN_COMPILER_TYPE} == "clang"
diff --git a/net/gupnp/pkg-plist b/net/gupnp/pkg-plist
index f7fe0026b00a..e0f21651de42 100644
--- a/net/gupnp/pkg-plist
+++ b/net/gupnp/pkg-plist
@@ -72,3 +72,5 @@ share/gtk-doc/html/gupnp/style.css
share/gtk-doc/html/gupnp/tutorial.html
share/gtk-doc/html/gupnp/up-insensitive.png
share/gtk-doc/html/gupnp/up.png
+%%VALA%%share/vala/vapi/gupnp-1.0.deps
+%%VALA%%share/vala/vapi/gupnp-1.0.vapi