aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryuri <yuri@FreeBSD.org>2019-08-13 00:44:39 +0800
committeryuri <yuri@FreeBSD.org>2019-08-13 00:44:39 +0800
commit290aeadf10048125baf47caa8c64c69f679cc280 (patch)
tree9d682ed955e2523cb74bd25fa352343f6b1887c6
parente7f3fa0c571ab38465620b90e03fd24f5483f118 (diff)
downloadfreebsd-ports-gnome-290aeadf10048125baf47caa8c64c69f679cc280.tar.gz
freebsd-ports-gnome-290aeadf10048125baf47caa8c64c69f679cc280.tar.zst
freebsd-ports-gnome-290aeadf10048125baf47caa8c64c69f679cc280.zip
New port: science/py-tensorflow-estimator: TensorFlow Estimator, an API to simplify machine learning programming
Dependencies are unusual for science/py-tensorflow-estimator: science/py-tensorflow imports science/py-tensorflow-estimator in its python code, but science/py-tensorflow-estimator is a separate project that depends on science/py-tensorflow in order to build. PR: 226400 Submitted by: Anthony <amzo1337@gmail.com>
-rw-r--r--science/Makefile1
-rw-r--r--science/py-tensorflow-estimator/Makefile47
-rw-r--r--science/py-tensorflow-estimator/distinfo3
-rw-r--r--science/py-tensorflow-estimator/files/patch-tensorflow__estimator_tools_pip__package_build__pip__package.sh20
-rw-r--r--science/py-tensorflow-estimator/pkg-descr5
-rw-r--r--science/py-tensorflow-estimator/pkg-plist133
6 files changed, 209 insertions, 0 deletions
diff --git a/science/Makefile b/science/Makefile
index d7d2e8276a0a..1a440775788c 100644
--- a/science/Makefile
+++ b/science/Makefile
@@ -283,6 +283,7 @@
SUBDIR += py-scoria
SUBDIR += py-spglib
SUBDIR += py-tensorflow
+ SUBDIR += py-tensorflow-estimator
SUBDIR += py-veusz
SUBDIR += py-ws2300
SUBDIR += pybrain
diff --git a/science/py-tensorflow-estimator/Makefile b/science/py-tensorflow-estimator/Makefile
new file mode 100644
index 000000000000..c275399c9870
--- /dev/null
+++ b/science/py-tensorflow-estimator/Makefile
@@ -0,0 +1,47 @@
+# $FreeBSD$
+
+PORTNAME= tensorflow-estimator
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.14.0
+CATEGORIES= science python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= amzo1337@gmail.com
+COMMENT= TensorFlow Estimator, an API to simplify machine learning programming
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= bash:shells/bash \
+ bazel:devel/bazel \
+ ${PYTHON_PKGNAMEPREFIX}tensorflow>=1.14.0:science/py-tensorflow@${PY_FLAVOR}
+
+USES= python shebangfix
+SHEBANG_GLOB= *.py
+USE_GITHUB= yes
+GH_ACCOUNT= tensorflow
+GH_PROJECT= estimator
+
+BAZEL_BOOT= --output_user_root=${WRKDIR}/bazel_out
+
+post-patch:
+ @${REINPLACE_CMD} "s#%%PYTHON%%#${PYTHON_CMD}#" \
+ ${WRKSRC}/tensorflow_estimator/tools/pip_package/build_pip_package.sh
+
+do-build:
+ @cd ${WRKSRC} && \
+ bazel ${BAZEL_BOOT} build -s \
+ //tensorflow_estimator/tools/pip_package:build_pip_package
+ @cd ${WRKSRC} && ${SETENV} TMPDIR=${WRKDIR} && \
+ bazel-bin/tensorflow_estimator/tools/pip_package/build_pip_package \
+ ${WRKDIR}/whl
+
+do-install:
+ @${MKDIR} ${STAGEDIR}/${PYTHON_SITELIBDIR}
+ @${MKDIR} ${WRKDIR}/tmp
+ @${UNZIP_NATIVE_CMD} -d ${WRKDIR}/tmp ${WRKDIR}/whl/${PORTNAME}-${PORTVERSION}-*.whl
+ cd ${WRKDIR}/tmp && ${COPYTREE_SHARE} ${PORTNAME} \
+ ${STAGEDIR}${PYTHON_SITELIBDIR}
+ cd ${WRKDIR}/tmp && ${COPYTREE_SHARE} ${PORTNAME}-${PORTVERSION}.dist-info \
+ ${STAGEDIR}${PYTHON_SITELIBDIR}
+
+.include <bsd.port.mk>
diff --git a/science/py-tensorflow-estimator/distinfo b/science/py-tensorflow-estimator/distinfo
new file mode 100644
index 000000000000..eedb8d467e96
--- /dev/null
+++ b/science/py-tensorflow-estimator/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1565118650
+SHA256 (tensorflow-estimator-v1.14.0_GH0.tar.gz) = 1f0b80b8067a52cc33bbe390d34791eb3e12453c506daa1b4c8fc07fbf962d9f
+SIZE (tensorflow-estimator-v1.14.0_GH0.tar.gz) = 670750
diff --git a/science/py-tensorflow-estimator/files/patch-tensorflow__estimator_tools_pip__package_build__pip__package.sh b/science/py-tensorflow-estimator/files/patch-tensorflow__estimator_tools_pip__package_build__pip__package.sh
new file mode 100644
index 000000000000..f7d51529f643
--- /dev/null
+++ b/science/py-tensorflow-estimator/files/patch-tensorflow__estimator_tools_pip__package_build__pip__package.sh
@@ -0,0 +1,20 @@
+--- tensorflow_estimator/tools/pip_package/build_pip_package.sh.orig 2019-06-11 17:18:02 UTC
++++ tensorflow_estimator/tools/pip_package/build_pip_package.sh
+@@ -38,7 +38,7 @@ function prepare_src() {
+
+ # Verifies all expected files are in pip.
+ # Creates init files in all directory in pip.
+- python tensorflow_estimator/tools/pip_package/create_pip_helper.py --pip-root "${TMPDIR}/tensorflow_estimator/" --bazel-root "./tensorflow_estimator"
++ %%PYTHON%% tensorflow_estimator/tools/pip_package/create_pip_helper.py --pip-root "${TMPDIR}/tensorflow_estimator/" --bazel-root "./tensorflow_estimator"
+ }
+
+ function build_wheel() {
+@@ -53,7 +53,7 @@ function build_wheel() {
+
+ pushd ${TMPDIR} > /dev/null
+ echo $(date) : "=== Building wheel"
+- "${PYTHON_BIN_PATH:-python}" setup.py bdist_wheel --universal --project_name $PROJECT_NAME
++ %%PYTHON%% setup.py bdist_wheel --universal --project_name $PROJECT_NAME
+ mkdir -p ${DEST}
+ cp dist/* ${DEST}
+ popd > /dev/null
diff --git a/science/py-tensorflow-estimator/pkg-descr b/science/py-tensorflow-estimator/pkg-descr
new file mode 100644
index 000000000000..7f650a3d96a4
--- /dev/null
+++ b/science/py-tensorflow-estimator/pkg-descr
@@ -0,0 +1,5 @@
+TensorFlow Estimator is a high-level TensorFlow API that greatly
+simplifies machine learning programming. Estimators encapsulate
+training, evaluation, prediction, and exporting for your model.
+
+WWW: https://github.com/tensorflow/estimator
diff --git a/science/py-tensorflow-estimator/pkg-plist b/science/py-tensorflow-estimator/pkg-plist
new file mode 100644
index 000000000000..1dfcd430389f
--- /dev/null
+++ b/science/py-tensorflow-estimator/pkg-plist
@@ -0,0 +1,133 @@
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator-1.14.0.dist-info/DESCRIPTION.rst
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator-1.14.0.dist-info/METADATA
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator-1.14.0.dist-info/RECORD
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator-1.14.0.dist-info/WHEEL
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator-1.14.0.dist-info/metadata.json
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator-1.14.0.dist-info/top_level.txt
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v1/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v1/estimator/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v1/estimator/experimental/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v1/estimator/export/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v1/estimator/inputs/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v1/estimator/tpu/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v1/v1.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v2/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v2/estimator/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v2/estimator/experimental/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v2/estimator/export/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v2/estimator/inputs/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/_api/v2/v2.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/boosted_trees.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/dnn_with_layer_annotations.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/export.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/exporter.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/extenders.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/logit_fns.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/multi_head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/replicate_model_fn.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/rnn.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/rnn_v2.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/contrib/estimator/python/estimator/saved_model_estimator.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v1/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v1/estimator/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v1/estimator/experimental/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v1/estimator/export/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v1/estimator/inputs/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v1/estimator/tpu/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v1/v1.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v2/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v2/estimator/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v2/estimator/experimental/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v2/estimator/export/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v2/estimator/inputs/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/api/_v2/v2.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/baseline.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/boosted_trees.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/boosted_trees_utils.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/dnn.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/dnn_linear_combined.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/dnn_testing_utils.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/kmeans.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/linear.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/linear_optimizer/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/linear_optimizer/python/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/linear_optimizer/python/utils/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/linear_optimizer/python/utils/sdca_ops.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/linear_optimizer/python/utils/sharded_mutable_dense_hashtable.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/linear_testing_utils.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/metric_keys.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/optimizers.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/parsing_utils.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/prediction_keys.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/saved_model_estimator.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/ar_model.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/estimators.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/feature_keys.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/math_utils.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/model.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/model_utils.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/saved_model_utils.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/timeseries/state_management.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/v1/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/v1/dnn_testing_utils_v1.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/canned/v1/linear_testing_utils_v1.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/early_stopping.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/estimator.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/estimator_lib.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/export/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/export/export.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/export/export_lib.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/export/export_output.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/export/function.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/exporter.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/extenders.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/gc.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/base_head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/binary_class_head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/head_utils.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/multi_class_head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/multi_head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/multi_label_head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/regression_head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/head/sequential_head.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/hooks/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/hooks/basic_session_run_hooks.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/hooks/fake_summary_writer.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/hooks/hooks.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/hooks/session_run_hook.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/inputs/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/inputs/inputs.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/inputs/numpy_io.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/inputs/pandas_io.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/inputs/queues/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/inputs/queues/feeding_functions.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/inputs/queues/feeding_queue_runner.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/keras.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/mode_keys.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/model_fn.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/run_config.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/tpu/__init__.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/tpu/_tpu_estimator_embedding.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/tpu/error_handling.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/tpu/iteration_count_estimator.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/tpu/tpu_config.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/tpu/tpu_context.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/tpu/tpu_estimator.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/tpu/util.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/training.py
+%%PYTHON_SITELIBDIR%%/tensorflow_estimator/python/estimator/util.py