aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2014-01-19 01:58:42 +0800
committerohauer <ohauer@FreeBSD.org>2014-01-19 01:58:42 +0800
commit290be2e181e55f76c000b8a0242cc17b982fce72 (patch)
treeecd66156c113b0c8d18d3f44c6eac4f90925b919
parentd03bdda9adbe324a3744e22dab8fda26926c44e7 (diff)
downloadfreebsd-ports-gnome-290be2e181e55f76c000b8a0242cc17b982fce72.tar.gz
freebsd-ports-gnome-290be2e181e55f76c000b8a0242cc17b982fce72.tar.zst
freebsd-ports-gnome-290be2e181e55f76c000b8a0242cc17b982fce72.zip
- pass maintainer to submitter
- add LICENSE - new MASTER site - new re-rolled distfile some minor cleanup (mostly white spaces) PR: ports/185585 Submitted by: C Hutchinson <portmaster@bsdforge.com> (new maintainer)
-rw-r--r--www/mod_log_mysql/Makefile22
-rw-r--r--www/mod_log_mysql/distinfo4
-rw-r--r--www/mod_log_mysql/files/patch-mod_log_mysql.c8
-rw-r--r--www/mod_log_mysql/pkg-descr4
4 files changed, 17 insertions, 21 deletions
diff --git a/www/mod_log_mysql/Makefile b/www/mod_log_mysql/Makefile
index 2ac1cf38ac34..18215c7ca33d 100644
--- a/www/mod_log_mysql/Makefile
+++ b/www/mod_log_mysql/Makefile
@@ -2,23 +2,19 @@
# $FreeBSD$
PORTNAME= mod_log_mysql
-PORTVERSION= 1.0
-PORTREVISION= 3
+PORTVERSION= 1.04
CATEGORIES= www
-# Original location: http://bitbrook.de/software/mod_log_mysql/mod_log_mysql.c
-# Please handle update requests with care!
-# sheepkiller was hacked and not cleaned over a long periode.
-# (First notice 2011-03 not cleaned until 2011-07)
-# Provide distfile now from LOCAL
-#MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/
-MASTER_SITES= LOCAL/ohauer
+MASTER_SITES= http://bsdforge.com/projects/source/apache2/
DIST_SUBDIR= apache2
-MAINTAINER= apache@FreeBSD.org
-COMMENT= Allows Apache 2 to log to a MySQL database
+MAINTAINER= portmaster@bsdforge.com
+COMMENT= Allows Apache 2.2.x to log to a MySQL database
-EXPIRATION_DATE= 2014-02-08
-DEPRECATED= Upstream site gone since 2011-03
+LICENSE= PUBLIC_DOMAIN APACHE11
+LICENSE_COMB= multi
+LICENSE_NAME_PUBLIC_DOMAIN= Public Domain
+LICENSE_TEXT_PUBLIC_DOMAIN= mod_log_mysql.c is in the Public Domain as of 2003.10.23.
+LICENSE_PERMS_PUBLIC_DOMAIN= dist-mirror dist-sell pkg-mirror pkg-sell auto-accept
RUN_DEPENDS+= ${LOCALBASE}/${APACHEMODDIR}/mod_log_config-st.so:${PORTSDIR}/www/mod_log_config-st
diff --git a/www/mod_log_mysql/distinfo b/www/mod_log_mysql/distinfo
index ecdfd8aba8a8..f42ead8a0361 100644
--- a/www/mod_log_mysql/distinfo
+++ b/www/mod_log_mysql/distinfo
@@ -1,2 +1,2 @@
-SHA256 (apache2/mod_log_mysql-1.0.tar.gz) = 27fdd2c87133d62171a38585807f70009821a3cb13e011d2ceb62fcc1c8ad4bb
-SIZE (apache2/mod_log_mysql-1.0.tar.gz) = 8046
+SHA256 (apache2/mod_log_mysql-1.04.tar.gz) = da6cfbd1788b28e7421fcf4963e592bafec3b946ea9f01ac5319708e7ec41d45
+SIZE (apache2/mod_log_mysql-1.04.tar.gz) = 8010
diff --git a/www/mod_log_mysql/files/patch-mod_log_mysql.c b/www/mod_log_mysql/files/patch-mod_log_mysql.c
index 8804de943db2..4b7df5982c9e 100644
--- a/www/mod_log_mysql/files/patch-mod_log_mysql.c
+++ b/www/mod_log_mysql/files/patch-mod_log_mysql.c
@@ -1,11 +1,11 @@
---- mod_log_mysql.c 2003-11-01 12:21:28.000000000 +0200
-+++ mod_log_mysql.c.new 2010-11-28 17:01:06.000000000 +0200
-@@ -172,11 +172,13 @@
+--- mod_log_mysql.c 2014-01-10 13:56:23.777364558 -0800
++++ mod_log_mysql.c.new 2014-01-10 13:58:54.058985546 -0800
+@@ -142,11 +142,13 @@
{
mysql_log *l = param;
MYSQL *db;
+ my_bool do_reconnect = 1;
-
+
db = apr_palloc(p, sizeof(MYSQL));
mysql_init(db);
diff --git a/www/mod_log_mysql/pkg-descr b/www/mod_log_mysql/pkg-descr
index 31f810478891..2a2bd0cec189 100644
--- a/www/mod_log_mysql/pkg-descr
+++ b/www/mod_log_mysql/pkg-descr
@@ -4,10 +4,10 @@ request logging into a MySQL database.
Key features are:
* Seamless integration into the standard Apache logging
configuration.
- * Only one configuration line needed to start logging.
+ * Only a single configuration line needed to start logging.
* Free SQL use.
* Multiple databases, database users and/or database servers.
- * Connection pooling, only one connection per log target per
+ * Connection pooling, only one connection per log target, per
child process.
* Logs data as it is: e.g. times as SQL DATETIME and n/a items
as SQL NULL.