aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2013-09-15 01:24:48 +0800
committersunpoet <sunpoet@FreeBSD.org>2013-09-15 01:24:48 +0800
commit29250ac9cc27ca2b7205fac7d8b37b68e634c3ad (patch)
treeabb72eaffb3d1507133a6a90f8cadad46e5dc900
parentf8e3d1a41f2a131629aff6670ea014dda70577cb (diff)
downloadfreebsd-ports-gnome-29250ac9cc27ca2b7205fac7d8b37b68e634c3ad.tar.gz
freebsd-ports-gnome-29250ac9cc27ca2b7205fac7d8b37b68e634c3ad.tar.zst
freebsd-ports-gnome-29250ac9cc27ca2b7205fac7d8b37b68e634c3ad.zip
- Fix build without libstdc++ by removing hardcoded libstdc++ linkage [1]
- Convert to new LIB_DEPENDS format - Use USE+= after bsd.port.*.mk inclusion Reported by: pkg-fallout [1]
-rw-r--r--databases/xapian-bindings/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/databases/xapian-bindings/Makefile b/databases/xapian-bindings/Makefile
index 64e7c97edcbc..19a1ad46ae94 100644
--- a/databases/xapian-bindings/Makefile
+++ b/databases/xapian-bindings/Makefile
@@ -12,7 +12,7 @@ COMMENT= Bindings allowing Xapian to be used from various programming languages
LICENSE= GPLv2
-LIB_DEPENDS= xapian:${PORTSDIR}/databases/xapian-core
+LIB_DEPENDS= libxapian.so:${PORTSDIR}/databases/xapian-core
OPTIONS_DEFINE= DOCS LUA PERL PHP PYTHON RUBY
OPTIONS_DEFAULT=PHP PYTHON RUBY
@@ -37,7 +37,7 @@ PLIST_SUB+= LUA="@comment "
.if ${PORT_OPTIONS:MPERL}
CONFIGURE_ARGS+=--with-perl
CONFIGURE_ENV+= PERL_LIB="${SITE_PERL}"
-USES= perl5
+USES+= perl5
PLIST_SUB+= PERL=""
.else
PLIST_SUB+= PERL="@comment "
@@ -75,6 +75,7 @@ PLIST_SUB+= RUBY="@comment "
.endif
post-patch:
+ @${REINPLACE_CMD} -e 's|-lstdc++||g' ${WRKSRC}/configure
# do not install rdoc
@${REINPLACE_CMD} -e '/^install-data-am:/ s|install-data-local||' ${WRKSRC}/ruby/Makefile.in
.if !${PORT_OPTIONS:MDOCS}