aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2009-12-07 22:41:50 +0800
committerWen Heping <wen@FreeBSD.org>2009-12-07 22:41:50 +0800
commit2956f23b0948d4c88631551740eebf6abc8e22fa (patch)
treeaf9b21bff65c7521b866c8dd4e546ad52492a157
parent5ff2b98adedbfc317dceb3a765d3f3a9a80bfd2c (diff)
downloadfreebsd-ports-gnome-2956f23b0948d4c88631551740eebf6abc8e22fa.tar.gz
freebsd-ports-gnome-2956f23b0948d4c88631551740eebf6abc8e22fa.tar.zst
freebsd-ports-gnome-2956f23b0948d4c88631551740eebf6abc8e22fa.zip
As with other Pseudo-Random Number Generator (PRNG) algorithms like the
Mersenne Twister (see Math::Random::MT), this algorithm is designed to take some seed information and produce seemingly random results as output. However, ISAAC (Indirection, Shift, Accumulate, Add, and Count) has different goals than these commonly used algorithms. In particular, it's really fast - on average, it requires only 18.75 machine cycles to generate a 32-bit value. This makes it suitable for applications where a significant amount of random data needs to be produced quickly, such solving using the Monte Carlo method or for games. WWW: http://search.cpan.org/dist/Math-Random-ISAAC-XS/
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Random-ISAAC-XS/Makefile24
-rw-r--r--math/p5-Math-Random-ISAAC-XS/distinfo3
-rw-r--r--math/p5-Math-Random-ISAAC-XS/pkg-descr12
-rw-r--r--math/p5-Math-Random-ISAAC-XS/pkg-plist11
5 files changed, 51 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 4f01b40143c5..be4c6ae2854e 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -330,6 +330,7 @@
SUBDIR += p5-Math-Polynomial-Solve
SUBDIR += p5-Math-Random
SUBDIR += p5-Math-Random-ISAAC
+ SUBDIR += p5-Math-Random-ISAAC-XS
SUBDIR += p5-Math-Random-MT
SUBDIR += p5-Math-Random-MT-Auto
SUBDIR += p5-Math-Random-OO
diff --git a/math/p5-Math-Random-ISAAC-XS/Makefile b/math/p5-Math-Random-ISAAC-XS/Makefile
new file mode 100644
index 000000000000..a515e4bb0a93
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC-XS/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: Math::Random::ISAAC::XS
+# Date created: 07 Dec, 2009
+# Whom: Wen Heping <wen@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Random-ISAAC-XS
+PORTVERSION= 1.001
+CATEGORIES= math perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= C implementation of the ISAAC PRNG Algorithm
+
+BUILD_DEPENDS= p5-Test-NoWarnings>0:${PORTSDIR}/devel/p5-Test-NoWarnings
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Math::Random::ISAAC::XS.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Random-ISAAC-XS/distinfo b/math/p5-Math-Random-ISAAC-XS/distinfo
new file mode 100644
index 000000000000..d57346737136
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC-XS/distinfo
@@ -0,0 +1,3 @@
+MD5 (Math-Random-ISAAC-XS-1.001.tar.gz) = 2656675416d9e36076016e73a2e326ff
+SHA256 (Math-Random-ISAAC-XS-1.001.tar.gz) = 357cd06bee82a51dd04511f9c35f96797264e41c36edc1339da13d2e464b3c34
+SIZE (Math-Random-ISAAC-XS-1.001.tar.gz) = 74962
diff --git a/math/p5-Math-Random-ISAAC-XS/pkg-descr b/math/p5-Math-Random-ISAAC-XS/pkg-descr
new file mode 100644
index 000000000000..c764bf79947d
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC-XS/pkg-descr
@@ -0,0 +1,12 @@
+As with other Pseudo-Random Number Generator (PRNG) algorithms like the
+Mersenne Twister (see Math::Random::MT), this algorithm is designed to
+take some seed information and produce seemingly random results as output.
+
+However, ISAAC (Indirection, Shift, Accumulate, Add, and Count) has
+different goals than these commonly used algorithms. In particular, it's
+really fast - on average, it requires only 18.75 machine cycles to generate
+a 32-bit value. This makes it suitable for applications where a significant
+amount of random data needs to be produced quickly, such solving using the
+Monte Carlo method or for games.
+
+WWW: http://search.cpan.org/dist/Math-Random-ISAAC-XS/
diff --git a/math/p5-Math-Random-ISAAC-XS/pkg-plist b/math/p5-Math-Random-ISAAC-XS/pkg-plist
new file mode 100644
index 000000000000..136dc108832d
--- /dev/null
+++ b/math/p5-Math-Random-ISAAC-XS/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/ISAAC/XS.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC/XS/XS.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC/XS/XS.so
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/ISAAC/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random/ISAAC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math/Random
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Math
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC/XS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random/ISAAC
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math/Random
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Math