aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2016-07-08 19:24:18 +0800
committertijl <tijl@FreeBSD.org>2016-07-08 19:24:18 +0800
commit29b7511a9f5e6353b2b1fe547be0bae72e17b03e (patch)
treee30f1ac4e357e8c376c8b838988c5bfd27797a31
parent400dbe87eb3cacb23d81e818e2f5d2afdc5d0064 (diff)
downloadfreebsd-ports-gnome-29b7511a9f5e6353b2b1fe547be0bae72e17b03e.tar.gz
freebsd-ports-gnome-29b7511a9f5e6353b2b1fe547be0bae72e17b03e.tar.zst
freebsd-ports-gnome-29b7511a9f5e6353b2b1fe547be0bae72e17b03e.zip
Remove a patch from devel/gmake so the port no longer depends on
print/texinfo which requires gmake. To break this circular dependency gmake-lite was introduced. This can be removed now as well. PR: 210623 Reviewed by: bapt Exp-run by: antoine Approved by: portmgr (antoine)
-rw-r--r--MOVED1
-rw-r--r--Mk/Uses/gmake.mk18
-rw-r--r--devel/Makefile1
-rw-r--r--devel/gmake/Makefile4
-rw-r--r--devel/gmake/files/patch-doc_make.text7
-rw-r--r--devel/slibtool/Makefile2
-rw-r--r--misc/help2man/Makefile3
-rw-r--r--print/texinfo/Makefile4
8 files changed, 12 insertions, 28 deletions
diff --git a/MOVED b/MOVED
index ac6953849de5..52d94a18c043 100644
--- a/MOVED
+++ b/MOVED
@@ -8608,3 +8608,4 @@ sysutils/moosefs-client|sysutils/moosefs2-client|2016-07-07|Moved to a numbered
sysutils/moosefs-master|sysutils/moosefs2-master|2016-07-07|Moved to a numbered port name
sysutils/moosefs-metalogger|sysutils/moosefs2-metalogger|2016-07-07|Moved to a numbered port name
sysutils/moosefs-netdump|sysutils/moosefs2-netdump|2016-07-07|Moved to a numbered port name
+devel/gmake-lite|devel/gmake|2016-07-08|No longer needed
diff --git a/Mk/Uses/gmake.mk b/Mk/Uses/gmake.mk
index ec5878b79c8a..9181da894075 100644
--- a/Mk/Uses/gmake.mk
+++ b/Mk/Uses/gmake.mk
@@ -3,7 +3,7 @@
# Provide support to use the GNU make
#
# Feature: gmake
-# Usage: USES=gmake[:lite]
+# Usage: USES=gmake
#
# MAINTAINER: portmgr@FreeBSD.org
@@ -11,19 +11,11 @@
_INCLUDE_USES_GMAKE_MK= yes
.if !empty(gmake_ARGS)
-.if ${gmake_ARGS} == lite
-_GMAKE_EXT= -lite
-.else
-IGNORE= Incorrect 'USES+= gmake:${gmake_ARGS}' gmake has only one valid argument: lite
-.endif
-.endif
-
-.if defined(DIET)
-_GMAKE_EXT= -lite
+IGNORE= Incorrect 'USES+= gmake:${gmake_ARGS}' gmake takes no arguments
.endif
-BUILD_DEPENDS+= gmake${_GMAKE_EXT}:devel/gmake${_GMAKE_EXT}
-CONFIGURE_ENV+= MAKE=gmake${_GMAKE_EXT}
-MAKE_CMD= gmake${_GMAKE_EXT}
+BUILD_DEPENDS+= gmake:devel/gmake
+CONFIGURE_ENV+= MAKE=gmake
+MAKE_CMD= gmake
.endif
diff --git a/devel/Makefile b/devel/Makefile
index cc8e4af7f27e..712c46c5990e 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -695,7 +695,6 @@
SUBDIR += glrparser
SUBDIR += glui
SUBDIR += gmake
- SUBDIR += gmake-lite
SUBDIR += gnatcoll
SUBDIR += gnatpython
SUBDIR += gnome-builder
diff --git a/devel/gmake/Makefile b/devel/gmake/Makefile
index f369a7c65a0c..cf89f0f083eb 100644
--- a/devel/gmake/Makefile
+++ b/devel/gmake/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gmake
PORTVERSION= 4.2.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= GNU/make
DISTNAME= make-${PORTVERSION}
@@ -19,11 +20,10 @@ LICENSE_FILE= ${WRKSRC}/COPYING
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --program-prefix=g \
--without-guile
-CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
# fmake does not like PO_DEPENDS_ON_POT being undefined
MAKE_ARGS= PO_DEPENDS_ON_POT=
-USES= cpe makeinfo tar:bzip2
+USES= cpe tar:bzip2
CPE_VENDOR= gnu
OPTIONS_DEFINE= NLS
diff --git a/devel/gmake/files/patch-doc_make.text b/devel/gmake/files/patch-doc_make.text
deleted file mode 100644
index f4bcc7661b0c..000000000000
--- a/devel/gmake/files/patch-doc_make.text
+++ /dev/null
@@ -1,7 +0,0 @@
---- doc/make.texi.orig 2010-07-19 02:10:54.000000000 -0500
-+++ doc/make.texi 2011-03-02 17:01:58.000000000 -0600
-@@ -54,3 +54,3 @@
- @direntry
--* Make: (make). Remake files automatically.
-+* GNU Make: (make). Remake files automatically.
- @end direntry
diff --git a/devel/slibtool/Makefile b/devel/slibtool/Makefile
index e5b73fc35ea7..2284744ab75a 100644
--- a/devel/slibtool/Makefile
+++ b/devel/slibtool/Makefile
@@ -12,7 +12,7 @@ LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING.SLIBTOOL
HAS_CONFIGURE= yes
-USES= gmake:lite tar:xz
+USES= gmake tar:xz
post-patch:
${REINPLACE_CMD} -e "s/make/${MAKE_CMD}/g" ${WRKSRC}/configure
diff --git a/misc/help2man/Makefile b/misc/help2man/Makefile
index d544f37d557c..9804c266cab0 100644
--- a/misc/help2man/Makefile
+++ b/misc/help2man/Makefile
@@ -17,8 +17,7 @@ OPTIONS_DEFINE= NLS
LIBS+= -L${LOCALBASE}/lib
GNU_CONFIGURE= yes
-# keep gmake:lite has a dependency to avoid circular dependency
-USES= gmake:lite perl5
+USES= gmake perl5
INFO= ${PORTNAME}
PLIST_FILES= bin/${PORTNAME} \
diff --git a/print/texinfo/Makefile b/print/texinfo/Makefile
index 0a4cb3d4276e..da5a995fd560 100644
--- a/print/texinfo/Makefile
+++ b/print/texinfo/Makefile
@@ -25,10 +25,10 @@ NLS_CONFIGURE_ENABLE= nls
GNU_CONFIGURE= yes
INSTALL_TARGET= install install-tex
PKGDEINSTALL= ${PKGINSTALL}
-USES+= charsetfix cpe gmake:lite ncurses perl5 tar:xz
+USES+= charsetfix cpe gmake ncurses perl5 tar:xz
MAKE_ARGS= TEXMF=${LOCALBASE}/${TEXMF} PERL=${LOCALBASE}/bin/perl
-INFO= texinfo info-stnd info
+INFO= texinfo info-stnd
CPE_VENDOR= gnu
CPE_VERSION= ${PORTVERSION:R}