aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlwhsu <lwhsu@FreeBSD.org>2014-02-07 15:22:09 +0800
committerlwhsu <lwhsu@FreeBSD.org>2014-02-07 15:22:09 +0800
commit29f7fecb52c7d1391c9e663bf0c99a0ad6b858e8 (patch)
tree10ee8e8ed4c563caa96cd787e4e36fa092c2c7c1
parent698ed07a443f2a4dd5935a9581c74a34f007a7bf (diff)
downloadfreebsd-ports-gnome-29f7fecb52c7d1391c9e663bf0c99a0ad6b858e8.tar.gz
freebsd-ports-gnome-29f7fecb52c7d1391c9e663bf0c99a0ad6b858e8.tar.zst
freebsd-ports-gnome-29f7fecb52c7d1391c9e663bf0c99a0ad6b858e8.zip
Add webgrind snapshot 20140207, xdebug Profiling Web Frontend in PHP.
-rw-r--r--www/Makefile1
-rw-r--r--www/webgrind/Makefile44
-rw-r--r--www/webgrind/distinfo2
-rw-r--r--www/webgrind/pkg-descr6
-rw-r--r--www/webgrind/pkg-plist46
5 files changed, 99 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index d897dee1a1aa..aff90cf8fc7f 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -2110,6 +2110,7 @@
SUBDIR += webcrawl
SUBDIR += webfs
SUBDIR += webgo
+ SUBDIR += webgrind
SUBDIR += webinject
SUBDIR += webkit-gtk2
SUBDIR += webkit-gtk3
diff --git a/www/webgrind/Makefile b/www/webgrind/Makefile
new file mode 100644
index 000000000000..47f5eeafc5a8
--- /dev/null
+++ b/www/webgrind/Makefile
@@ -0,0 +1,44 @@
+# Created by: Li-Wen Hsu <lwhsu@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= webgrind
+DISTVERSION= 1.0.s${SNAPSHOT}
+CATEGORIES= www
+
+MAINTAINER= lwhsu@FreeBSD.org
+COMMENT= Xdebug Profiling Web Frontend in PHP
+
+LICENSE= BSD3CLAUSE
+
+OPTIONS_DEFINE= CALLGRAPH
+
+USE_GITHUB= yes
+GH_ACCOUNT= jokkedk
+GH_TAGNAME= ${GH_COMMIT}
+
+SNAPSHOT= 20140207
+GH_COMMIT= dc35393
+
+USE_PHP= yes
+
+NO_BUILD= yes
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCALLGRAPH}
+USE_PYTHON= yes
+RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
+.endif
+
+post-patch:
+ ${REINPLACE_CMD} -e 's,/usr/bin/python,/usr/local/bin/python,' ${WRKSRC}/config.php
+
+do-install:
+ @${MKDIR} ${STAGEDIR}${WWWDIR}
+ (cd ${WRKSRC}/ && ${COPYTREE_SHARE} "*" ${STAGEDIR}${WWWDIR} "! -name *.bak")
+
+ @${CHOWN} -R ${WWWOWN}:${WWWGRP} ${STAGEDIR}${WWWDIR}
+ @${FIND} ${STAGEDIR}${WWWDIR} -type f -exec ${CHMOD} 0444 {} \;
+ @${FIND} ${STAGEDIR}${WWWDIR} -type d -exec ${CHMOD} 0755 {} \;
+
+.include <bsd.port.mk>
diff --git a/www/webgrind/distinfo b/www/webgrind/distinfo
new file mode 100644
index 000000000000..bbd266713090
--- /dev/null
+++ b/www/webgrind/distinfo
@@ -0,0 +1,2 @@
+SHA256 (webgrind-1.0.s20140207.tar.gz) = ff3cd3e5cac99bfc85b9dde5fed2d4a489458d9458f2bb8d835d9ff7a02646a6
+SIZE (webgrind-1.0.s20140207.tar.gz) = 74290
diff --git a/www/webgrind/pkg-descr b/www/webgrind/pkg-descr
new file mode 100644
index 000000000000..8232c5caf6b5
--- /dev/null
+++ b/www/webgrind/pkg-descr
@@ -0,0 +1,6 @@
+Webgrind is a Xdebug profiling web frontend in PHP5. It implements
+a subset of the features of kcachegrind and installs in seconds
+and works on all platforms. For quick'n'dirty optimizations it
+does the job.
+
+WWW: https://github.com/jokkedk/webgrind
diff --git a/www/webgrind/pkg-plist b/www/webgrind/pkg-plist
new file mode 100644
index 000000000000..1d7d63300aac
--- /dev/null
+++ b/www/webgrind/pkg-plist
@@ -0,0 +1,46 @@
+%%WWWDIR%%/README.md
+%%WWWDIR%%/config.php
+%%WWWDIR%%/img/asc.gif
+%%WWWDIR%%/img/bg.gif
+%%WWWDIR%%/img/blank.gif
+%%WWWDIR%%/img/call_class.png
+%%WWWDIR%%/img/call_include.png
+%%WWWDIR%%/img/call_internal.png
+%%WWWDIR%%/img/call_procedural.png
+%%WWWDIR%%/img/desc.gif
+%%WWWDIR%%/img/down.gif
+%%WWWDIR%%/img/file.png
+%%WWWDIR%%/img/file_line.png
+%%WWWDIR%%/img/gradient_class.png
+%%WWWDIR%%/img/gradient_include.png
+%%WWWDIR%%/img/gradient_internal.png
+%%WWWDIR%%/img/gradient_left.png
+%%WWWDIR%%/img/gradient_markers.png
+%%WWWDIR%%/img/gradient_procedural.png
+%%WWWDIR%%/img/gradient_right.png
+%%WWWDIR%%/img/head.png
+%%WWWDIR%%/img/marker.png
+%%WWWDIR%%/img/reload.png
+%%WWWDIR%%/img/right.gif
+%%WWWDIR%%/index.php
+%%WWWDIR%%/js/jquery.blockUI.js
+%%WWWDIR%%/js/jquery.js
+%%WWWDIR%%/js/jquery.scrollTo.js
+%%WWWDIR%%/js/jquery.selectboxes.js
+%%WWWDIR%%/js/jquery.tablesorter.js
+%%WWWDIR%%/js/sprintf.js
+%%WWWDIR%%/library/FileHandler.php
+%%WWWDIR%%/library/Preprocessor.php
+%%WWWDIR%%/library/Reader.php
+%%WWWDIR%%/library/gprof2dot.py
+%%WWWDIR%%/license.txt
+%%WWWDIR%%/package.sh
+%%WWWDIR%%/styles/style.css
+%%WWWDIR%%/templates/fileviewer.phtml
+%%WWWDIR%%/templates/index.phtml
+@dirrm %%WWWDIR%%/templates
+@dirrm %%WWWDIR%%/styles
+@dirrm %%WWWDIR%%/library
+@dirrm %%WWWDIR%%/js
+@dirrm %%WWWDIR%%/img
+@dirrm %%WWWDIR%%