aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2003-02-22 00:38:34 +0800
committernectar <nectar@FreeBSD.org>2003-02-22 00:38:34 +0800
commit2ab22c90bceda8e9cd87d9bea0acc5316de628f2 (patch)
treec9a8ac2f1a9b02066e78a03023952db9b0001be3
parent63350d0624e92c553cbbebaacfa19698c14ff812 (diff)
downloadfreebsd-ports-gnome-2ab22c90bceda8e9cd87d9bea0acc5316de628f2.tar.gz
freebsd-ports-gnome-2ab22c90bceda8e9cd87d9bea0acc5316de628f2.tar.zst
freebsd-ports-gnome-2ab22c90bceda8e9cd87d9bea0acc5316de628f2.zip
In OpenSSL 0.9.7, `OpenSSL_add_all_algorithms' is now a macro. This
causes configure scripts that look for this function in libcrypto to lose. Use `OpenSSL_add_all_ciphers' instead (which is a function in both OpenSSL 0.9.6 and 0.9.7).
-rw-r--r--security/tinc/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/tinc/Makefile b/security/tinc/Makefile
index 9a22b3068115..3584a7d4799d 100644
--- a/security/tinc/Makefile
+++ b/security/tinc/Makefile
@@ -21,6 +21,7 @@ COMMENT= A Virtual Private Network (VPN) daemon
LIB_DEPENDS= intl:${PORTSDIR}/devel/gettext
USE_OPENSSL= yes
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -30,6 +31,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN5= tinc.conf.5
MAN8= tincd.8
+pre-configure:
+ ${REINPLACE_CMD} \
+ 's/OpenSSL_add_all_algorithms/OpenSSL_add_all_ciphers/' \
+ ${WRKSRC}/configure
+
post-extract:
@${RM} -f ${WRKSRC}/doc/tinc.info*