aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorvanilla <vanilla@FreeBSD.org>2007-06-30 18:39:30 +0800
committervanilla <vanilla@FreeBSD.org>2007-06-30 18:39:30 +0800
commit2b7998e81f81ac83066aa348fcf01ac326c8d544 (patch)
treedd409f971fdaef2af8d572253da37037db9b6f42
parent5e8bc949dbcfc4d6c9c850013748ea5364acdc49 (diff)
downloadfreebsd-ports-gnome-2b7998e81f81ac83066aa348fcf01ac326c8d544.tar.gz
freebsd-ports-gnome-2b7998e81f81ac83066aa348fcf01ac326c8d544.tar.zst
freebsd-ports-gnome-2b7998e81f81ac83066aa348fcf01ac326c8d544.zip
Add p5-Net-SSH-Expect 0.05, SSH wrapper to execute remote commands.
PR: ports/114147 Submitted by: Tsung-Han Yeh <snowfly at yuntech.edu.tw>
-rw-r--r--net/Makefile1
-rw-r--r--net/p5-Net-SSH-Expect/Makefile31
-rw-r--r--net/p5-Net-SSH-Expect/distinfo3
-rw-r--r--net/p5-Net-SSH-Expect/pkg-descr7
-rw-r--r--net/p5-Net-SSH-Expect/pkg-plist8
5 files changed, 50 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index f678a751028f..e788b0300790 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -503,6 +503,7 @@
SUBDIR += p5-Net-SMS-PChome
SUBDIR += p5-Net-SNPP
SUBDIR += p5-Net-SSH
+ SUBDIR += p5-Net-SSH-Expect
SUBDIR += p5-Net-SSH-Perl
SUBDIR += p5-Net-SSH2
SUBDIR += p5-Net-Server
diff --git a/net/p5-Net-SSH-Expect/Makefile b/net/p5-Net-SSH-Expect/Makefile
new file mode 100644
index 000000000000..e41ee50fb4c9
--- /dev/null
+++ b/net/p5-Net-SSH-Expect/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: p5-Net-SSH-Expect
+# Date created: 2007-06-30
+# Whom: Tsung-Han Yeh <snowfly@yuntech.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-SSH-Expect
+PORTVERSION= 0.05
+CATEGORIES= net perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Net
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= snowfly@yuntech.edu.tw
+COMMENT= SSH wrapper to execute remote commands
+
+RUN_DEPENDS= ${SITE_PERL}/Expect.pm:${PORTSDIR}/lang/p5-Expect
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::SSH::Expect.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+IGNORE= requires perl 5.8.0 due to dependency. Install lang/perl5.8 and try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net/p5-Net-SSH-Expect/distinfo b/net/p5-Net-SSH-Expect/distinfo
new file mode 100644
index 000000000000..a8c7dbfd979f
--- /dev/null
+++ b/net/p5-Net-SSH-Expect/distinfo
@@ -0,0 +1,3 @@
+MD5 (Net-SSH-Expect-0.05.tar.gz) = cb008bfa1254ea968165664367641c5d
+SHA256 (Net-SSH-Expect-0.05.tar.gz) = 1132c994743f89f20f2c429cdf3eaf5229bebbd53bed3cd8af449b46c2e000c6
+SIZE (Net-SSH-Expect-0.05.tar.gz) = 6960
diff --git a/net/p5-Net-SSH-Expect/pkg-descr b/net/p5-Net-SSH-Expect/pkg-descr
new file mode 100644
index 000000000000..c76dc6e7e0cd
--- /dev/null
+++ b/net/p5-Net-SSH-Expect/pkg-descr
@@ -0,0 +1,7 @@
+This module is a wrapper to the ssh executable that is available in
+your system's $PATH. Use this module to execute commands on the remote SSH
+server. It authenticates with the user and password you passed in the
+constructor's attributes user and password.
+
+Author: Adam Kennedy <cpan@ali.as>
+WWW: http://search.cpan.org/dist/Net-SSH-Expect/
diff --git a/net/p5-Net-SSH-Expect/pkg-plist b/net/p5-Net-SSH-Expect/pkg-plist
new file mode 100644
index 000000000000..f37df1cb44ee
--- /dev/null
+++ b/net/p5-Net-SSH-Expect/pkg-plist
@@ -0,0 +1,8 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Net/SSH/Expect.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSH/Expect/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSH/Expect
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/SSH
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net
+@dirrmtry %%SITE_PERL%%/Net/SSH
+@dirrmtry %%SITE_PERL%%/Net