aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2013-10-10 16:13:00 +0800
committergahr <gahr@FreeBSD.org>2013-10-10 16:13:00 +0800
commit2b912f5da2a3101452e96d3e309318cb79adf1f0 (patch)
treeab1a734eb4b9270e93523cdfd0d743bf3d2857c3
parent3a04bad281f8712d3e1bd34f3f8a5b7e2290a9cb (diff)
downloadfreebsd-ports-gnome-2b912f5da2a3101452e96d3e309318cb79adf1f0.tar.gz
freebsd-ports-gnome-2b912f5da2a3101452e96d3e309318cb79adf1f0.tar.zst
freebsd-ports-gnome-2b912f5da2a3101452e96d3e309318cb79adf1f0.zip
- Convert to USES+=gmake
- STAGE-clean - JOBS-clean
-rw-r--r--textproc/xerces-c3/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/textproc/xerces-c3/Makefile b/textproc/xerces-c3/Makefile
index f6e494ca4d19..b80e35e52534 100644
--- a/textproc/xerces-c3/Makefile
+++ b/textproc/xerces-c3/Makefile
@@ -14,8 +14,7 @@ COMMENT= Validating XML parser from the Apache XML Project
CONFLICTS= xerces_c-[0-9]* xerces-c2-[0-9]*
-USE_GMAKE= yes
-USES= pathfix
+USES= gmake pathfix
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
@@ -23,11 +22,8 @@ CONFIGURE_ARGS+=--with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
--enable-netaccessor-socket
MAKE_ENV+= XERCESCROOT=${WRKSRC}
-MAKE_JOBS_UNSAFE=yes
-
-NO_STAGE= yes
post-install:
- ${LN} -sf libxerces-c-${PORTVERSION:R}.so ${PREFIX}/lib/libxerces-c.so.${PORTVERSION:R:R}
+ ${LN} -sf libxerces-c-${PORTVERSION:R}.so ${STAGEDIR}${PREFIX}/lib/libxerces-c.so.${PORTVERSION:R:R}
test:
cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${MAKE} check