aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjbeich <jbeich@FreeBSD.org>2016-11-10 06:59:05 +0800
committerjbeich <jbeich@FreeBSD.org>2016-11-10 06:59:05 +0800
commit2bce0a143dd8e1ef44fbb2600153419174dd3dc9 (patch)
treeb8b33efe6b10d7630bdc05c623d06407f4509213
parent1104116922e44f8b1c921d8d9fe47a73b1df221e (diff)
downloadfreebsd-ports-gnome-2bce0a143dd8e1ef44fbb2600153419174dd3dc9.tar.gz
freebsd-ports-gnome-2bce0a143dd8e1ef44fbb2600153419174dd3dc9.tar.zst
freebsd-ports-gnome-2bce0a143dd8e1ef44fbb2600153419174dd3dc9.zip
games/zdoom: add .desktop file + icon for it
PR: 213904 Submitted by: Kyle Evans <bsdports@kyle-evans.net> (maintainer)
-rw-r--r--games/zdoom/Makefile8
-rw-r--r--games/zdoom/files/zdoom.xpm83
2 files changed, 89 insertions, 2 deletions
diff --git a/games/zdoom/Makefile b/games/zdoom/Makefile
index f6ec4f4652e7..7db269ba2cff 100644
--- a/games/zdoom/Makefile
+++ b/games/zdoom/Makefile
@@ -3,7 +3,7 @@
PORTNAME= zdoom
PORTVERSION= 2.8.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= games
MAINTAINER= bsdports@kyle-evans.net
@@ -32,8 +32,11 @@ USE_SDL= sdl2
CMAKE_ARGS= -DNO_FMOD:BOOL=ON
CXXFLAGS+= -DSHARE_DIR=\\\"${DATADIR}\\\"
+DESKTOP_ENTRIES= "ZDoom" "" "${PORTNAME}" "${PORTNAME}" "Game;Shooter;" ""
+
PLIST_FILES= bin/${PORTNAME} \
- ${DATADIR}/${PORTNAME}.pk3
+ ${DATADIR}/${PORTNAME}.pk3 \
+ share/pixmaps/${PORTNAME}.xpm
OPTIONS_DEFINE= FLUIDSYNTH
OPTIONS_DEFAULT=FLUIDSYNTH
@@ -48,5 +51,6 @@ do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
${INSTALL_PROGRAM} ${CONFIGURE_WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_DATA} ${CONFIGURE_WRKSRC}/${PORTNAME}.pk3 ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${FILESDIR}/${PORTNAME}.xpm ${STAGEDIR}${PREFIX}/share/pixmaps
.include <bsd.port.mk>
diff --git a/games/zdoom/files/zdoom.xpm b/games/zdoom/files/zdoom.xpm
new file mode 100644
index 000000000000..eae49eb77ffe
--- /dev/null
+++ b/games/zdoom/files/zdoom.xpm
@@ -0,0 +1,83 @@
+/* XPM */
+static char * zdoom_xpm[] = {
+"48 48 32 1",
+" c None",
+". c #ADA990",
+"+ c #999966",
+"@ c #666666",
+"# c #393939",
+"$ c #555555",
+"% c #996666",
+"& c #777777",
+"* c #5F5F5F",
+"= c #333333",
+"- c #4D4D4D",
+"; c #868686",
+"> c #969696",
+", c #1C1C1C",
+"' c #339933",
+") c #336633",
+"! c #66CC66",
+"~ c #66FF66",
+"{ c #66CC33",
+"] c #222222",
+"^ c #333300",
+"/ c #292929",
+"( c #040404",
+"_ c #0C0C0C",
+": c #663333",
+"< c #996633",
+"[ c #CC9966",
+"} c #CC6633",
+"| c #CC9999",
+"1 c #FFCC99",
+"2 c #FF9966",
+"3 c #FFCCCC",
+" ... ",
+" ++@##$+ ",
+" +...+%&+ ",
+" %*=-*&;$=&* ",
+" %**=$@;>@=&*% ",
+" &**@$*@@$-.+& ",
+" %$%@*..$@.. ",
+" ,#@+++@@#& ",
+" $,#$$@@$#=$'' ",
+" )!!!~!{=],,,,]^)'!{') =/, ",
+" )){'~!!'')=],=))'{)'')) /=],( ",
+" )'!!'!)~'{'),)''''''')) @@/==](( ",
+" ^)''')'{{''')'''''),))) $$@$/,( ",
+" ,^))),))''''))'')^,__/$$$-#-(( ",
+" :<[}<,_)))))))),___,]#@@-/]] ",
+" :<|12<:_,,,,,_,#$$-#/,^^=^}}< ",
+" :<[1}::,^,,__,#$-==/,,::^:<<< ",
+" ::&+@#^,,__/)#-=/,,,,-::^<::= ",
+" :*+12[:==_,$-=/,,,,/,#::::=^ ",
+" #*}331}-$]-==/,,,,// ##:=^ ",
+" /]<13[---],,,,,,,]_] ",
+" ,:--/,___]]]]:^___/ ",
+" _______,^^,^,__/# ",
+" ______:::::/$,,/# ",
+" ____^:::=,^^^^,^^ ",
+" __,,:=^,,)))^,,= ",
+" _,,),,,,,^)^^^,, ",
+" ,^,,),__,^))),,^ ",
+" ,,,^^,,,,,)))),, ",
+" ,,,,,,,)^))))^ ",
+" ,,^,,,^^)))))^ ",
+" ,^^,,,,)))))), ",
+" ,^,,,,))^))), ",
+" ],,,,,$&&&*$# ",
+" ],,,]#****$# ",
+" ]]]]]^####, ",
+" ]]]]*,,,,#* ",
+" ,_,#@&&@*/ ",
+" __$####=# ",
+" ,_/$$$$$# ",
+" ,,,$*$$$ ",
+" ],,,$**$# ",
+" ],,,@&&@# ",
+" ],,,$**#= ",
+" ,,=+++%$ ",
+" *%%%*$ ",
+" /$*$#/ ",
+" ],,]] "};