aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorale <ale@FreeBSD.org>2005-10-14 14:18:06 +0800
committerale <ale@FreeBSD.org>2005-10-14 14:18:06 +0800
commit2c32e56b8bcd21469a8cddc85843b9779bbb5d1b (patch)
tree83ba1fde3b7fd2dac62ece00f095d0ae36975c0c
parent92dd72dc509c13446e2bce6cbdf386e373282ce8 (diff)
downloadfreebsd-ports-gnome-2c32e56b8bcd21469a8cddc85843b9779bbb5d1b.tar.gz
freebsd-ports-gnome-2c32e56b8bcd21469a8cddc85843b9779bbb5d1b.tar.zst
freebsd-ports-gnome-2c32e56b8bcd21469a8cddc85843b9779bbb5d1b.zip
Autoselect APACHE2 option if WITH_APACHE2 is defined.
Submitted by: Rick van der Zwet <rick@wzoeterwoude.net>
-rw-r--r--lang/php4/Makefile4
-rw-r--r--lang/php5/Makefile4
-rw-r--r--lang/php53/Makefile4
3 files changed, 12 insertions, 0 deletions
diff --git a/lang/php4/Makefile b/lang/php4/Makefile
index 8d8d32f7fe2b..c4211f81b0bf 100644
--- a/lang/php4/Makefile
+++ b/lang/php4/Makefile
@@ -69,8 +69,12 @@ OPTIONS= REDIRECT "Enable force-cgi-redirect support" off \
PATHINFO "Enable path-info-check support" on
.endif
.if defined(WITH_APACHE)
+.if defined(WITH_APACHE2)
+OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" on
+.else
OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" off
.endif
+.endif
OPTIONS+= DEBUG "Enable debug" off \
MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on \
diff --git a/lang/php5/Makefile b/lang/php5/Makefile
index 1674ca5c05ac..17a4f807600a 100644
--- a/lang/php5/Makefile
+++ b/lang/php5/Makefile
@@ -74,8 +74,12 @@ OPTIONS= REDIRECT "Enable force-cgi-redirect support" off \
PATHINFO "Enable path-info-check support" on
.endif
.if defined(WITH_APACHE)
+.if defined(WITH_APACHE2)
+OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" on
+.else
OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" off
.endif
+.endif
OPTIONS+= DEBUG "Enable debug" off \
MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on
diff --git a/lang/php53/Makefile b/lang/php53/Makefile
index 1674ca5c05ac..17a4f807600a 100644
--- a/lang/php53/Makefile
+++ b/lang/php53/Makefile
@@ -74,8 +74,12 @@ OPTIONS= REDIRECT "Enable force-cgi-redirect support" off \
PATHINFO "Enable path-info-check support" on
.endif
.if defined(WITH_APACHE)
+.if defined(WITH_APACHE2)
+OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" on
+.else
OPTIONS= APACHE2 "Use apache 2.x instead of apache 1.3.x" off
.endif
+.endif
OPTIONS+= DEBUG "Enable debug" off \
MULTIBYTE "Enable zend multibyte support" off \
IPV6 "Enable ipv6 support" on