aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-05-07 01:24:31 +0800
committermarino <marino@FreeBSD.org>2014-05-07 01:24:31 +0800
commit2cdbd72f7b29f6f32df364104e7d8c308c07fa4f (patch)
tree099c1987cdbb750fd331f623d1f5e2f26d93e5b5
parent5003644462711b53ab353c78ee4bdd3a5cb3b8e8 (diff)
downloadfreebsd-ports-gnome-2cdbd72f7b29f6f32df364104e7d8c308c07fa4f.tar.gz
freebsd-ports-gnome-2cdbd72f7b29f6f32df364104e7d8c308c07fa4f.tar.zst
freebsd-ports-gnome-2cdbd72f7b29f6f32df364104e7d8c308c07fa4f.zip
games/doomsday: Unbreak on DragonFly (note OSVERSION used without OPSYS)
OPVERSION always requires coupling with OPSYS to be correct, but normally I let "<" comparison violators go because it never equates to "true" on DragonFly. This is a rare case where DragonFly needs the comparison to be true. Add a couple of OPSYS to fix the recent breakage on DragonFly.
-rw-r--r--games/doomsday/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/games/doomsday/Makefile b/games/doomsday/Makefile
index 10be40bd64c8..3e495fe852ed 100644
--- a/games/doomsday/Makefile
+++ b/games/doomsday/Makefile
@@ -41,7 +41,7 @@ OPENAL_QMAKE_OFF= CONFIG+=deng_noopenal
PORTSCOUT= limit:^\d+\.\d+\.\d+$$
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 1000052
+.if ${OPSYS} == DragonFly || (${OPSYS} == FreeBSD && ${OSVERSION} < 1000052)
LIB_DEPENDS+= libexecinfo.so:${PORTSDIR}/devel/libexecinfo
.endif