aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2010-02-10 22:55:27 +0800
committerskv <skv@FreeBSD.org>2010-02-10 22:55:27 +0800
commit2d773c2f5dd47aacfcc674de59a52734bd6510b1 (patch)
tree68b1bdc07a606593a964a83efd2df32c5d667c6b
parent36f6e0d91052125b5712fa546ab10ff550e81d7f (diff)
downloadfreebsd-ports-gnome-2d773c2f5dd47aacfcc674de59a52734bd6510b1.tar.gz
freebsd-ports-gnome-2d773c2f5dd47aacfcc674de59a52734bd6510b1.tar.zst
freebsd-ports-gnome-2d773c2f5dd47aacfcc674de59a52734bd6510b1.zip
Fix some garbage in last commit (five-second rule in action!)
-rw-r--r--devel/subversion/Makefile6
-rw-r--r--devel/subversion/Makefile.common1
-rw-r--r--devel/subversion16/Makefile6
-rw-r--r--devel/subversion16/Makefile.common1
4 files changed, 4 insertions, 10 deletions
diff --git a/devel/subversion/Makefile b/devel/subversion/Makefile
index c013340188ca..d027a996c339 100644
--- a/devel/subversion/Makefile
+++ b/devel/subversion/Makefile
@@ -74,11 +74,7 @@ SCRIPTS_DATA=
pre-everything::
@${ECHO_MSG} ""
-.if defined(WITH_NEON) && defined(WITH_NEON28)
- @${ECHO_CMD} "It doesn't make sense to depend on neon (neon29) and neon28 choose only one."
- @${FALSE}
-.endif
-.if defined(WITH_NEON) || defined(WITH_NEON28)
+.if defined(WITH_NEON)
@${ECHO_MSG} "WebDAV/Delta-V repository access module enabled."
.else
@${ECHO_MSG} "WebDAV/Delta-V repository access module disabled."
diff --git a/devel/subversion/Makefile.common b/devel/subversion/Makefile.common
index d25c6d66331b..cfee00008791 100644
--- a/devel/subversion/Makefile.common
+++ b/devel/subversion/Makefile.common
@@ -42,6 +42,7 @@ NEON_VER!= ${LOCALBASE}/bin/neon-config --version | \
NEON_VER= 29
.endif
LIB_DEPENDS+= neon.${NEON_VER}:${PORTSDIR}/www/neon${NEON_VER}
+PLIST_SUB+= NEON=""
.else
CONFIGURE_ARGS+= --without-neon
PLIST_SUB+= NEON="@comment "
diff --git a/devel/subversion16/Makefile b/devel/subversion16/Makefile
index c013340188ca..d027a996c339 100644
--- a/devel/subversion16/Makefile
+++ b/devel/subversion16/Makefile
@@ -74,11 +74,7 @@ SCRIPTS_DATA=
pre-everything::
@${ECHO_MSG} ""
-.if defined(WITH_NEON) && defined(WITH_NEON28)
- @${ECHO_CMD} "It doesn't make sense to depend on neon (neon29) and neon28 choose only one."
- @${FALSE}
-.endif
-.if defined(WITH_NEON) || defined(WITH_NEON28)
+.if defined(WITH_NEON)
@${ECHO_MSG} "WebDAV/Delta-V repository access module enabled."
.else
@${ECHO_MSG} "WebDAV/Delta-V repository access module disabled."
diff --git a/devel/subversion16/Makefile.common b/devel/subversion16/Makefile.common
index d25c6d66331b..cfee00008791 100644
--- a/devel/subversion16/Makefile.common
+++ b/devel/subversion16/Makefile.common
@@ -42,6 +42,7 @@ NEON_VER!= ${LOCALBASE}/bin/neon-config --version | \
NEON_VER= 29
.endif
LIB_DEPENDS+= neon.${NEON_VER}:${PORTSDIR}/www/neon${NEON_VER}
+PLIST_SUB+= NEON=""
.else
CONFIGURE_ARGS+= --without-neon
PLIST_SUB+= NEON="@comment "