aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorromain <romain@FreeBSD.org>2017-07-28 01:48:33 +0800
committerromain <romain@FreeBSD.org>2017-07-28 01:48:33 +0800
commit2e30a2af29f03bfbc425e37a4d66d1226ffe0c2f (patch)
treebd6169c1f3ac3220410c4cb73261e708479b04c3
parent5a2b70c8509708543454c8c003120dd255bd93c8 (diff)
downloadfreebsd-ports-gnome-2e30a2af29f03bfbc425e37a4d66d1226ffe0c2f.tar.gz
freebsd-ports-gnome-2e30a2af29f03bfbc425e37a4d66d1226ffe0c2f.tar.zst
freebsd-ports-gnome-2e30a2af29f03bfbc425e37a4d66d1226ffe0c2f.zip
Update to 0.1.5
Remove all patches: it's simpler to cope with the wrong library name in dependent ports while this change has not been merged upstream. PR: 220601 [1], 220661 [2] Submitted by: romain [1], sunpoet [2] With hat: puppet
-rw-r--r--devel/cpp-hocon/Makefile10
-rw-r--r--devel/cpp-hocon/distinfo6
-rw-r--r--devel/cpp-hocon/files/patch-lib_CMakeLists.txt32
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__include__context.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__includer.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__includer__file.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__list.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__mergeable.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__object.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__origin.hpp47
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__parse__options.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__parseable.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__render__options.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__resolve__options.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__value.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_config__value__factory.hpp14
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__document.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__document__factory.hpp28
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__node.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_inc_hocon_path.hpp11
-rw-r--r--devel/cpp-hocon/files/patch-lib_src_config__value__factory.cc63
-rw-r--r--devel/cpp-hocon/files/patch-lib_tests_CMakeLists.txt31
-rw-r--r--devel/cpp-hocon/files/patch-lib_tests_config__value__test.cc20
-rw-r--r--devel/cpp-hocon/pkg-plist5
25 files changed, 12 insertions, 409 deletions
diff --git a/devel/cpp-hocon/Makefile b/devel/cpp-hocon/Makefile
index bb8443327f24..fdb0bb4a289e 100644
--- a/devel/cpp-hocon/Makefile
+++ b/devel/cpp-hocon/Makefile
@@ -1,14 +1,14 @@
# $FreeBSD$
PORTNAME= cpp-hocon
-PORTVERSION= 0.1.4
-PORTREVISION= 1
+PORTVERSION= 0.1.5
CATEGORIES= devel
MAINTAINER= puppet@FreeBSD.org
COMMENT= C++ configuration library
LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libboost_system.so:devel/boost-libs \
libleatherman_util.so:devel/leatherman
@@ -16,7 +16,11 @@ LIB_DEPENDS= libboost_system.so:devel/boost-libs \
USE_GITHUB= yes
GH_ACCOUNT= puppetlabs
+PLIST_SUB+= PORTVERSION="${PORTVERSION}"
+
+CMAKE_ARGS+= -DBUILD_SHARED_LIBS=SHARED
+TEST_TARGET= test
USES= cmake
-CMAKE_ARGS= -DCPP_HOCON_SHARED:BOOL=ON
+USE_LDCONFIG= yes
.include <bsd.port.mk>
diff --git a/devel/cpp-hocon/distinfo b/devel/cpp-hocon/distinfo
index 6df68ceefcb7..b2021e9a17c8 100644
--- a/devel/cpp-hocon/distinfo
+++ b/devel/cpp-hocon/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1477237793
-SHA256 (puppetlabs-cpp-hocon-0.1.4_GH0.tar.gz) = 2274b99dc098122b6e3d2c8d23173d21893555190c5a008e5a9a7d84875c7275
-SIZE (puppetlabs-cpp-hocon-0.1.4_GH0.tar.gz) = 157988
+TIMESTAMP = 1487758806
+SHA256 (puppetlabs-cpp-hocon-0.1.5_GH0.tar.gz) = 4b9d13edf455fd00aedf5a5c151b637f933e796be896f7dc59c9e8255aec99ab
+SIZE (puppetlabs-cpp-hocon-0.1.5_GH0.tar.gz) = 158284
diff --git a/devel/cpp-hocon/files/patch-lib_CMakeLists.txt b/devel/cpp-hocon/files/patch-lib_CMakeLists.txt
deleted file mode 100644
index a42dd7c1b296..000000000000
--- a/devel/cpp-hocon/files/patch-lib_CMakeLists.txt
+++ /dev/null
@@ -1,32 +0,0 @@
---- lib/CMakeLists.txt.orig 2016-09-23 20:45:10 UTC
-+++ lib/CMakeLists.txt
-@@ -75,20 +75,23 @@ set(PROJECT_SOURCES
- ## Without the intermediate target, unexported symbols can't be tested.
- add_library(libprojectsrc OBJECT ${PROJECT_SOURCES})
- set_target_properties(libprojectsrc PROPERTIES POSITION_INDEPENDENT_CODE true)
--
--add_library(lib${PROJECT_NAME} $<TARGET_OBJECTS:libprojectsrc>)
--set_target_properties(lib${PROJECT_NAME} PROPERTIES VERSION "${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}")
--target_link_libraries(lib${PROJECT_NAME}
-+if(CPP_HOCON_SHARED)
-+ add_library(${PROJECT_NAME} SHARED $<TARGET_OBJECTS:libprojectsrc>)
-+else()
-+ add_library(${PROJECT_NAME} $<TARGET_OBJECTS:libprojectsrc>)
-+endif()
-+set_target_properties(${PROJECT_NAME} PROPERTIES VERSION "${PROJECT_VERSION_MAJOR}.${PROJECT_VERSION_MINOR}.${PROJECT_VERSION_PATCH}")
-+target_link_libraries(${PROJECT_NAME}
- ${LEATHERMAN_LIBRARIES}
- ${Boost_LIBRARIES}
- )
-
- # Generate the export header for restricting symbols exported from the library.
- # Restricting symbols has several advantages, noted at https://gcc.gnu.org/wiki/Visibility.
--symbol_exports(lib${PROJECT_NAME} "${CMAKE_CURRENT_LIST_DIR}/inc/hocon/export.h")
-+symbol_exports(${PROJECT_NAME} "${CMAKE_CURRENT_LIST_DIR}/inc/hocon/export.h")
-
- # This correctly handles DLL installation on Windows.
--leatherman_install(lib${PROJECT_NAME})
-+leatherman_install(${PROJECT_NAME})
- install(DIRECTORY inc/hocon DESTINATION include)
-
- add_subdirectory(tests)
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config.hpp
deleted file mode 100644
index 151ce3e8b563..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config.hpp
-@@ -169,7 +169,7 @@ namespace hocon {
- * interface is likely to grow new methods over time, so third-party
- * implementations will break.
- */
-- class LIBCPP_HOCON_EXPORT config : public config_mergeable, public std::enable_shared_from_this<config> {
-+ class CPP_HOCON_EXPORT config : public config_mergeable, public std::enable_shared_from_this<config> {
- friend class config_object;
- friend class config_value;
- friend class config_parseable;
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__include__context.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__include__context.hpp
deleted file mode 100644
index 5918d25b684a..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__include__context.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_include_context.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_include_context.hpp
-@@ -18,7 +18,7 @@ namespace hocon {
- * interface is likely to grow new methods over time, so third-party
- * implementations will break.
- */
-- class LIBCPP_HOCON_EXPORT config_include_context {
-+ class CPP_HOCON_EXPORT config_include_context {
- public:
- /**
- * Tries to find a name relative to whatever is doing the including, for
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__includer.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__includer.hpp
deleted file mode 100644
index 9af9ca1f4ac4..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__includer.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_includer.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_includer.hpp
-@@ -12,7 +12,7 @@ namespace hocon {
- * customize handling of {@code include} statements in config files. You may
- * also want to implement {@link config_includer_file} and {@link config_includer_URL}, or not.
- */
-- class LIBCPP_HOCON_EXPORT config_includer {
-+ class CPP_HOCON_EXPORT config_includer {
- public:
- /**
- * Returns a new includer that falls back to the given includer. This is how
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__includer__file.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__includer__file.hpp
deleted file mode 100644
index 71a207927acd..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__includer__file.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_includer_file.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_includer_file.hpp
-@@ -11,7 +11,7 @@ namespace hocon {
- * If you do not implement this but do implement {@link config_includer},
- * attempts to load files will use the default includer.
- */
-- class LIBCPP_HOCON_EXPORT config_includer_file {
-+ class CPP_HOCON_EXPORT config_includer_file {
- public:
- /**
- * Parses another item to be included. The returned object typically would
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__list.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__list.hpp
deleted file mode 100644
index 29d068d76a2c..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__list.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_list.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_list.hpp
-@@ -34,7 +34,7 @@ namespace hocon {
- *
- */
-
-- class LIBCPP_HOCON_EXPORT config_list : public config_value {
-+ class CPP_HOCON_EXPORT config_list : public config_value {
- public:
- config_list(shared_origin origin) : config_value(move(origin)) {}
-
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__mergeable.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__mergeable.hpp
deleted file mode 100644
index f3d7452d7f9e..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__mergeable.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_mergeable.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_mergeable.hpp
-@@ -5,7 +5,7 @@
-
- namespace hocon {
-
-- class LIBCPP_HOCON_EXPORT config_mergeable {
-+ class CPP_HOCON_EXPORT config_mergeable {
- friend class config_value;
- public:
- /**
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__object.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__object.hpp
deleted file mode 100644
index 1ef29f17fa17..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__object.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_object.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_object.hpp
-@@ -8,7 +8,7 @@
-
- namespace hocon {
-
-- class LIBCPP_HOCON_EXPORT config_object : public config_value {
-+ class CPP_HOCON_EXPORT config_object : public config_value {
- friend class config;
- friend class config_value;
- friend class simple_config_object;
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__origin.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__origin.hpp
deleted file mode 100644
index 9b7d0626dd60..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__origin.hpp
+++ /dev/null
@@ -1,47 +0,0 @@
---- lib/inc/hocon/config_origin.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_origin.hpp
-@@ -36,7 +36,7 @@ namespace hocon {
- *
- * @return string describing the origin
- */
-- LIBCPP_HOCON_EXPORT virtual std::string const& description() const = 0;
-+ CPP_HOCON_EXPORT virtual std::string const& description() const = 0;
-
- /**
- * Returns a {@code ConfigOrigin} based on this one, but with the given
-@@ -55,7 +55,7 @@ namespace hocon {
- * @param lineNumber the new line number
- * @return the created ConfigOrigin
- */
-- LIBCPP_HOCON_EXPORT virtual shared_origin with_line_number(int line_number) const = 0;
-+ CPP_HOCON_EXPORT virtual shared_origin with_line_number(int line_number) const = 0;
-
- /**
- * Returns a line number where the value or exception originated. This will
-@@ -63,7 +63,7 @@ namespace hocon {
- *
- * @return line number or -1 if none is available
- */
-- LIBCPP_HOCON_EXPORT virtual int line_number() const = 0;
-+ CPP_HOCON_EXPORT virtual int line_number() const = 0;
-
- /**
- * Returns any comments that appeared to "go with" this place in the file.
-@@ -75,7 +75,7 @@ namespace hocon {
- * @return any comments that seemed to "go with" this origin, empty list if
- * none
- */
-- LIBCPP_HOCON_EXPORT virtual std::vector<std::string> const& comments() const = 0;
-+ CPP_HOCON_EXPORT virtual std::vector<std::string> const& comments() const = 0;
-
- /**
- * Returns a {@code config_origin} based on this one, but with the given
-@@ -92,7 +92,7 @@ namespace hocon {
- * @param comments the comments used on the returned origin
- * @return the config_origin with the given comments
- */
-- LIBCPP_HOCON_EXPORT virtual shared_origin with_comments(std::vector<std::string> comments) const = 0;
-+ CPP_HOCON_EXPORT virtual shared_origin with_comments(std::vector<std::string> comments) const = 0;
- };
-
- } // namespace hocon
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__parse__options.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__parse__options.hpp
deleted file mode 100644
index 45b8ef7167a7..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__parse__options.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_parse_options.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_parse_options.hpp
-@@ -22,7 +22,7 @@ namespace hocon {
- *
- * ClassLoader is Java-specific, so it was not ported to C++.
- */
-- class LIBCPP_HOCON_EXPORT config_parse_options {
-+ class CPP_HOCON_EXPORT config_parse_options {
- public:
- /**
- * Gets an instance of <code>config_parse_options</code> with all fields
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__parseable.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__parseable.hpp
deleted file mode 100644
index adde77404f48..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__parseable.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_parseable.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_parseable.hpp
-@@ -16,7 +16,7 @@ namespace hocon {
- * interface is likely to grow new methods over time, so third-party
- * implementations will break.
- */
-- class LIBCPP_HOCON_EXPORT config_parseable {
-+ class CPP_HOCON_EXPORT config_parseable {
- public:
- /**
- * Parse whatever it is. The options should come from
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__render__options.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__render__options.hpp
deleted file mode 100644
index ed2796cd80fa..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__render__options.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_render_options.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_render_options.hpp
-@@ -17,7 +17,7 @@ namespace hocon {
- * config_render_options().set_comments(false)
- * </pre>
- */
-- class LIBCPP_HOCON_EXPORT config_render_options {
-+ class CPP_HOCON_EXPORT config_render_options {
- public:
- /** Leaving the default arguments will result in a verbose rendering,
- * which contains comments and therefore is not valid JSON.
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__resolve__options.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__resolve__options.hpp
deleted file mode 100644
index d071230a5e04..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__resolve__options.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_resolve_options.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_resolve_options.hpp
-@@ -27,7 +27,7 @@ namespace hocon {
- * environment variables or other external system information. (Right now,
- * environment variables are the only example.)
- */
-- class LIBCPP_HOCON_EXPORT config_resolve_options {
-+ class CPP_HOCON_EXPORT config_resolve_options {
- public:
- /**
- * Returns the default resolve options. By default the system environment
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__value.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__value.hpp
deleted file mode 100644
index ce7296825c7c..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__value.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/config_value.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_value.hpp
-@@ -36,7 +36,7 @@ namespace hocon {
- * Also, this interface is likely to grow new methods over time, so third-party
- * implementations will break.
- */
-- class LIBCPP_HOCON_EXPORT config_value : public config_mergeable, public std::enable_shared_from_this<config_value> {
-+ class CPP_HOCON_EXPORT config_value : public config_mergeable, public std::enable_shared_from_this<config_value> {
- friend class token;
- friend class value;
- friend class default_transformer;
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__value__factory.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_config__value__factory.hpp
deleted file mode 100644
index ff244d45672e..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_config__value__factory.hpp
+++ /dev/null
@@ -1,14 +0,0 @@
---- lib/inc/hocon/config_value_factory.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/config_value_factory.hpp
-@@ -2,9 +2,10 @@
-
- #include "types.hpp"
- #include "export.h"
-+#include <string>
-
- namespace hocon {
-- class LIBCPP_HOCON_EXPORT config_value_factory {
-+ class CPP_HOCON_EXPORT config_value_factory {
- public:
- /**
- * Creates a {@link ConfigValue} from a plain value, which may be
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__document.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__document.hpp
deleted file mode 100644
index 77db63b1de21..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__document.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/parser/config_document.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/parser/config_document.hpp
-@@ -23,7 +23,7 @@ namespace hocon {
- * Also, this interface is likely to grow new methods over time, so third-party
- * implementations will break.
- */
-- class LIBCPP_HOCON_EXPORT config_document {
-+ class CPP_HOCON_EXPORT config_document {
- public:
- /**
- * Returns a new config_document that is a copy of the current config_document,
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__document__factory.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__document__factory.hpp
deleted file mode 100644
index 6d00cdd8a74d..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__document__factory.hpp
+++ /dev/null
@@ -1,28 +0,0 @@
---- lib/inc/hocon/parser/config_document_factory.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/parser/config_document_factory.hpp
-@@ -18,11 +18,11 @@ namespace hocon { namespace config_docum
- * parse options to control how the file is interpreted
- * @return the parsed configuration
- */
-- LIBCPP_HOCON_EXPORT std::shared_ptr<config_document> parse_file(std::string input_file_path,
-+ CPP_HOCON_EXPORT std::shared_ptr<config_document> parse_file(std::string input_file_path,
- config_parse_options options);
-
- /** Parses a file into a config_document instance using default options. */
-- LIBCPP_HOCON_EXPORT std::shared_ptr<config_document> parse_file(std::string input_file_path);
-+ CPP_HOCON_EXPORT std::shared_ptr<config_document> parse_file(std::string input_file_path);
-
- /**
- * Parses a string which should be valid HOCON or JSON.
-@@ -31,9 +31,9 @@ namespace hocon { namespace config_docum
- * @param options parse options
- * @return the parsed configuration
- */
-- LIBCPP_HOCON_EXPORT std::shared_ptr<config_document> parse_string(std::string s, config_parse_options options);
-+ CPP_HOCON_EXPORT std::shared_ptr<config_document> parse_string(std::string s, config_parse_options options);
-
- /** Parses a string into a config_document instance using default options. */
-- LIBCPP_HOCON_EXPORT std::shared_ptr<config_document> parse_string(std::string s);
-+ CPP_HOCON_EXPORT std::shared_ptr<config_document> parse_string(std::string s);
-
- }} // namespace hocon::config_document_factory
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__node.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__node.hpp
deleted file mode 100644
index f5fbcff5b2cd..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_parser_config__node.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/parser/config_node.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/parser/config_node.hpp
-@@ -18,7 +18,7 @@ namespace hocon {
- * Also, this interface is likely to grow new methods over time, so third-party
- * implementations will break.
- */
-- class LIBCPP_HOCON_EXPORT config_node {
-+ class CPP_HOCON_EXPORT config_node {
- public:
- /**
- * The original text of the input which was used to form this particular
diff --git a/devel/cpp-hocon/files/patch-lib_inc_hocon_path.hpp b/devel/cpp-hocon/files/patch-lib_inc_hocon_path.hpp
deleted file mode 100644
index 0fa53ae9cdf7..000000000000
--- a/devel/cpp-hocon/files/patch-lib_inc_hocon_path.hpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- lib/inc/hocon/path.hpp.orig 2016-09-23 20:45:10 UTC
-+++ lib/inc/hocon/path.hpp
-@@ -10,7 +10,7 @@
-
- namespace hocon {
-
-- class LIBCPP_HOCON_EXPORT path {
-+ class CPP_HOCON_EXPORT path {
- public:
- path();
- explicit path(std::string first, path const& remainder);
diff --git a/devel/cpp-hocon/files/patch-lib_src_config__value__factory.cc b/devel/cpp-hocon/files/patch-lib_src_config__value__factory.cc
deleted file mode 100644
index 592982846c9e..000000000000
--- a/devel/cpp-hocon/files/patch-lib_src_config__value__factory.cc
+++ /dev/null
@@ -1,63 +0,0 @@
---- lib/src/config_value_factory.cc.orig 2016-09-23 20:45:10 UTC
-+++ lib/src/config_value_factory.cc
-@@ -17,27 +17,27 @@ namespace hocon {
- // TODO: If use cases of from_any_ref require other types to produce config_nulls,
- // we can revise this behavior
- shared_value operator()(boost::blank null_value) const {
-- return make_shared<const config_null>(nullptr);
-+ return make_shared<config_null>(nullptr);
- }
-
- shared_value operator()(string str) const {
-- return make_shared<const config_string>(nullptr, str, config_string_type::QUOTED);
-+ return make_shared<config_string>(nullptr, str, config_string_type::QUOTED);
- }
-
- shared_value operator()(int64_t num) const {
-- return make_shared<const config_long>(nullptr, num, "");
-+ return make_shared<config_long>(nullptr, num, "");
- }
-
- shared_value operator()(double num) const {
-- return make_shared<const config_double>(nullptr, num, "");
-+ return make_shared<config_double>(nullptr, num, "");
- }
-
- shared_value operator()(int num) const {
-- return make_shared<const config_int>(nullptr, num, "");
-+ return make_shared<config_int>(nullptr, num, "");
- }
-
- shared_value operator()(bool boolean) const {
-- return make_shared<const config_boolean>(nullptr, boolean);
-+ return make_shared<config_boolean>(nullptr, boolean);
- }
-
- shared_value operator()(vector<unwrapped_value> value_list) const {
-@@ -45,7 +45,7 @@ namespace hocon {
- for (unwrapped_value v : value_list) {
- config_values.emplace_back(boost::apply_visitor(config_value_visitor(), v));
- }
-- return make_shared<const simple_config_list>(nullptr, config_values);
-+ return make_shared<simple_config_list>(nullptr, config_values);
- }
-
- shared_value operator()(unordered_map<string, unwrapped_value> value_map) const {
-@@ -53,7 +53,7 @@ namespace hocon {
- for (auto pair : value_map) {
- config_map[pair.first] = boost::apply_visitor(config_value_visitor(), pair.second);
- }
-- return make_shared<const simple_config_object>(nullptr, config_map);
-+ return make_shared<simple_config_object>(nullptr, config_map);
- }
- };
-
-@@ -62,7 +62,7 @@ namespace hocon {
- if (origin.empty()) {
- origin = "hardcoded value";
- }
-- auto conf_origin = make_shared<const simple_config_origin>(origin);
-+ auto conf_origin = make_shared<simple_config_origin>(origin);
- return boost::apply_visitor(config_value_visitor(), value)->with_origin(conf_origin);
- }
- } // namespace hocon
diff --git a/devel/cpp-hocon/files/patch-lib_tests_CMakeLists.txt b/devel/cpp-hocon/files/patch-lib_tests_CMakeLists.txt
deleted file mode 100644
index 9273fafa82ad..000000000000
--- a/devel/cpp-hocon/files/patch-lib_tests_CMakeLists.txt
+++ /dev/null
@@ -1,31 +0,0 @@
---- lib/tests/CMakeLists.txt.orig 2016-09-23 20:45:10 UTC
-+++ lib/tests/CMakeLists.txt
-@@ -18,23 +18,23 @@ set(TEST_CASES
- program_options.cc
- )
-
--add_executable(lib${PROJECT_NAME}_test $<TARGET_OBJECTS:libprojectsrc> ${TEST_CASES} main.cc)
-+add_executable(${PROJECT_NAME}_test $<TARGET_OBJECTS:libprojectsrc> ${TEST_CASES} main.cc)
-
- if (${CMAKE_SYSTEM_NAME} MATCHES "Linux" OR ${CMAKE_SYSTEM_NAME} MATCHES "SunOS")
-- target_link_libraries(lib${PROJECT_NAME}_test rt)
-+ target_link_libraries(${PROJECT_NAME}_test rt)
- endif()
-
--target_link_libraries(lib${PROJECT_NAME}_test
-+target_link_libraries(${PROJECT_NAME}_test
- ${Boost_LIBRARIES}
- ${LEATHERMAN_LIBRARIES}
- ${CMAKE_THREAD_LIBS_INIT}
- )
-
- if (${CMAKE_SYSTEM_NAME} MATCHES "Darwin" AND BOOST_STATIC AND LEATHERMAN_USE_LOCALES)
-- target_link_libraries(lib${PROJECT_NAME}_test iconv)
-+ target_link_libraries(${PROJECT_NAME}_test iconv)
- endif()
-
--add_test(NAME "unit_tests" COMMAND lib${PROJECT_NAME}_test)
-+add_test(NAME "unit_tests" COMMAND ${PROJECT_NAME}_test)
-
- configure_file (
- "${CMAKE_CURRENT_LIST_DIR}/fixtures.hpp.in"
diff --git a/devel/cpp-hocon/files/patch-lib_tests_config__value__test.cc b/devel/cpp-hocon/files/patch-lib_tests_config__value__test.cc
deleted file mode 100644
index 3cb67ae67c19..000000000000
--- a/devel/cpp-hocon/files/patch-lib_tests_config__value__test.cc
+++ /dev/null
@@ -1,20 +0,0 @@
---- lib/tests/config_value_test.cc.orig 2016-09-23 20:45:10 UTC
-+++ lib/tests/config_value_test.cc
-@@ -91,7 +91,7 @@ TEST_CASE("config object unwraps") {
- auto value2 = config_int::new_number(fake_origin(), int64_t(2), "2");
- auto value3 = config_int::new_number(fake_origin(), int64_t(3), "3");
- unordered_map<string, shared_value> org {{"a", value1}, {"b", value2}, {"c", value3}};
-- auto obj = make_shared<const simple_config_object>(fake_origin(), org);
-+ auto obj = make_shared<simple_config_object>(fake_origin(), org);
- unordered_map<string, unwrapped_value> map {{"a", 1}, {"b", 2}, {"c", 3}};
- unwrapped_value expected(map);
- bool test = expected == obj->unwrapped();
-@@ -103,7 +103,7 @@ TEST_CASE("config list unwraps") {
- auto value2 = config_int::new_number(fake_origin(), int64_t(2), "2");
- auto value3 = config_int::new_number(fake_origin(), int64_t(3), "3");
- vector<shared_value> data { value1, value2, value3 };
-- auto list = make_shared<const simple_config_list>(fake_origin(), data);
-+ auto list = make_shared<simple_config_list>(fake_origin(), data);
- vector<unwrapped_value> v { 1,2,3 };
- unwrapped_value expected(v);
- bool test = expected == list->unwrapped();
diff --git a/devel/cpp-hocon/pkg-plist b/devel/cpp-hocon/pkg-plist
index a5bb0d50dbb9..4a357b05d59e 100644
--- a/devel/cpp-hocon/pkg-plist
+++ b/devel/cpp-hocon/pkg-plist
@@ -14,7 +14,6 @@ include/hocon/config_resolve_options.hpp
include/hocon/config_syntax.hpp
include/hocon/config_value.hpp
include/hocon/config_value_factory.hpp
-include/hocon/config_value_factory.hpp.orig
include/hocon/export.h
include/hocon/functional_list.hpp
include/hocon/parser/config_document.hpp
@@ -24,5 +23,5 @@ include/hocon/path.hpp
include/hocon/program_options.hpp
include/hocon/types.hpp
include/hocon/version.h
-lib/libcpp-hocon.so
-lib/libcpp-hocon.so.0.1.2
+lib/liblibcpp-hocon.so
+lib/liblibcpp-hocon.so.%%PORTVERSION%%