aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2007-03-18 05:57:53 +0800
committerarved <arved@FreeBSD.org>2007-03-18 05:57:53 +0800
commit2e72434f755cea2ef4654bb0dbd04d1b9e4af7da (patch)
treeb26d387b126e41e713c57e6463f6456237952933
parent19be0fffccc8c2d7b73ea0136ed69b8c837f98b9 (diff)
downloadfreebsd-ports-gnome-2e72434f755cea2ef4654bb0dbd04d1b9e4af7da.tar.gz
freebsd-ports-gnome-2e72434f755cea2ef4654bb0dbd04d1b9e4af7da.tar.zst
freebsd-ports-gnome-2e72434f755cea2ef4654bb0dbd04d1b9e4af7da.zip
Fix build after objformat removal and on !i386
-rw-r--r--devel/libopensync/Makefile9
-rw-r--r--devel/libopensync022/Makefile9
2 files changed, 8 insertions, 10 deletions
diff --git a/devel/libopensync/Makefile b/devel/libopensync/Makefile
index 9e1e57c97d6d..89d839015952 100644
--- a/devel/libopensync/Makefile
+++ b/devel/libopensync/Makefile
@@ -30,11 +30,7 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Does not build on FreeBSD 4.x"
-.endif
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+BROKEN= Does not build on FreeBSD 4.x
.endif
pre-everything::
@@ -46,5 +42,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|$${libdir}/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/opensync/Makefile.in \
+ ${WRKSRC}/osengine/Makefile.in
+ ${REINPLACE_CMD} -e "s,echo aout, echo elf,g" ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/devel/libopensync022/Makefile b/devel/libopensync022/Makefile
index 9e1e57c97d6d..89d839015952 100644
--- a/devel/libopensync022/Makefile
+++ b/devel/libopensync022/Makefile
@@ -30,11 +30,7 @@ INSTALLS_SHLIB= yes
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-BROKEN= "Does not build on FreeBSD 4.x"
-.endif
-
-.if ${ARCH} != "i386"
-BROKEN= "Does not compile on !i386"
+BROKEN= Does not build on FreeBSD 4.x
.endif
pre-everything::
@@ -46,5 +42,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|$${libdir}/pkgconfig|${PREFIX}/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in
+ ${REINPLACE_CMD} -e "s,-Werror,," ${WRKSRC}/opensync/Makefile.in \
+ ${WRKSRC}/osengine/Makefile.in
+ ${REINPLACE_CMD} -e "s,echo aout, echo elf,g" ${WRKSRC}/configure
.include <bsd.port.post.mk>