aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2014-02-18 04:32:51 +0800
committerantoine <antoine@FreeBSD.org>2014-02-18 04:32:51 +0800
commit2e88519aabf76b46bebbc85979386cd77073aaa5 (patch)
tree9033104e453a4b77e7b21a7a37e36139219caaf5
parentd873ab03a5202d089d4851a6f8e0872dfe35bb4d (diff)
downloadfreebsd-ports-gnome-2e88519aabf76b46bebbc85979386cd77073aaa5.tar.gz
freebsd-ports-gnome-2e88519aabf76b46bebbc85979386cd77073aaa5.tar.zst
freebsd-ports-gnome-2e88519aabf76b46bebbc85979386cd77073aaa5.zip
- Stage support
- Switch from easy_install to install
-rw-r--r--finance/py-stripe/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/finance/py-stripe/Makefile b/finance/py-stripe/Makefile
index b8d1297abc66..66d70cad8a4b 100644
--- a/finance/py-stripe/Makefile
+++ b/finance/py-stripe/Makefile
@@ -4,7 +4,7 @@
PORTNAME= stripe
PORTVERSION= 1.9.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= finance python
MASTER_SITES= https://code.stripe.com/stripe/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -18,14 +18,11 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}requests1>=0.8.8:${PORTSDIR}/www/py-requests
TEST_DEPENDS:= ${RUN_DEPENDS}
USE_PYTHON= yes
-USE_PYDISTUTILS= easy_install
+USE_PYDISTUTILS= yes
PYDISTUTILS_AUTOPLIST= yes
post-patch:
- @${REINPLACE_CMD} 's/version=version\.VERSION,/version=version.VERSION, zip_safe=False,/' \
- ${WRKSRC}/setup.py
-
-NO_STAGE= yes
+ @${REINPLACE_CMD} "s|, '../VERSION'||" ${WRKSRC}/setup.py
regression-test: build
@cd ${WRKSRC} && ${PYTHON_CMD} ${PYSETUP} test