aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2014-06-12 12:52:30 +0800
committernivit <nivit@FreeBSD.org>2014-06-12 12:52:30 +0800
commit2eca20a4cbface08432c17b79d284bf11e332e38 (patch)
tree4d08e178dce2b4371b06361702f666883cc9504f
parenteeedac798b6b89ad65e71fcbfdf65a99c7228868 (diff)
downloadfreebsd-ports-gnome-2eca20a4cbface08432c17b79d284bf11e332e38.tar.gz
freebsd-ports-gnome-2eca20a4cbface08432c17b79d284bf11e332e38.tar.zst
freebsd-ports-gnome-2eca20a4cbface08432c17b79d284bf11e332e38.zip
- Fix LICENSE type
- Remove MANPAGES option - Use auto plist for Python files - Don't build/install Python files as egg - Add support for stage dir
-rw-r--r--misc/py-yolk/Makefile29
-rw-r--r--misc/py-yolk/pkg-plist3
2 files changed, 12 insertions, 20 deletions
diff --git a/misc/py-yolk/Makefile b/misc/py-yolk/Makefile
index c52bde1f151e..bc95f4f91db5 100644
--- a/misc/py-yolk/Makefile
+++ b/misc/py-yolk/Makefile
@@ -12,34 +12,27 @@ PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
MAINTAINER= nivit@FreeBSD.org
COMMENT= Command-line tool for querying PyPI and Python packages installed
-LICENSE= BSD
+LICENSE= BSD3CLAUSE
-OPTIONSFILE?= ${PORT_DBDIR}/py-${PORTNAME}/options
-OPTIONS_DEFINE= EXAMPLES MANPAGES
-OPTIONS_DEFAULT= MANPAGES
+PYDISTUTILS_AUTOPLIST= yes
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= EXAMPLES
-.if ${PORT_OPTIONS:MMANPAGES}
-MAN1= ${PORTNAME}.1
-.endif
+USE_PYTHON= 2
+USE_PYDISTUTILS= yes
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MEXAMPLES}
EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
.endif
-USE_PYTHON= 2
-USE_PYDISTUTILS= easy_install
-
post-install:
-.if ${PORT_OPTIONS:MMANPAGES}
- ${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.1 ${MANPREFIX}/man/man1/${PORTNAME}.1
-.endif
+ ${INSTALL_DATA} ${WRKSRC}/docs/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1/${PORTNAME}.1
.if ${PORT_OPTIONS:MEXAMPLES}
- @${MKDIR} ${EXAMPLESDIR}
- @cd ${WRKSRC}/examples && ${FIND} . -type d -exec ${MKDIR} ${EXAMPLESDIR}/{} ";"
- cd ${WRKSRC}/examples && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${EXAMPLESDIR}/{} ";"
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ @cd ${WRKSRC}/examples && ${FIND} . -type d -exec ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}/{} ";"
+ cd ${WRKSRC}/examples && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${STAGEDIR}${EXAMPLESDIR}/{} ";"
.endif
.include <bsd.port.pre.mk>
diff --git a/misc/py-yolk/pkg-plist b/misc/py-yolk/pkg-plist
index a57680b577bf..e6601a5e012e 100644
--- a/misc/py-yolk/pkg-plist
+++ b/misc/py-yolk/pkg-plist
@@ -1,4 +1,4 @@
-bin/yolk
+man/man1/yolk.1.gz
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plugins/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plugins/yolk_pkg_manager/README
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plugins/yolk_pkg_manager/setup.py
@@ -10,4 +10,3 @@ bin/yolk
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/plugins/yolk_portage
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/plugins
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
-%%PYTHON_SITELIBDIR%%/%%PYEASYINSTALL_EGG%%