aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-10-28 22:32:07 +0800
committerchinsan <chinsan@FreeBSD.org>2008-10-28 22:32:07 +0800
commit2ed0c62da220b38fd1182aed2c369d2103fed984 (patch)
treeb7826c0277f5c474ad1da9d109b7178b0ef6a0fe
parent76d8b7f89d564a9a76d38a3249fd7070a96033ba (diff)
downloadfreebsd-ports-gnome-2ed0c62da220b38fd1182aed2c369d2103fed984.tar.gz
freebsd-ports-gnome-2ed0c62da220b38fd1182aed2c369d2103fed984.tar.zst
freebsd-ports-gnome-2ed0c62da220b38fd1182aed2c369d2103fed984.zip
Add p5-Getopt-Euclid, Executable Uniform Command-Line Interface Descriptions.
Getopt::Euclid uses your program's own documentation to create a command-line argument parser. This ensures that your program's documented interface and its actual interface always agree. WWW: http://search.cpan.org/dist/Getopt-Euclid/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Getopt-Euclid/Makefile25
-rw-r--r--devel/p5-Getopt-Euclid/distinfo3
-rw-r--r--devel/p5-Getopt-Euclid/pkg-descr5
-rw-r--r--devel/p5-Getopt-Euclid/pkg-plist7
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3e18fcb1b412..e58635889933 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1353,6 +1353,7 @@
SUBDIR += p5-Getargs-Long
SUBDIR += p5-Getopt-ArgvFile
SUBDIR += p5-Getopt-Declare
+ SUBDIR += p5-Getopt-Euclid
SUBDIR += p5-Getopt-Long
SUBDIR += p5-Getopt-Long-Descriptive
SUBDIR += p5-Getopt-Mixed
diff --git a/devel/p5-Getopt-Euclid/Makefile b/devel/p5-Getopt-Euclid/Makefile
new file mode 100644
index 000000000000..f3a5578aa2b3
--- /dev/null
+++ b/devel/p5-Getopt-Euclid/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: devel/p5-Getopt-Euclid
+# Date created: 28 Oct 2008
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Getopt-Euclid
+PORTVERSION= 0.2.0
+DISTVERSIONPREFIX=v
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Executable Uniform Command-Line Interface Descriptions
+
+BUILD_DEPENDS= p5-version>=0:${PORTSDIR}/devel/p5-version
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Getopt::Euclid.3 Getopt::Euclid::HierDemo.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Getopt-Euclid/distinfo b/devel/p5-Getopt-Euclid/distinfo
new file mode 100644
index 000000000000..db8203c6c37a
--- /dev/null
+++ b/devel/p5-Getopt-Euclid/distinfo
@@ -0,0 +1,3 @@
+MD5 (Getopt-Euclid-v0.2.0.tar.gz) = d9389f7dc20ca8efde4730536e1adbef
+SHA256 (Getopt-Euclid-v0.2.0.tar.gz) = 91ebe1e2223952a83f1498fbc6575737570515ce175b7ad839d4079e98a1416f
+SIZE (Getopt-Euclid-v0.2.0.tar.gz) = 25664
diff --git a/devel/p5-Getopt-Euclid/pkg-descr b/devel/p5-Getopt-Euclid/pkg-descr
new file mode 100644
index 000000000000..b6d74101e391
--- /dev/null
+++ b/devel/p5-Getopt-Euclid/pkg-descr
@@ -0,0 +1,5 @@
+Getopt::Euclid uses your program's own documentation to create a
+command-line argument parser. This ensures that your program's documented
+interface and its actual interface always agree.
+
+WWW: http://search.cpan.org/dist/Getopt-Euclid/
diff --git a/devel/p5-Getopt-Euclid/pkg-plist b/devel/p5-Getopt-Euclid/pkg-plist
new file mode 100644
index 000000000000..c4c2862787fb
--- /dev/null
+++ b/devel/p5-Getopt-Euclid/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Euclid/.packlist
+%%SITE_PERL%%/Getopt/Euclid.pm
+%%SITE_PERL%%/Getopt/Euclid/HierDemo.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt/Euclid
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Getopt
+@dirrmtry %%SITE_PERL%%/Getopt/Euclid
+@dirrmtry %%SITE_PERL%%/Getopt