aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2012-11-07 04:43:55 +0800
committerpawel <pawel@FreeBSD.org>2012-11-07 04:43:55 +0800
commit2f20dd084150f64add2a7eb9effdf30f76e851ad (patch)
treeabb535761d68b3e723cca9005a92affeefc899b6
parent7f8073b5eb89cad7359cb8cb9acbfada766b0e03 (diff)
downloadfreebsd-ports-gnome-2f20dd084150f64add2a7eb9effdf30f76e851ad.tar.gz
freebsd-ports-gnome-2f20dd084150f64add2a7eb9effdf30f76e851ad.tar.zst
freebsd-ports-gnome-2f20dd084150f64add2a7eb9effdf30f76e851ad.zip
- Update MASTER_SITES
- Add LICENSE - Add MAKE_JOBS_SAFE - Add option for ALSA support While here: - Fix COMMENT - Add missing deps that package links to PR: ports/171960 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
-rw-r--r--audio/ices/Makefile42
1 files changed, 29 insertions, 13 deletions
diff --git a/audio/ices/Makefile b/audio/ices/Makefile
index c97720a669b0..43aaa5da2dfd 100644
--- a/audio/ices/Makefile
+++ b/audio/ices/Makefile
@@ -1,28 +1,44 @@
-# New ports collection makefile for: ices
-# Date created: 11 Nov 2002
-# Whom: Michael Nottebrock <michaelnottebrock@gmx.net>
-#
+# Created by: Michael Nottebrock <michaelnottebrock@gmx.net>
# $FreeBSD$
-#
PORTNAME= ices
PORTVERSION= 2.0.2
PORTEPOCH= 1
CATEGORIES= audio net
-MASTER_SITES= http://svn.xiph.org/releases/ices/
+MASTER_SITES= http://downloads.xiph.org/releases/ices/ \
+ http://svn.xiph.org/releases/ices/
MAINTAINER= ports@FreeBSD.org
-COMMENT= A vorbis streaming source client for icecast 2
+COMMENT= Vorbis streaming source client for icecast 2
-LIB_DEPENDS= shout:${PORTSDIR}/audio/libshout2 \
+LICENSE= GPLv2
+
+LIB_DEPENDS= ogg:${PORTSDIR}/audio/libogg \
+ shout:${PORTSDIR}/audio/libshout2 \
vorbis:${PORTSDIR}/audio/libvorbis \
- xml2:${PORTSDIR}/textproc/libxml2
+ speex:${PORTSDIR}/audio/speex \
+ theora:${PORTSDIR}/multimedia/libtheora
+
+OPTIONS_DEFINE= ALSA
-CFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
-LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-CONFIGURE_ARGS+= --disable-alsa --disable-roaraudio --disable-sun-audio
+USE_BZIP2= yes
+USE_GNOME= libxml2
USE_GMAKE= yes
+USE_ICONV= yes
GNU_CONFIGURE= yes
-USE_BZIP2= yes
+CONFIGURE_ARGS= --disable-roaraudio --disable-sun-audio
+USE_PKGCONFIG= build
+MAKE_JOBS_SAFE= yes
+
+CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MALSA}
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
+.else
+CONFIGURE_ARGS+=--disable-alsa
+.endif
.include <bsd.port.mk>