aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-03-28 12:47:53 +0800
committerBryan Drewery <bdrewery@FreeBSD.org>2014-03-28 12:47:53 +0800
commit2f86ccfa61970677c6ae3180c5145380c5fb7591 (patch)
tree63c5bd0c73ae09000bd9fed937c4156937a8b5ae
parent31bedcfd946c11f4eee901019862bad6cd543087 (diff)
downloadfreebsd-ports-gnome-2f86ccfa61970677c6ae3180c5145380c5fb7591.tar.gz
freebsd-ports-gnome-2f86ccfa61970677c6ae3180c5145380c5fb7591.tar.zst
freebsd-ports-gnome-2f86ccfa61970677c6ae3180c5145380c5fb7591.zip
- Fix error running 'make stage' when NO_STAGE is set:
touch: /usr/ports/mail/qmail/work/.stage_done.qmail._var_qmail: No such file or directory With hat: portmgr
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 711ea8bc0259..6b7f7c655c3a 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3174,6 +3174,13 @@ build: configure
@${TOUCH} ${TOUCH_FLAGS} ${BUILD_COOKIE}
.endif
+# Disable staging. Be non-fatal here as some scripts may just call it as a
+# matter of correctness in their ordering.
+.if defined(NO_STAGE) && !target(stage)
+stage:
+ @${ECHO_MSG} "===> This port does not yet support staging"
+.endif
+
# Disable install
.if defined(NO_INSTALL) && !target(do-install)
do-install: