aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkoobs <koobs@FreeBSD.org>2016-01-08 13:05:35 +0800
committerkoobs <koobs@FreeBSD.org>2016-01-08 13:05:35 +0800
commit2fbcd7a6117a2a475838fee1ed193fca672a3acd (patch)
tree712cc49b51fced27dd834deac930954fb20720c7
parent3dad774716f39c3c89aaf6f26946cde76401d42b (diff)
downloadfreebsd-ports-gnome-2fbcd7a6117a2a475838fee1ed193fca672a3acd.tar.gz
freebsd-ports-gnome-2fbcd7a6117a2a475838fee1ed193fca672a3acd.tar.zst
freebsd-ports-gnome-2fbcd7a6117a2a475838fee1ed193fca672a3acd.zip
[NEW] net/py-matrix-synapse: Matrix protocol reference homeserver
Matrix is an ambitious new ecosystem for open federated Instant Messaging and VoIP. The basics you need to know to get up and running are: * Everything in Matrix happens in a room. Rooms are distributed and do not exist on any single server. Rooms can be located using convenience aliases like #matrix:matrix.org or #test:localhost:8448. * Matrix user IDs look like @matthew:matrix.org (although in the future you will normally refer to yourself and others using a 3PID: email address, phone number, etc rather than manipulating Matrix user IDs) Synapse is currently in rapid development, but as of version 0.5 we believe it is sufficiently stable to be run as an internet-facing service for real usage! WWW: https://www.matrix.org PR: 205914 Submitted by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
-rw-r--r--net/Makefile1
-rw-r--r--net/py-matrix-synapse/Makefile54
-rw-r--r--net/py-matrix-synapse/distinfo2
-rw-r--r--net/py-matrix-synapse/files/patch-tox.ini20
-rw-r--r--net/py-matrix-synapse/pkg-descr14
5 files changed, 91 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index 5e40be3d6d1f..9c3fbc770290 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -947,6 +947,7 @@
SUBDIR += py-libcloud
SUBDIR += py-libdnet
SUBDIR += py-libnet
+ SUBDIR += py-matrix-synapse
SUBDIR += py-maxminddb
SUBDIR += py-miniupnpc
SUBDIR += py-msrplib
diff --git a/net/py-matrix-synapse/Makefile b/net/py-matrix-synapse/Makefile
new file mode 100644
index 000000000000..99ff8c557551
--- /dev/null
+++ b/net/py-matrix-synapse/Makefile
@@ -0,0 +1,54 @@
+# Created by: Brendan Molloy <brendan+freebsd@bbqsrc.net>
+# $FreeBSD$
+
+PORTNAME= matrix-synapse
+DISTVERSIONPREFIX= v
+DISTVERSION= 0.12.0
+CATEGORIES= net python
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= brendan+freebsd@bbqsrc.net
+COMMENT= Matrix protocol reference homeserver
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}virtualenv>0:${PORTSDIR}/devel/py-virtualenv \
+ ${PYTHON_PKGNAMEPREFIX}tox>0:${PORTSDIR}/devel/py-tox
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}frozendict>=0.4:${PORTSDIR}/devel/py-frozendict \
+ ${PYTHON_PKGNAMEPREFIX}unpaddedbase64>=1.0.1:${PORTSDIR}/devel/py-unpaddedbase64 \
+ ${PYTHON_PKGNAMEPREFIX}canonicaljson>=1.0.0:${PORTSDIR}/devel/py-canonicaljson \
+ ${PYTHON_PKGNAMEPREFIX}signedjson>=1.0.0:${PORTSDIR}/security/py-signedjson \
+ ${PYTHON_PKGNAMEPREFIX}pynacl>=0.3.0:${PORTSDIR}/security/py-pynacl \
+ ${PYTHON_PKGNAMEPREFIX}service_identity>=1.0.0:${PORTSDIR}/security/py-service_identity \
+ ${PYTHON_PKGNAMEPREFIX}twisted>=15.1.0:${PORTSDIR}/devel/py-twisted \
+ ${PYTHON_PKGNAMEPREFIX}openssl>=0.14:${PORTSDIR}/security/py-openssl \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:${PORTSDIR}/devel/py-yaml \
+ ${PYTHON_PKGNAMEPREFIX}pyasn1>0:${PORTSDIR}/devel/py-pyasn1 \
+ ${PYTHON_PKGNAMEPREFIX}daemonize>0:${PORTSDIR}/devel/py-daemonize \
+ ${PYTHON_PKGNAMEPREFIX}bcrypt>0:${PORTSDIR}/security/py-bcrypt \
+ ${PYTHON_PKGNAMEPREFIX}pillow>0:${PORTSDIR}/graphics/py-pillow \
+ ${PYTHON_PKGNAMEPREFIX}pydenticon>0:${PORTSDIR}/devel/py-pydenticon \
+ ${PYTHON_PKGNAMEPREFIX}ujson>0:${PORTSDIR}/devel/py-ujson \
+ ${PYTHON_PKGNAMEPREFIX}blist>0:${PORTSDIR}/devel/py-blist \
+ ${PYTHON_PKGNAMEPREFIX}pysaml2>0:${PORTSDIR}/security/py-pysaml2 \
+ ${PYTHON_PKGNAMEPREFIX}pymacaroons-pynacl>0:${PORTSDIR}/security/py-pymacaroons-pynacl \
+ ${PYTHON_PKGNAMEPREFIX}simplejson>0:${PORTSDIR}/devel/py-simplejson \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:${PORTSDIR}/databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}matrix-angular-sdk>0:${PORTSDIR}/devel/py-matrix-angular-sdk
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_ACCOUNT= matrix-org
+GH_PROJECT= synapse
+
+NO_ARCH= yes
+
+do-test:
+ # -epy27 added to skip running python packaging and other dist tests
+ @(cd ${WRKSRC} && ${PYTHON_CMD} ${PYDISTUTILS_SETUP} ${TEST_TARGET} \
+ -a "-epy27")
+
+.include <bsd.port.mk>
diff --git a/net/py-matrix-synapse/distinfo b/net/py-matrix-synapse/distinfo
new file mode 100644
index 000000000000..f67bc2f0a69e
--- /dev/null
+++ b/net/py-matrix-synapse/distinfo
@@ -0,0 +1,2 @@
+SHA256 (matrix-org-synapse-v0.12.0_GH0.tar.gz) = 26a3d97c7ff97ce970d042f6e07d3f8af7477504da3e208aa6d811f8f999b8e0
+SIZE (matrix-org-synapse-v0.12.0_GH0.tar.gz) = 572984
diff --git a/net/py-matrix-synapse/files/patch-tox.ini b/net/py-matrix-synapse/files/patch-tox.ini
new file mode 100644
index 000000000000..5c59069f6e15
--- /dev/null
+++ b/net/py-matrix-synapse/files/patch-tox.ini
@@ -0,0 +1,20 @@
+--- tox.ini.orig 2016-01-04 14:02:50 UTC
++++ tox.ini
+@@ -10,8 +10,9 @@ deps =
+ junitxml
+ setenv =
+ PYTHONDONTWRITEBYTECODE = no_byte_code
++# Assumes bash unnecessarily
+ commands =
+- /bin/bash -c "coverage run {env:COVERAGE_OPTS:} --source={toxinidir}/synapse \
++ /bin/sh -c "coverage run {env:COVERAGE_OPTS:} --source={toxinidir}/synapse \
+ {envbindir}/trial {env:TRIAL_FLAGS:} {posargs:tests} {env:TOXSUFFIX:}"
+ {env:DUMP_COVERAGE_COMMAND:coverage report -m}
+
+@@ -26,4 +27,5 @@ skip_install = True
+ basepython = python2.7
+ deps =
+ flake8
+-commands = /bin/bash -c "flake8 synapse {env:PEP8SUFFIX:}"
++# Assumes bash unnecessarily
++commands = /bin/sh -c "flake8 synapse {env:PEP8SUFFIX:}"
diff --git a/net/py-matrix-synapse/pkg-descr b/net/py-matrix-synapse/pkg-descr
new file mode 100644
index 000000000000..a39d0ceac87f
--- /dev/null
+++ b/net/py-matrix-synapse/pkg-descr
@@ -0,0 +1,14 @@
+Matrix is an ambitious new ecosystem for open federated Instant Messaging and
+VoIP. The basics you need to know to get up and running are:
+
+ * Everything in Matrix happens in a room. Rooms are distributed and do not
+ exist on any single server. Rooms can be located using convenience
+ aliases like #matrix:matrix.org or #test:localhost:8448.
+ * Matrix user IDs look like @matthew:matrix.org (although in the future you
+ will normally refer to yourself and others using a 3PID: email address,
+ phone number, etc rather than manipulating Matrix user IDs)
+
+Synapse is currently in rapid development, but as of version 0.5 we believe it
+is sufficiently stable to be run as an internet-facing service for real usage!
+
+WWW: https://www.matrix.org