aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-12-07 17:43:10 +0800
committermarino <marino@FreeBSD.org>2014-12-07 17:43:10 +0800
commit2fdfc0bc74c730bd0b459e631f0c1b4779405f24 (patch)
treeeb97cd54974f6c3f54c9593f24e14eb3544e49a5
parent9bd60d35a112da142bd832e6c912695626dd6223 (diff)
downloadfreebsd-ports-gnome-2fdfc0bc74c730bd0b459e631f0c1b4779405f24.tar.gz
freebsd-ports-gnome-2fdfc0bc74c730bd0b459e631f0c1b4779405f24.tar.zst
freebsd-ports-gnome-2fdfc0bc74c730bd0b459e631f0c1b4779405f24.zip
Limit pgsql to 9.2 on four databases category ports
As the result of a recent exp-run for postgresql 9.3, several ports failed to build as a result. Most could likely be fixed by updating the port to a later available version. Until that happens, set the maximum version of pgsql to 9.2 for these ports. * pg_rman (1.23) : version 1.27 is available * pg_statsinfo (2.4.1) : version 2.5.0 available, works on pgsql 9.3 * pgpool-II (3.1.6) : version 3.4 available, works on pgsql 9.3 * pgpool-II30 (3.0.4) PR: 195281
-rw-r--r--databases/pg_rman/Makefile2
-rw-r--r--databases/pg_statsinfo/Makefile2
-rw-r--r--databases/pgpool-II-30/Makefile2
-rw-r--r--databases/pgpool-II/Makefile2
4 files changed, 4 insertions, 4 deletions
diff --git a/databases/pg_rman/Makefile b/databases/pg_rman/Makefile
index 1ccc6c82b0e1..631e66b594d3 100644
--- a/databases/pg_rman/Makefile
+++ b/databases/pg_rman/Makefile
@@ -9,7 +9,7 @@ MASTER_SITES= http://pg-rman.googlecode.com/files/
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Online backup and restore tool for PostgreSQL
-USES= gmake pgsql
+USES= gmake pgsql:9.2-
WANT_PGSQL= client server
MAKE_ARGS= USE_PGXS=1
PLIST_FILES= bin/pg_rman
diff --git a/databases/pg_statsinfo/Makefile b/databases/pg_statsinfo/Makefile
index 7e7db35333e7..51f06192bc7b 100644
--- a/databases/pg_statsinfo/Makefile
+++ b/databases/pg_statsinfo/Makefile
@@ -8,7 +8,7 @@ MASTER_SITES= http://pgfoundry.org/frs/download.php/3429/
MAINTAINER= kuriyama@FreeBSD.org
COMMENT= Monitor statistics and activity of PostgreSQL
-USES= gmake pgsql
+USES= gmake pgsql:9.2-
WANT_PGSQL= server
MAKE_ARGS= USE_PGXS=1 LDFLAGS=-lkvm
diff --git a/databases/pgpool-II-30/Makefile b/databases/pgpool-II-30/Makefile
index f21bb6cbbe73..a0e7e468fb21 100644
--- a/databases/pgpool-II-30/Makefile
+++ b/databases/pgpool-II-30/Makefile
@@ -15,7 +15,7 @@ LICENSE= MIT
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake pgsql libtool
+USES= gmake pgsql:9.2- libtool
USE_LDCONFIG= yes
CONFLICTS= pgpool-3.* pgpool-II-3.* pgpool-II-22-* pgpool-II-23-*
diff --git a/databases/pgpool-II/Makefile b/databases/pgpool-II/Makefile
index 784cd084c34a..341d472fa2bc 100644
--- a/databases/pgpool-II/Makefile
+++ b/databases/pgpool-II/Makefile
@@ -15,7 +15,7 @@ LICENSE= MIT
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= gmake pgsql libtool
+USES= gmake pgsql:9.2- libtool
USE_LDCONFIG= yes
USE_OPENSSL= yes
CONFIGURE_ARGS= --with-openssl