aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2015-05-05 19:19:15 +0800
committerolgeni <olgeni@FreeBSD.org>2015-05-05 19:19:15 +0800
commit2fe63a96bb7cbc911ab8495075afeedcde9fc90e (patch)
tree5350c14dec25c062cfe64bde6ce0b4305daee9fd
parentf106ab7b8cba3cd3f5ec63c5710b229d80bcc713 (diff)
downloadfreebsd-ports-gnome-2fe63a96bb7cbc911ab8495075afeedcde9fc90e.tar.gz
freebsd-ports-gnome-2fe63a96bb7cbc911ab8495075afeedcde9fc90e.tar.zst
freebsd-ports-gnome-2fe63a96bb7cbc911ab8495075afeedcde9fc90e.zip
Upgrade to version 1.0.1.
- Add LICENSE - Remove unnecessary GitHub variables - Cleanup and remove @dirrmtry
-rw-r--r--www/cowboy/Makefile17
-rw-r--r--www/cowboy/distinfo4
-rw-r--r--www/cowboy/pkg-plist51
3 files changed, 10 insertions, 62 deletions
diff --git a/www/cowboy/Makefile b/www/cowboy/Makefile
index 2acd959da829..e547887c62f0 100644
--- a/www/cowboy/Makefile
+++ b/www/cowboy/Makefile
@@ -1,12 +1,14 @@
# $FreeBSD$
PORTNAME= cowboy
-PORTVERSION= 1.0.0
+PORTVERSION= 1.0.1
CATEGORIES= www
MAINTAINER= olgeni@FreeBSD.org
COMMENT= Small, fast and modular HTTP server written in Erlang
+LICENSE= ISCL
+
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang \
cowlib>=1.0.0:${PORTSDIR}/devel/cowlib
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang \
@@ -18,17 +20,14 @@ PLIST_SUB= VERSION="${PORTVERSION}"
USES= gmake
USE_GITHUB= yes
GH_ACCOUNT= ninenines
-GH_PROJECT= cowboy
-GH_COMMIT= 021f4f6
-GH_TAGNAME= ${PORTVERSION}
do-install:
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
cd ${WRKSRC}/examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}/ebin
- @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}/src
- ${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}/ebin
- ${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/cowboy-${PORTVERSION}/src
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
+ @${MKDIR} ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
+ ${INSTALL_DATA} ${WRKSRC}/ebin/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/ebin
+ ${INSTALL_DATA} ${WRKSRC}/src/* ${STAGEDIR}${PREFIX}/lib/erlang/lib/${PORTNAME}-${PORTVERSION}/src
.include <bsd.port.mk>
diff --git a/www/cowboy/distinfo b/www/cowboy/distinfo
index eaddae07269c..2804a6522755 100644
--- a/www/cowboy/distinfo
+++ b/www/cowboy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cowboy-1.0.0.tar.gz) = 62e0c37dd96094914d9d565b15c8f8c02a72514dd32ffefb36fea6f9ab3c7f60
-SIZE (cowboy-1.0.0.tar.gz) = 4790037
+SHA256 (ninenines-cowboy-1.0.1_GH0.tar.gz) = 23c7acbfbc2017c60f645ebd1fc0d000952cefedae47701a122ccd6c68b6437e
+SIZE (ninenines-cowboy-1.0.1_GH0.tar.gz) = 4790457
diff --git a/www/cowboy/pkg-plist b/www/cowboy/pkg-plist
index 0eefe7a6619a..bc6bdb062817 100644
--- a/www/cowboy/pkg-plist
+++ b/www/cowboy/pkg-plist
@@ -186,54 +186,3 @@ lib/erlang/lib/cowboy-%%VERSION%%/src/cowboy_websocket_handler.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket_app.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/websocket_sup.erl
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/websocket/src/ws_handler.erl
-@dirrmtry lib/erlang/lib/cowboy-%%VERSION%%/src
-@dirrmtry lib/erlang/lib/cowboy-%%VERSION%%/ebin
-@dirrmtry lib/erlang/lib/cowboy-%%VERSION%%
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/websocket/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/websocket/priv/static
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/websocket/priv
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/websocket
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/web_server/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/web_server/priv
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/web_server
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/upload/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/upload/priv
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/upload
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/static_world/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/static_world/priv
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/static_world
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ssl_hello_world/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ssl_hello_world/priv/ssl
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ssl_hello_world/priv
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/ssl_hello_world
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_stream_response/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_stream_response
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_pastebin/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_pastebin/priv
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_pastebin
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_hello_world/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_hello_world
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_basic_auth/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/rest_basic_auth
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/markdown_middleware/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/markdown_middleware/priv
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/markdown_middleware
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/hello_world/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/hello_world
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/eventsource/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/eventsource/priv
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/eventsource
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/error_hook/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/error_hook
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/echo_post/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/echo_post
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/echo_get/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/echo_get
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/cookie/templates
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/cookie/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/cookie
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/compress_response/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/compress_response
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/chunked_hello_world/src
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%/chunked_hello_world
-%%PORTEXAMPLES%%@dirrmtry %%EXAMPLESDIR%%