aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorclive <clive@FreeBSD.org>2002-09-03 01:21:05 +0800
committerclive <clive@FreeBSD.org>2002-09-03 01:21:05 +0800
commit3039467cbd567cb0bbb35affe2e0eb649538ab4b (patch)
treecc92754bf3f8191daa759dd402a52a9de0f80a4f
parent2cf4f7b6e65aa0cc1658993957bd9b3b7111923d (diff)
downloadfreebsd-ports-gnome-3039467cbd567cb0bbb35affe2e0eb649538ab4b.tar.gz
freebsd-ports-gnome-3039467cbd567cb0bbb35affe2e0eb649538ab4b.tar.zst
freebsd-ports-gnome-3039467cbd567cb0bbb35affe2e0eb649538ab4b.zip
Unbreak this port on -CURRENT.
-rw-r--r--www/bk2site/Makefile1
-rw-r--r--www/bk2site/files/patch-iwebstream.C22
-rw-r--r--www/bk2site/files/patch-reference.C35
3 files changed, 58 insertions, 0 deletions
diff --git a/www/bk2site/Makefile b/www/bk2site/Makefile
index aea102380356..bf98cb15e147 100644
--- a/www/bk2site/Makefile
+++ b/www/bk2site/Makefile
@@ -38,6 +38,7 @@ USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix="${PREFIX}" --enable-standard-datadir
+CONFIGURE_ENV= CPPFLAGS=-Wno-deprecated
PLIST_SUB= CGIDIR="${CGIDIR}" ICONSDIR="${ICONSDIR}"
diff --git a/www/bk2site/files/patch-iwebstream.C b/www/bk2site/files/patch-iwebstream.C
new file mode 100644
index 000000000000..2b9fbe5f36e1
--- /dev/null
+++ b/www/bk2site/files/patch-iwebstream.C
@@ -0,0 +1,22 @@
+--- iwebstream.C~ Tue Sep 3 01:05:42 2002
++++ iwebstream.C Tue Sep 3 01:08:08 2002
+@@ -33,7 +33,7 @@
+ //#define DEBUG_TIMEOUT
+
+ // The constructor.
+-iwebstream::iwebstream(string url, int timeout = 30) : defaultTimeout(timeout), data(""), position(0) {
++iwebstream::iwebstream(string url, int timeout) : defaultTimeout(timeout), data(""), position(0) {
+ string origurl = url;
+ string method;
+ string host;
+@@ -424,8 +424,8 @@
+ // Case is ignored in comparisions.
+ // If begin is not found, return "". Move position to point to char after end;
+ // If end == "" then just find begin and place position just after it
+-string iwebstream::findTag(const string & begin, const string & end, const string & after = "",
+- const string & before = "") {
++string iwebstream::findTag(const string & begin, const string & end, const string & after,
++ const string & before) {
+ // cout << "findTag begin=" << begin << "=" << endl
+ // << "end=" << end << "=" << endl
+ // << "after=" << after << "=" << endl
diff --git a/www/bk2site/files/patch-reference.C b/www/bk2site/files/patch-reference.C
new file mode 100644
index 000000000000..97cc0ee28551
--- /dev/null
+++ b/www/bk2site/files/patch-reference.C
@@ -0,0 +1,35 @@
+--- reference.C~ Tue Sep 3 01:02:48 2002
++++ reference.C Tue Sep 3 01:04:14 2002
+@@ -1189,7 +1189,7 @@
+
+ The hard work is done by FolderCommentParser
+ */
+-void referenceTree::fixCommentCommands(const string parentFolderHTML = ""){
++void referenceTree::fixCommentCommands(const string parentFolderHTML){
+ for (vector<reference>::iterator i = contents.begin(); i != contents.end(); ++i){
+ reference& r = *i;
+ replaceAll(r.comment,"&lt;","<");
+@@ -1398,7 +1398,7 @@
+ returns the number of elements added.
+ Only adds URLS that are not Private and not Aliasof another one and
+ are not under avoidFolder. */
+-void referenceTree::makeVector(vector<reference> & vr, const string & avoidFolder = "")
++void referenceTree::makeVector(vector<reference> & vr, const string & avoidFolder)
+ {
+ for (vector<reference>::iterator i = contents.begin(); i != contents.end(); ++i){
+ reference & r = *i;
+@@ -1466,10 +1466,10 @@
+ void referenceTree::createSiteH(const string varValues[], vector<reference> & allReferences,
+ channelContainer & channels,
+ fileView & baseView, fileView & otherView,
+- vector<reference> & newsItems, int depth = 0,
+- string navigateBar = "", string searchNavBar = "",
+- string parentTitle = "", string folderTitle="",
+- string filePath = "") {
++ vector<reference> & newsItems, int depth,
++ string navigateBar, string searchNavBar,
++ string parentTitle, string folderTitle,
++ string filePath ) {
+ string ofileName;
+ fileView & fv = baseView;
+ string fileContents;