aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-04-26 12:47:27 +0800
committermarcus <marcus@FreeBSD.org>2003-04-26 12:47:27 +0800
commit3075a08a871fbf3c37c45f30b52e9aba547f965a (patch)
tree4c89baaadddf223e28349eb96e438bc892475aaa
parent7b253572853e595c81a142bef3680f69e0c11566 (diff)
downloadfreebsd-ports-gnome-3075a08a871fbf3c37c45f30b52e9aba547f965a.tar.gz
freebsd-ports-gnome-3075a08a871fbf3c37c45f30b52e9aba547f965a.tar.zst
freebsd-ports-gnome-3075a08a871fbf3c37c45f30b52e9aba547f965a.zip
Don't call free when we haven't actually malloc'd any memory. This should
fix an abort on -CURRENT. Reported by: walt <wa1ter@myrealbox.com>
-rw-r--r--news/pan2/Makefile1
-rw-r--r--news/pan2/files/patch-pan_base_article.c10
2 files changed, 11 insertions, 0 deletions
diff --git a/news/pan2/Makefile b/news/pan2/Makefile
index d5ddcf827d4c..78562ae8b0dd 100644
--- a/news/pan2/Makefile
+++ b/news/pan2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= pan2
PORTVERSION= 0.13.95
+PORTREVISION= 1
CATEGORIES= news gnome
MASTER_SITES= http://pan.rebelbase.com/download/releases/${PORTVERSION}/SOURCE/ \
http://pan.rebelbase.com/download/obsolete/${PORTVERSION}/SOURCE/ \
diff --git a/news/pan2/files/patch-pan_base_article.c b/news/pan2/files/patch-pan_base_article.c
new file mode 100644
index 000000000000..20ee6780549a
--- /dev/null
+++ b/news/pan2/files/patch-pan_base_article.c
@@ -0,0 +1,10 @@
+--- pan/base/article.c.orig Sat Apr 26 00:33:54 2003
++++ pan/base/article.c Sat Apr 26 00:45:00 2003
+@@ -505,7 +505,6 @@
+ if (changed_qty > 0)
+ articles_set_dirty (changed, changed_qty);
+
+- g_free (changed);
+ }
+
+