aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2006-04-20 22:34:47 +0800
committertobez <tobez@FreeBSD.org>2006-04-20 22:34:47 +0800
commit30846696151d5faa26cecf454bf0a6599d0b19a6 (patch)
tree5db8f5b412c9ba916a4243a884546b290938b3e7
parent1df4bfad251c6d6669f191e3a8b504ac7a0a4268 (diff)
downloadfreebsd-ports-gnome-30846696151d5faa26cecf454bf0a6599d0b19a6.tar.gz
freebsd-ports-gnome-30846696151d5faa26cecf454bf0a6599d0b19a6.tar.zst
freebsd-ports-gnome-30846696151d5faa26cecf454bf0a6599d0b19a6.zip
Add devel/p5-Class-Prototyped, a Perl module that facilitates fast
prototype-based OO programming.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Class-Prototyped/Makefile23
-rw-r--r--devel/p5-Class-Prototyped/distinfo3
-rw-r--r--devel/p5-Class-Prototyped/pkg-descr6
-rw-r--r--devel/p5-Class-Prototyped/pkg-plist8
5 files changed, 41 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 9ba7a73f9c8a..9374a9cf12aa 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -781,6 +781,7 @@
SUBDIR += p5-Class-ObjectTemplate-DB
SUBDIR += p5-Class-Observable
SUBDIR += p5-Class-ParmList
+ SUBDIR += p5-Class-Prototyped
SUBDIR += p5-Class-ReturnValue
SUBDIR += p5-Class-Roles
SUBDIR += p5-Class-Singleton
diff --git a/devel/p5-Class-Prototyped/Makefile b/devel/p5-Class-Prototyped/Makefile
new file mode 100644
index 000000000000..4cd767403963
--- /dev/null
+++ b/devel/p5-Class-Prototyped/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: devel/p5-Class-Prototyped
+# Date created: 20 April 2006
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Class-Prototyped
+PORTVERSION= 1.10
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Class
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Fast prototype-based OO programming in Perl
+
+PERL_CONFIGURE= yes
+
+MAN3= Class::Prototyped.3 \
+ Class::Prototyped::why.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Class-Prototyped/distinfo b/devel/p5-Class-Prototyped/distinfo
new file mode 100644
index 000000000000..a9891d8a6c78
--- /dev/null
+++ b/devel/p5-Class-Prototyped/distinfo
@@ -0,0 +1,3 @@
+MD5 (Class-Prototyped-1.10.tar.gz) = 82d22ef4628e276b2eb7d4debabdf31d
+SHA256 (Class-Prototyped-1.10.tar.gz) = c180f1c71d4f3f1141b2c354c8110acfa7cfa910785a30d358028d104ed37545
+SIZE (Class-Prototyped-1.10.tar.gz) = 59450
diff --git a/devel/p5-Class-Prototyped/pkg-descr b/devel/p5-Class-Prototyped/pkg-descr
new file mode 100644
index 000000000000..669df655563c
--- /dev/null
+++ b/devel/p5-Class-Prototyped/pkg-descr
@@ -0,0 +1,6 @@
+This module provides for efficient and simple prototype-based
+programming in Perl. You can provide different subroutines for each
+object, and also have objects inherit their behavior and state from
+another object.
+
+WWW: http://search.cpan.org/dist/Class-Prototyped/
diff --git a/devel/p5-Class-Prototyped/pkg-plist b/devel/p5-Class-Prototyped/pkg-plist
new file mode 100644
index 000000000000..02119ecde9b2
--- /dev/null
+++ b/devel/p5-Class-Prototyped/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/Class/Prototyped.pm
+%%SITE_PERL%%/Class/Prototyped/Graph.pm
+%%SITE_PERL%%/Class/Prototyped/why.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Prototyped/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class/Prototyped
+@dirrmtry %%SITE_PERL%%/Class/Prototyped
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Class
+@dirrmtry %%SITE_PERL%%/Class