aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-03-11 03:24:43 +0800
committerwill <will@FreeBSD.org>2001-03-11 03:24:43 +0800
commit30b7014249ef005cb49863f749b1ae7b27169185 (patch)
treee88d2ee859c9e98d903db1aba3cfc5193613dfaa
parenta7da97d4336aad0c82113998bafca93cecf421fb (diff)
downloadfreebsd-ports-gnome-30b7014249ef005cb49863f749b1ae7b27169185.tar.gz
freebsd-ports-gnome-30b7014249ef005cb49863f749b1ae7b27169185.tar.zst
freebsd-ports-gnome-30b7014249ef005cb49863f749b1ae7b27169185.zip
Add mksunbootcd 1.0, a program to make ISO images suitible to boot on
sparc systems. PR: 24086 Submitted by: Roman Shterenzon <roman@xpert.com>
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/mksunbootcd/Makefile23
-rw-r--r--sysutils/mksunbootcd/distinfo1
-rw-r--r--sysutils/mksunbootcd/pkg-comment1
-rw-r--r--sysutils/mksunbootcd/pkg-descr10
-rw-r--r--sysutils/mksunbootcd/pkg-plist1
6 files changed, 37 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index 3bb760dc9d17..459e1b90e746 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -68,6 +68,7 @@
SUBDIR += mei
SUBDIR += memtest
SUBDIR += mkisofs
+ SUBDIR += mksunbootcd
SUBDIR += monitord
SUBDIR += muse
SUBDIR += no-login
diff --git a/sysutils/mksunbootcd/Makefile b/sysutils/mksunbootcd/Makefile
new file mode 100644
index 000000000000..fb8ea3f5c466
--- /dev/null
+++ b/sysutils/mksunbootcd/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: mksunbootcd
+# Date Created: 5 Jan 2001
+# Whom: Roman Shterenzon <roman@xpert.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mksunbootcd
+PORTVERSION= 1.0
+CATEGORIES= sysutils
+MASTER_SITES= ftp://ftp.netbsd.org/pub/NetBSD/misc/mksunbootcd/
+
+MAINTAINER= roman@xpert.com
+
+MAN1= mksunbootcd.1
+
+GNU_CONFIGURE= yes
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mksunbootcd ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/sysutils/mksunbootcd/distinfo b/sysutils/mksunbootcd/distinfo
new file mode 100644
index 000000000000..6025a52cf724
--- /dev/null
+++ b/sysutils/mksunbootcd/distinfo
@@ -0,0 +1 @@
+MD5 (mksunbootcd-1.0.tar.gz) = edc50758db95aefa137d4ba235aa3dc1
diff --git a/sysutils/mksunbootcd/pkg-comment b/sysutils/mksunbootcd/pkg-comment
new file mode 100644
index 000000000000..4db0fb3ef72b
--- /dev/null
+++ b/sysutils/mksunbootcd/pkg-comment
@@ -0,0 +1 @@
+Makes ISO images suitible to boot on sparc systems
diff --git a/sysutils/mksunbootcd/pkg-descr b/sysutils/mksunbootcd/pkg-descr
new file mode 100644
index 000000000000..00c815c58e60
--- /dev/null
+++ b/sysutils/mksunbootcd/pkg-descr
@@ -0,0 +1,10 @@
+mksunbootcd combines filesystem partitions for Sun Microsystems,
+Inc. computers into an image suitable for writing to a compact
+disc, that will allow the disc to be booted on the sun3, sun3x, sun4,
+sun4c, sun4m and sun4u platforms. This hardware is supported by the
+NetBSD sparc, sparc64 and sun3 ports.
+See http://www.netbsd.org for more information on NetBSD.
+
+WWW: http://www.netbsd.org/
+
+Roman Shterenzon <roman@xpert.com>
diff --git a/sysutils/mksunbootcd/pkg-plist b/sysutils/mksunbootcd/pkg-plist
new file mode 100644
index 000000000000..42105fe8646c
--- /dev/null
+++ b/sysutils/mksunbootcd/pkg-plist
@@ -0,0 +1 @@
+bin/mksunbootcd