aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-17 00:02:48 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-17 00:02:48 +0800
commit30d071bbb7f95a420d9138e0d57b5917b06f45f8 (patch)
tree898d5c3fc197a3c30f37d8c78f9e94cb73a13a4f
parent70db90a2d52b1d1343518fbc8f2f138ecb977325 (diff)
downloadfreebsd-ports-gnome-30d071bbb7f95a420d9138e0d57b5917b06f45f8.tar.gz
freebsd-ports-gnome-30d071bbb7f95a420d9138e0d57b5917b06f45f8.tar.zst
freebsd-ports-gnome-30d071bbb7f95a420d9138e0d57b5917b06f45f8.zip
Use USE_GNOMENG.
-rw-r--r--games/gnomoku/Makefile12
-rw-r--r--x11-toolkits/gnome--/Makefile3
-rw-r--r--x11-toolkits/gtk--/Makefile3
-rw-r--r--x11-toolkits/gtk--2/Makefile3
-rw-r--r--x11-toolkits/gtkmm12/Makefile3
-rw-r--r--x11-toolkits/gtkmm20/Makefile3
-rw-r--r--x11-toolkits/gtkmm24/Makefile3
-rw-r--r--x11-toolkits/gtkmm30/Makefile3
8 files changed, 19 insertions, 14 deletions
diff --git a/games/gnomoku/Makefile b/games/gnomoku/Makefile
index 193ece64553f..dce271b99dfa 100644
--- a/games/gnomoku/Makefile
+++ b/games/gnomoku/Makefile
@@ -16,17 +16,15 @@ MAINTAINER= gnome@FreeBSD.org
LIB_DEPENDS= gnomemm.9:${PORTSDIR}/x11-toolkits/gnome--
USE_X_PREFIX= yes
-#USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomeprefix gnomehack gnomelibs
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-fpermissive -I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.mk>
diff --git a/x11-toolkits/gnome--/Makefile b/x11-toolkits/gnome--/Makefile
index ddd8f42eacf5..88944857a42f 100644
--- a/x11-toolkits/gnome--/Makefile
+++ b/x11-toolkits/gnome--/Makefile
@@ -20,7 +20,8 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtk--/Makefile b/x11-toolkits/gtk--/Makefile
index 249f8252680b..609b141feabc 100644
--- a/x11-toolkits/gtk--/Makefile
+++ b/x11-toolkits/gtk--/Makefile
@@ -21,7 +21,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_NEWGCC= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtk--2/Makefile b/x11-toolkits/gtk--2/Makefile
index 249f8252680b..609b141feabc 100644
--- a/x11-toolkits/gtk--2/Makefile
+++ b/x11-toolkits/gtk--2/Makefile
@@ -21,7 +21,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_NEWGCC= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtkmm12/Makefile b/x11-toolkits/gtkmm12/Makefile
index 249f8252680b..609b141feabc 100644
--- a/x11-toolkits/gtkmm12/Makefile
+++ b/x11-toolkits/gtkmm12/Makefile
@@ -21,7 +21,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_NEWGCC= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtkmm20/Makefile b/x11-toolkits/gtkmm20/Makefile
index 249f8252680b..609b141feabc 100644
--- a/x11-toolkits/gtkmm20/Makefile
+++ b/x11-toolkits/gtkmm20/Makefile
@@ -21,7 +21,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_NEWGCC= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtkmm24/Makefile b/x11-toolkits/gtkmm24/Makefile
index 249f8252680b..609b141feabc 100644
--- a/x11-toolkits/gtkmm24/Makefile
+++ b/x11-toolkits/gtkmm24/Makefile
@@ -21,7 +21,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_NEWGCC= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes
diff --git a/x11-toolkits/gtkmm30/Makefile b/x11-toolkits/gtkmm30/Makefile
index 249f8252680b..609b141feabc 100644
--- a/x11-toolkits/gtkmm30/Makefile
+++ b/x11-toolkits/gtkmm30/Makefile
@@ -21,7 +21,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_NEWGCC= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_LIBTOOL= yes
LIBTOOLFLAGS= --disable-ltlibs --release-ignore
INSTALLS_SHLIB= yes