aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2006-09-30 15:30:18 +0800
committermiwi <miwi@FreeBSD.org>2006-09-30 15:30:18 +0800
commit31d3fc6fd1c1ffaa2d8bc2d6e58b0bc4e3f7cd71 (patch)
treef3aee247e92916a11a6e53307348ad20e7773398
parent51cc99f59207904c06476ca02e08935f21964066 (diff)
downloadfreebsd-ports-gnome-31d3fc6fd1c1ffaa2d8bc2d6e58b0bc4e3f7cd71.tar.gz
freebsd-ports-gnome-31d3fc6fd1c1ffaa2d8bc2d6e58b0bc4e3f7cd71.tar.zst
freebsd-ports-gnome-31d3fc6fd1c1ffaa2d8bc2d6e58b0bc4e3f7cd71.zip
PBNJ is a network suite to monitor changes that occur on a network
over time. It does this by checking for changes on the target machine(s), which includes the details about the services running on them as well as the service state. PBNJ parses the data from a scan and stores it in a database. PBNJ uses Nmap to perform scans. WWW: http://www.sf.net/projects/pbnj PR: ports/100904 Submitted by: Joshua D. Abraham <jabra(at)ccs.neu.edu>
-rw-r--r--security/Makefile1
-rw-r--r--security/pbnj/Makefile36
-rw-r--r--security/pbnj/distinfo3
-rw-r--r--security/pbnj/pkg-descr8
-rw-r--r--security/pbnj/pkg-plist5
5 files changed, 53 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index b7d8c3375deb..2c33920a2555 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -483,6 +483,7 @@
SUBDIR += pamsfs
SUBDIR += pamtester
SUBDIR += parano
+ SUBDIR += pbnj
SUBDIR += pear-Auth
SUBDIR += pear-Auth_HTTP
SUBDIR += pear-Auth_PrefManager
diff --git a/security/pbnj/Makefile b/security/pbnj/Makefile
new file mode 100644
index 000000000000..b4d317222f53
--- /dev/null
+++ b/security/pbnj/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: pbnj
+# Date created: July 26, 2006
+# Whom: Joshua D. Abraham <jabra@ccs.neu.edu>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pbnj
+PORTVERSION= 2.02
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX=
+
+MAINTAINER= jabra@ccs.neu.edu
+COMMENT= A suite of tools to monitor changes on a network
+
+BUILD_DEPENDS= ${SITE_PERL}/XML/Twig.pm:${PORTSDIR}/textproc/p5-XML-Twig \
+ ${SITE_PERL}/Nmap/Parser.pm:${PORTSDIR}/security/p5-Nmap-Parser \
+ ${SITE_PERL}/mach/DBD/SQLite.pm:${PORTSDIR}/databases/p5-DBD-SQLite \
+ ${SITE_PERL}/mach/Text/CSV_XS.pm:${PORTSDIR}/textproc/p5-Text-CSV_XS \
+ ${SITE_PERL}/File/HomeDir.pm:${PORTSDIR}/devel/p5-File-HomeDir \
+ ${SITE_PERL}/File/Which.pm:${PORTSDIR}/sysutils/p5-File-Which
+RUN_DEPENDS= ${BUILD_DEPENDS} \
+ nmap:${PORTSDIR}/security/nmap
+
+PERL_CONFIGURE= yes
+
+MAN1= scanpbnj.1 \
+ outputpbnj.1 \
+ genlist.1
+
+post-configure:
+ @${PERL} -pi -e 's/^(POD2MAN_EXE.*)$$/\1 --lax/;' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/security/pbnj/distinfo b/security/pbnj/distinfo
new file mode 100644
index 000000000000..73565bb9db87
--- /dev/null
+++ b/security/pbnj/distinfo
@@ -0,0 +1,3 @@
+MD5 (pbnj-2.02.tar.gz) = 8d5108cd8d8b06770087aa40a2674b31
+SHA256 (pbnj-2.02.tar.gz) = 049a9f586b4707aff0a492cad8f02a71961bad6ad152a39c316a46a75b3594ba
+SIZE (pbnj-2.02.tar.gz) = 84397
diff --git a/security/pbnj/pkg-descr b/security/pbnj/pkg-descr
new file mode 100644
index 000000000000..ff02412f1908
--- /dev/null
+++ b/security/pbnj/pkg-descr
@@ -0,0 +1,8 @@
+PBNJ is a network suite to monitor changes that occur on a network
+over time. It does this by checking for changes on the target
+machine(s), which includes the details about the services running on
+them as well as the service state. PBNJ parses the data from a scan
+and stores it in a database. PBNJ uses Nmap to perform scans.
+
+
+WWW: http://www.sf.net/projects/pbnj
diff --git a/security/pbnj/pkg-plist b/security/pbnj/pkg-plist
new file mode 100644
index 000000000000..dd9c549d408f
--- /dev/null
+++ b/security/pbnj/pkg-plist
@@ -0,0 +1,5 @@
+bin/scanpbnj
+bin/outputpbnj
+bin/genlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/pbnj/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/pbnj