aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2006-02-01 00:16:41 +0800
committergarga <garga@FreeBSD.org>2006-02-01 00:16:41 +0800
commit31ed6c4b2cc8212954846d3f506bc5229d413ead (patch)
tree96a7f886d44827f1fb2a4563762cac1bbce81972
parent1c7c9d5b9d1350b02e561e92c3baf118610803e1 (diff)
downloadfreebsd-ports-gnome-31ed6c4b2cc8212954846d3f506bc5229d413ead.tar.gz
freebsd-ports-gnome-31ed6c4b2cc8212954846d3f506bc5229d413ead.tar.zst
freebsd-ports-gnome-31ed6c4b2cc8212954846d3f506bc5229d413ead.zip
Add pecl-operator 0.2, PHP extension that provides operator overloading
for PHP objects. PR: ports/92573 Submitted by: Alexander Zhuravlev <zaa@zaa.pp.ru>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pecl-operator/Makefile26
-rw-r--r--devel/pecl-operator/distinfo3
-rw-r--r--devel/pecl-operator/pkg-descr5
4 files changed, 35 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 2db9fa822539..7fd27c8e828a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1315,6 +1315,7 @@
SUBDIR += pear-XML_Util
SUBDIR += pear-XML_XPath
SUBDIR += pear-apd
+ SUBDIR += pecl-operator
SUBDIR += pecl-runkit
SUBDIR += pecl-statgrab
SUBDIR += pecl-svn
diff --git a/devel/pecl-operator/Makefile b/devel/pecl-operator/Makefile
new file mode 100644
index 000000000000..012319bc4a6b
--- /dev/null
+++ b/devel/pecl-operator/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: pecl-operator
+# Date created: 2006-01-31
+# Whom: Alexander Zhuravlev <zaa@zaa.pp.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= operator
+PORTVERSION= 0.2
+CATEGORIES= devel pear
+MASTER_SITES= http://pecl.php.net/get/
+PKGNAMEPREFIX= pecl-
+DISTNAME= operator-${PORTVERSION}
+EXTRACT_SUFX= .tgz
+DIST_SUBDIR= PECL
+
+MAINTAINER= zaa@zaa.pp.ru
+COMMENT= PHP extension that provides operator overloading for PHP objects
+
+USE_PHP= yes
+USE_PHPEXT= yes
+DEFAULT_PHP_VER= 5
+BROKEN_WITH_PHP= 4
+PHP_MODNAME= ${PORTNAME}
+
+.include <bsd.port.mk>
diff --git a/devel/pecl-operator/distinfo b/devel/pecl-operator/distinfo
new file mode 100644
index 000000000000..dbf1c2c14d5a
--- /dev/null
+++ b/devel/pecl-operator/distinfo
@@ -0,0 +1,3 @@
+MD5 (PECL/operator-0.2.tgz) = 301ee9558ad86c2d37fffddb1a1697f2
+SHA256 (PECL/operator-0.2.tgz) = 3ea5aba5ad9e0d81e670dfdb73cc429c8a456a4d73f33e3a9c6ce29593dd58c0
+SIZE (PECL/operator-0.2.tgz) = 6325
diff --git a/devel/pecl-operator/pkg-descr b/devel/pecl-operator/pkg-descr
new file mode 100644
index 000000000000..cf8538c07f1b
--- /dev/null
+++ b/devel/pecl-operator/pkg-descr
@@ -0,0 +1,5 @@
+PHP PECL extension provides possibility to overload operators for PHP objects.
+At the moment it allows overloading of the following operators:
++ - * / % << >> . | & ^ ~ ! ++ -- += -= *= /= %= <<= >>= .= |= &= ^= and ~=
+
+WWW: http://pecl.php.net/package/operator