aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2017-01-10 03:08:56 +0800
committerantoine <antoine@FreeBSD.org>2017-01-10 03:08:56 +0800
commit32d23d59cb4f49e41fb309e4d06d4bb5945de519 (patch)
tree6119d37bd91f5f375fb467c8be2a40f5eba2af35
parent06772fbea5329b77d45593ac2ac51f6b1180c74f (diff)
downloadfreebsd-ports-gnome-32d23d59cb4f49e41fb309e4d06d4bb5945de519.tar.gz
freebsd-ports-gnome-32d23d59cb4f49e41fb309e4d06d4bb5945de519.tar.zst
freebsd-ports-gnome-32d23d59cb4f49e41fb309e4d06d4bb5945de519.zip
New port: devel/py-nbformat
This package contains the base implementation of the Jupyter Notebook format, and Python APIs for working with notebooks. WWW: http://jupyter.org/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/py-nbformat/Makefile30
-rw-r--r--devel/py-nbformat/distinfo3
-rw-r--r--devel/py-nbformat/pkg-descr4
4 files changed, 38 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 08ab6966cc31..01adf19cff09 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -4382,6 +4382,7 @@
SUBDIR += py-nagioscheck
SUBDIR += py-natsort
SUBDIR += py-natural
+ SUBDIR += py-nbformat
SUBDIR += py-ncurses
SUBDIR += py-nose
SUBDIR += py-nose-cov
diff --git a/devel/py-nbformat/Makefile b/devel/py-nbformat/Makefile
new file mode 100644
index 000000000000..1a927f214e25
--- /dev/null
+++ b/devel/py-nbformat/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= nbformat
+PORTVERSION= 4.2.0
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= python@FreeBSD.org
+COMMENT= Jupyter Notebook format
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/COPYING.md
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}ipython_genutils>=0:devel/py-ipython_genutils \
+ ${PYTHON_PKGNAMEPREFIX}jsonschema>=2.4:devel/py-jsonschema \
+ ${PYTHON_PKGNAMEPREFIX}jupyter_core>=0:devel/py-jupyter_core \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>=0:databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}traitlets>=4.1:devel/py-traitlets
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pytest>=0:devel/py-pytest \
+ ${PYTHON_PKGNAMEPREFIX}testpath>=0:devel/py-testpath
+
+USES= python
+USE_PYTHON= distutils autoplist
+NO_ARCH= yes
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} pytest-${PYTHON_VER})
+
+.include <bsd.port.mk>
diff --git a/devel/py-nbformat/distinfo b/devel/py-nbformat/distinfo
new file mode 100644
index 000000000000..c1e083dd7a9a
--- /dev/null
+++ b/devel/py-nbformat/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1483907218
+SHA256 (nbformat-4.2.0.tar.gz) = 389a5b630a30539074f238a48fb9864592f63d611baccfa2ffaf14ffe239de06
+SIZE (nbformat-4.2.0.tar.gz) = 110309
diff --git a/devel/py-nbformat/pkg-descr b/devel/py-nbformat/pkg-descr
new file mode 100644
index 000000000000..761066609541
--- /dev/null
+++ b/devel/py-nbformat/pkg-descr
@@ -0,0 +1,4 @@
+This package contains the base implementation of the Jupyter Notebook format,
+and Python APIs for working with notebooks.
+
+WWW: http://jupyter.org/