aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-08-03 20:20:38 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-08-03 20:20:38 +0800
commit338503a782992dffc31c41de910793c202e2fa2f (patch)
treee7446043192b448f0ecb61a868db6e0ac1e4dec2
parent388adf276f17535e82416898b738ba5b799bfaf1 (diff)
downloadfreebsd-ports-gnome-338503a782992dffc31c41de910793c202e2fa2f.tar.gz
freebsd-ports-gnome-338503a782992dffc31c41de910793c202e2fa2f.tar.zst
freebsd-ports-gnome-338503a782992dffc31c41de910793c202e2fa2f.zip
Add form 4.2.0, symbolic Manipulation System.
-rw-r--r--math/Makefile1
-rw-r--r--math/form/Makefile39
-rw-r--r--math/form/distinfo3
-rw-r--r--math/form/pkg-descr7
-rw-r--r--math/form/pkg-plist15
5 files changed, 65 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index fee22af3a482..931b5268a1a8 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -166,6 +166,7 @@
SUBDIR += fftw3-long
SUBDIR += fftw3-quad
SUBDIR += fityk
+ SUBDIR += form
SUBDIR += fpc-fftw
SUBDIR += fpc-gmp
SUBDIR += fpc-numlib
diff --git a/math/form/Makefile b/math/form/Makefile
new file mode 100644
index 000000000000..ee2f8139f248
--- /dev/null
+++ b/math/form/Makefile
@@ -0,0 +1,39 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= form
+PORTVERSION= 4.2.0
+DISTVERSIONPREFIX= v
+CATEGORIES= math
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Symbolic Manipulation System
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libgmp.so:math/gmp
+
+USES= autoreconf gmake
+USE_GITHUB= yes
+GNU_CONFIGURE= yes
+
+GH_ACCOUNT= vermaseren
+
+OPTIONS_DEFINE= DOXYGEN
+OPTIONS_SUB= yes
+
+DOXYGEN_BUILD_DEPENDS= doxygen:devel/doxygen
+
+CONFIGURE_ARGS+= --enable-scalar \
+ --enable-largefile \
+ --with-api=posix
+
+post-build-DOXYGEN-on:
+ (cd ${WRKSRC}/doc/manual; ${MAKE_CMD} html pdf)
+
+post-install-DOXYGEN-on:
+ (cd ${WRKSRC}/doc/manual && ${COPYTREE_SHARE} html ${STAGEDIR}${DOCSDIR})
+ ${INSTALL_DATA} ${WRKSRC}/doc/manual/manual.pdf ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/math/form/distinfo b/math/form/distinfo
new file mode 100644
index 000000000000..730bb0c96d2e
--- /dev/null
+++ b/math/form/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1501741738
+SHA256 (vermaseren-form-v4.2.0_GH0.tar.gz) = ccfc68ef1b0467695e4c67644bf740db57ae326fd00bb2e664aea6067796e192
+SIZE (vermaseren-form-v4.2.0_GH0.tar.gz) = 1234552
diff --git a/math/form/pkg-descr b/math/form/pkg-descr
new file mode 100644
index 000000000000..12124660b538
--- /dev/null
+++ b/math/form/pkg-descr
@@ -0,0 +1,7 @@
+FORM is a Symbolic Manipulation System. It reads symbolic expressions from files
+and executes symbolic/algebraic transformations upon them. The answers are
+returned in a textual mathematical representation. As its landmark feature, the
+size of the considered expressions in FORM is only limited by the available disk
+space and not by the available RAM.
+
+WWW: https://www.nikhef.nl/~form/
diff --git a/math/form/pkg-plist b/math/form/pkg-plist
new file mode 100644
index 000000000000..b929f9980343
--- /dev/null
+++ b/math/form/pkg-plist
@@ -0,0 +1,15 @@
+bin/form
+bin/tform
+man/man1/form.1.gz
+%%DOXYGEN%%%%DOCSDIR%%/html/manual.css
+%%DOXYGEN%%%%DOCSDIR%%/html/manual.html
+%%DOXYGEN%%%%DOCSDIR%%/html/manual0x.png
+%%DOXYGEN%%%%DOCSDIR%%/html/manual1x.png
+%%DOXYGEN%%%%DOCSDIR%%/html/manual2x.png
+%%DOXYGEN%%%%DOCSDIR%%/html/manual3x.png
+%%DOXYGEN%%%%DOCSDIR%%/html/manual4x.png
+%%DOXYGEN%%%%DOCSDIR%%/html/manual5x.png
+%%DOXYGEN%%%%DOCSDIR%%/html/manual6x.png
+%%DOXYGEN%%%%DOCSDIR%%/html/manual7x.png
+%%DOXYGEN%%%%DOCSDIR%%/html/manual8x.png
+%%DOXYGEN%%%%DOCSDIR%%/manual.pdf