aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2013-05-15 08:17:20 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2013-05-15 08:17:20 +0800
commit33aa74dac611defd2a6fc038bf21fe2f3ca266d5 (patch)
treeff5a63e8eb15fb6fad5b99cf964d5f928fe2ac29
parent47db6fae004ef4a9de2081143f3fcbdf3eb88471 (diff)
downloadfreebsd-ports-gnome-33aa74dac611defd2a6fc038bf21fe2f3ca266d5.tar.gz
freebsd-ports-gnome-33aa74dac611defd2a6fc038bf21fe2f3ca266d5.tar.zst
freebsd-ports-gnome-33aa74dac611defd2a6fc038bf21fe2f3ca266d5.zip
OpenXcom is an open-source clone of the popular
UFO: Enemy Unknown (X-Com: UFO Defense in USA) videogame by Microprose, licensed under the GPL and written in C++ / SDL. WWW: http://openxcom.org
-rw-r--r--games/Makefile1
-rw-r--r--games/openxcom/Makefile58
-rw-r--r--games/openxcom/distinfo2
-rw-r--r--games/openxcom/files/pkg-message.in14
-rw-r--r--games/openxcom/pkg-descr5
5 files changed, 80 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index a02949fa3913..3fa9f0e9b451 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -690,6 +690,7 @@
SUBDIR += opensonic
SUBDIR += openssn
SUBDIR += openttd
+ SUBDIR += openxcom
SUBDIR += openyahtzee
SUBDIR += optimax
SUBDIR += orbital_eunuchs_sniper
diff --git a/games/openxcom/Makefile b/games/openxcom/Makefile
new file mode 100644
index 000000000000..b315260fdd7c
--- /dev/null
+++ b/games/openxcom/Makefile
@@ -0,0 +1,58 @@
+# Created by: Dmitry Marakasov <amdmi3@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= openxcom
+PORTVERSION= 0.9.0
+CATEGORIES= games
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Open-source reimplementation of the original X-Com
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= yaml-cpp:${PORTSDIR}/devel/yaml-cpp
+
+USE_GITHUB= yes
+GH_ACCOUNT= SupSuper
+GH_PROJECT= OpenXcom
+GH_TAGNAME= v0.9
+GH_COMMIT= 5c8b540
+
+USE_GMAKE= yes
+USE_SDL= sdl mixer image gfx
+USE_GL= gl
+MAKE_JOBS_SAFE= yes
+USE_GCC= 4.6+
+
+BUILD_WRKSRC= ${WRKSRC}/src
+MAKEFILE= Makefile.simple
+
+SUB_FILES= pkg-message
+
+PLIST_FILES= bin/openxcom
+
+PORTDOCS= *
+PORTDATA= *
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' ${WRKSRC}/src/pch.h \
+ ${WRKSRC}/src/Engine/Surface.cpp
+ @${REINPLACE_CMD} -e 's|/usr/local|${LOCALBASE}|' ${WRKSRC}/README.txt \
+ ${WRKSRC}/src/Engine/CrossPlatform.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/${PORTNAME} ${PREFIX}/bin/
+.if !defined(NOPORTDATA)
+ ${MKDIR} ${DATADIR}
+ cd ${WRKSRC}/bin && ${COPYTREE_SHARE} data ${DATADIR}/
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/
+.endif
+ @${ECHO_CMD}; ${CAT} ${PKGMESSAGE}; ${ECHO_CMD}
+
+.include <bsd.port.mk>
diff --git a/games/openxcom/distinfo b/games/openxcom/distinfo
new file mode 100644
index 000000000000..fb6b217bb691
--- /dev/null
+++ b/games/openxcom/distinfo
@@ -0,0 +1,2 @@
+SHA256 (openxcom-0.9.0.tar.gz) = 340ff7292baa9a2b7ce4b244cc6dc0200c1d3b807a59087ef9827bba5c135634
+SIZE (openxcom-0.9.0.tar.gz) = 1540556
diff --git a/games/openxcom/files/pkg-message.in b/games/openxcom/files/pkg-message.in
new file mode 100644
index 000000000000..cf6dc7218740
--- /dev/null
+++ b/games/openxcom/files/pkg-message.in
@@ -0,0 +1,14 @@
+==========================================================================
+
+OpenXcom requires original UFO: Enemy Unknown / X-Com: UFO Defense
+data files. Please copy all subfolders from original game into
+%%PREFIX%%/share/openxcom/data directory.
+
+Also note that if you get "GMDEFENT NOT FOUND" message, you need
+to patch your UFO to at least version 1.4. See
+
+http://openxcom.org/forum/index.php?topic=1129.0
+
+for reference.
+
+==========================================================================
diff --git a/games/openxcom/pkg-descr b/games/openxcom/pkg-descr
new file mode 100644
index 000000000000..9097e2b81539
--- /dev/null
+++ b/games/openxcom/pkg-descr
@@ -0,0 +1,5 @@
+OpenXcom is an open-source clone of the popular
+UFO: Enemy Unknown (X-Com: UFO Defense in USA) videogame by
+Microprose, licensed under the GPL and written in C++ / SDL.
+
+WWW: http://openxcom.org