aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2017-02-26 20:56:41 +0800
committerlinimon <linimon@FreeBSD.org>2017-02-26 20:56:41 +0800
commit34b63ad757506f132e5c7b30404e0988fd1beaf3 (patch)
tree3cc8567ce7ea5e860b623aa2f14428cfb91f4898
parentc80d40ca7a41b4ac1b6a66a4f6f20cf9cd1b7bdb (diff)
downloadfreebsd-ports-gnome-34b63ad757506f132e5c7b30404e0988fd1beaf3.tar.gz
freebsd-ports-gnome-34b63ad757506f132e5c7b30404e0988fd1beaf3.tar.zst
freebsd-ports-gnome-34b63ad757506f132e5c7b30404e0988fd1beaf3.zip
Mark various ports as broken on armv6: invokes x86 asm.
Approved by: portmgr (tier-2 blanket)
-rw-r--r--biology/avida/Makefile1
-rw-r--r--biology/gmap/Makefile1
-rw-r--r--devel/k8048/Makefile2
-rw-r--r--devel/kyra/Makefile1
-rw-r--r--devel/php-uprofiler/Makefile1
-rw-r--r--multimedia/libde265/Makefile4
-rw-r--r--net-mgmt/fastnetmon/Makefile5
7 files changed, 12 insertions, 3 deletions
diff --git a/biology/avida/Makefile b/biology/avida/Makefile
index 2bbaef108e79..be08e312e5de 100644
--- a/biology/avida/Makefile
+++ b/biology/avida/Makefile
@@ -13,6 +13,7 @@ COMMENT= Auto-adaptive genetic system designed for ALife research
LICENSE= GPLv3
BROKEN_aarch64= invokes x86 asm
+BROKEN_armv6= invokes x86 asm
BROKEN_mips= invokes x86 asm
BROKEN_mips64= invokes x86 asm
BROKEN_sparc64= missing atomics implementation
diff --git a/biology/gmap/Makefile b/biology/gmap/Makefile
index bf33cdec3bd6..af0f1e6e6eba 100644
--- a/biology/gmap/Makefile
+++ b/biology/gmap/Makefile
@@ -25,6 +25,7 @@ OPTIONS_DEFINE= SIMD
SIMD_CONFIGURE_OFF= --disable-builtin-popcount --disable-simd
BROKEN_aarch64= Does not build: invokes x86 asm
+BROKEN_armv6= Does not build: invokes x86 asm
BROKEN_mips64= Does not build: invokes x86 asm
BROKEN_powerpc64= Does not build on powerpc64
BROKEN_sparc64= Does not build: invokes x86 asm
diff --git a/devel/k8048/Makefile b/devel/k8048/Makefile
index aba4627fa5f8..687bb5d3761b 100644
--- a/devel/k8048/Makefile
+++ b/devel/k8048/Makefile
@@ -16,6 +16,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}/Src
USES= gmake
ALL_TARGET= build
+BROKEN_armv6= fails to compile: invokes x86 asm
+
PLIST_FILES= bin/${PORTNAME} bin/kio ${BIN_SYMLINKS}
BIN_SYMLINKS= bin/k12 bin/k14 bin/k16 bin/ktest
diff --git a/devel/kyra/Makefile b/devel/kyra/Makefile
index bcd9c7c9158e..9f24d509c607 100644
--- a/devel/kyra/Makefile
+++ b/devel/kyra/Makefile
@@ -27,6 +27,7 @@ MAKE_ARGS= CC="${CC}" CXX="${CXX}" LD="${CXX}" \
RELEASE_CFLAGS="${CFLAGS}" RELEASE_CXXFLAGS="${CXXFLAGS}"
BROKEN_aarch64= Fails to compile: error: invalid output constraint =A in asm
+BROKEN_armv6= Fails to compile: error: invalid output constraint =A in asm
do-install:
.for i in encoder spriteed
diff --git a/devel/php-uprofiler/Makefile b/devel/php-uprofiler/Makefile
index fbcbeef737da..fe336d45b59e 100644
--- a/devel/php-uprofiler/Makefile
+++ b/devel/php-uprofiler/Makefile
@@ -14,6 +14,7 @@ LICENSE= APACHE20
LICENSE_FILE= ${WRKSRC}/../LICENSE
BROKEN_aarch64= Does not build: invokes x86 asm
+BROKEN_armv6= Does not build: invokes x86 asm
BROKEN_mips64= Does not build: invokes x86 asm
BROKEN_powerpc64= Does not build
BROKEN_sparc64= Does not build: invokes x86 asm
diff --git a/multimedia/libde265/Makefile b/multimedia/libde265/Makefile
index 07d5cce9126f..76e4d6e46421 100644
--- a/multimedia/libde265/Makefile
+++ b/multimedia/libde265/Makefile
@@ -3,8 +3,8 @@
PORTNAME= libde265
PORTVERSION= 1.0.2
-CATEGORIES= multimedia
DISTVERSIONPREFIX= v
+CATEGORIES= multimedia
MAINTAINER= kwm@FreeBSD.org
COMMENT= Open source h.265 video codec
@@ -16,4 +16,6 @@ USES= autoreconf compiler:c++11-lib libtool pathfix pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-sherlock265 --disable-dec265
+BROKEN_armv6= fails to compile: invokes x86 assembler
+
.include <bsd.port.mk>
diff --git a/net-mgmt/fastnetmon/Makefile b/net-mgmt/fastnetmon/Makefile
index 4179031d8040..fc0e369199a0 100644
--- a/net-mgmt/fastnetmon/Makefile
+++ b/net-mgmt/fastnetmon/Makefile
@@ -13,8 +13,6 @@ COMMENT= Very fast DDoS analyzer with sflow/netflow/mirror support
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/LICENSE
-BROKEN_powerpc64= Does not build
-
LIB_DEPENDS= libboost_regex.so:devel/boost-libs \
liblog4cpp.so:devel/log4cpp \
libndpi.so:net/ndpi \
@@ -34,6 +32,9 @@ CMAKE_SOURCE_PATH= ${WRKSRC}/src
CMAKE_ARGS+= -DDISABLE_PF_RING_SUPPORT=ON
CMAKE_INSTALL_PREFIX= ${PREFIX}
+BROKEN_armv6= Does not build: invokes x86 assembler
+BROKEN_powerpc64= Does not build
+
USE_RC_SUBR= ${PORTNAME}
OPTIONS_DEFINE= DOCS REDIS