aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjrm <jrm@FreeBSD.org>2017-04-15 04:36:11 +0800
committerjrm <jrm@FreeBSD.org>2017-04-15 04:36:11 +0800
commit365ae2eb20e8685e6f3db53c7a26a4065278e7e8 (patch)
tree7733bc0e5545ce78c98f6fac50b675e2e05d0dcd
parenta57b03c3fa52519d98188d482d2d67c4e1d0365c (diff)
downloadfreebsd-ports-gnome-365ae2eb20e8685e6f3db53c7a26a4065278e7e8.tar.gz
freebsd-ports-gnome-365ae2eb20e8685e6f3db53c7a26a4065278e7e8.tar.zst
freebsd-ports-gnome-365ae2eb20e8685e6f3db53c7a26a4065278e7e8.zip
New port, devel/rubygem-simple-navigation: Create navigations for Rails,
Sinatra or Padrino applications Adding devel/rubygem-simple-navigation, because it is a dependency of the upcoming www/mastodon port. Approved by: swills (mentor, implicit)
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-simple-navigation/Makefile21
-rw-r--r--devel/rubygem-simple-navigation/distinfo3
-rw-r--r--devel/rubygem-simple-navigation/pkg-descr7
4 files changed, 32 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 29d314e29b3a..b95908b653ad 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5534,6 +5534,7 @@
SUBDIR += rubygem-sidetiq
SUBDIR += rubygem-sigdump
SUBDIR += rubygem-simple_form
+ SUBDIR += rubygem-simple-navigation
SUBDIR += rubygem-simplecov
SUBDIR += rubygem-slack-notifier
SUBDIR += rubygem-slack-notifier1
diff --git a/devel/rubygem-simple-navigation/Makefile b/devel/rubygem-simple-navigation/Makefile
new file mode 100644
index 000000000000..8a4e1c2a28ee
--- /dev/null
+++ b/devel/rubygem-simple-navigation/Makefile
@@ -0,0 +1,21 @@
+# $FreeBSD$
+
+PORTNAME= simple-navigation
+PORTVERSION= 4.0.5
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= jrm@FreeBSD.org
+COMMENT= Create navigations for Rails, Sinatra or Padrino applications
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= rubygem-activesupport4>=2.3.2:devel/rubygem-activesupport4
+
+NO_ARCH= yes
+
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-simple-navigation/distinfo b/devel/rubygem-simple-navigation/distinfo
new file mode 100644
index 000000000000..0874271362fe
--- /dev/null
+++ b/devel/rubygem-simple-navigation/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1492201871
+SHA256 (rubygem/simple-navigation-4.0.5.gem) = 937a8fc09abac119e031af9f123c886a6608f018d92059641f790dab50d04221
+SIZE (rubygem/simple-navigation-4.0.5.gem) = 43520
diff --git a/devel/rubygem-simple-navigation/pkg-descr b/devel/rubygem-simple-navigation/pkg-descr
new file mode 100644
index 000000000000..2cd168783013
--- /dev/null
+++ b/devel/rubygem-simple-navigation/pkg-descr
@@ -0,0 +1,7 @@
+With the simple-navigation gem installed you can easily create multilevel
+navigations for your Rails, Sinatra or Padrino applications. The navigation is
+defined in a single configuration file. It supports automatic as well as
+explicit highlighting of the currently active navigation through regular
+expressions.
+
+WWW: http://github.com/codeplant/simple-navigation/