aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2010-01-03 21:40:04 +0800
committerwen <wen@FreeBSD.org>2010-01-03 21:40:04 +0800
commit366c9a2b88afdfac94d7840ee3a8989a274aafb1 (patch)
treed54dfc3599381f4b17bc618fcd55293c88226879
parent993ab896ec44315c4f806ec8604a53e1c455ff90 (diff)
downloadfreebsd-ports-gnome-366c9a2b88afdfac94d7840ee3a8989a274aafb1.tar.gz
freebsd-ports-gnome-366c9a2b88afdfac94d7840ee3a8989a274aafb1.tar.zst
freebsd-ports-gnome-366c9a2b88afdfac94d7840ee3a8989a274aafb1.zip
Astro::Hipparcos is a Perl extension for reading the Hipparcos star catalog.
WWW: http://search.cpan.org/dist/Astro-Hipparcos/
-rw-r--r--astro/Makefile1
-rw-r--r--astro/p5-Astro-Hipparcos/Makefile25
-rw-r--r--astro/p5-Astro-Hipparcos/distinfo3
-rw-r--r--astro/p5-Astro-Hipparcos/pkg-descr3
-rw-r--r--astro/p5-Astro-Hipparcos/pkg-plist9
5 files changed, 41 insertions, 0 deletions
diff --git a/astro/Makefile b/astro/Makefile
index 9fef5bbbaf23..4a852743e9cc 100644
--- a/astro/Makefile
+++ b/astro/Makefile
@@ -48,6 +48,7 @@
SUBDIR += p5-Astro-Catalog
SUBDIR += p5-Astro-DSS
SUBDIR += p5-Astro-FITS-Header
+ SUBDIR += p5-Astro-Hipparcos
SUBDIR += p5-Astro-MoonPhase
SUBDIR += p5-Astro-SIMBAD
SUBDIR += p5-Astro-SIMBAD-Client
diff --git a/astro/p5-Astro-Hipparcos/Makefile b/astro/p5-Astro-Hipparcos/Makefile
new file mode 100644
index 000000000000..db6353181ccf
--- /dev/null
+++ b/astro/p5-Astro-Hipparcos/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: p5-Astro-Hipparcos
+# Date created: 14 Dec, 2009
+# Whom: Wen Heping <wenheping@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Astro-Hipparcos
+PORTVERSION= 0.08
+CATEGORIES= astro perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= wen@FreeBSD.org
+COMMENT= Perl extension for reading the Hipparcos star catalog
+
+BUILD_DEPENDS= p5-ExtUtils-XSpp>=0.05:${PORTSDIR}/devel/p5-ExtUtils-XSpp
+
+MAKE_ARGS+= "CC=g++"
+PERL_CONFIGURE= yes
+
+MAN3= Astro::Hipparcos::Record.3 \
+ Astro::Hipparcos.3
+
+.include <bsd.port.mk>
diff --git a/astro/p5-Astro-Hipparcos/distinfo b/astro/p5-Astro-Hipparcos/distinfo
new file mode 100644
index 000000000000..e3f9c955edb2
--- /dev/null
+++ b/astro/p5-Astro-Hipparcos/distinfo
@@ -0,0 +1,3 @@
+MD5 (Astro-Hipparcos-0.08.tar.gz) = 83dec82fdeed02f7ac48348945024cf3
+SHA256 (Astro-Hipparcos-0.08.tar.gz) = 5950f7b99bcb7490bf2a708abe0c192f2476ff7f6b3f2294a5faa414b89f17e6
+SIZE (Astro-Hipparcos-0.08.tar.gz) = 56445
diff --git a/astro/p5-Astro-Hipparcos/pkg-descr b/astro/p5-Astro-Hipparcos/pkg-descr
new file mode 100644
index 000000000000..bc79124dbac3
--- /dev/null
+++ b/astro/p5-Astro-Hipparcos/pkg-descr
@@ -0,0 +1,3 @@
+Astro::Hipparcos is a Perl extension for reading the Hipparcos star catalog.
+
+WWW: http://search.cpan.org/dist/Astro-Hipparcos/
diff --git a/astro/p5-Astro-Hipparcos/pkg-plist b/astro/p5-Astro-Hipparcos/pkg-plist
new file mode 100644
index 000000000000..a204f18c8aaa
--- /dev/null
+++ b/astro/p5-Astro-Hipparcos/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Astro/Hipparcos/Record.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/Astro/Hipparcos.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Hipparcos/Hipparcos.so
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Hipparcos/Hipparcos.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Hipparcos/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Astro/Hipparcos
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Astro
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro/Hipparcos
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Astro