diff options
author | pawel <pawel@FreeBSD.org> | 2014-12-16 23:53:33 +0800 |
---|---|---|
committer | pawel <pawel@FreeBSD.org> | 2014-12-16 23:53:33 +0800 |
commit | 36b6317402db9377d49a7a59d3d94e1303009bb4 (patch) | |
tree | 29a9a247b4351cd28662c5860237431ba5253ecb | |
parent | 141b6dcd4fc5441f47bd3611828e1dac75a93ddc (diff) | |
download | freebsd-ports-gnome-36b6317402db9377d49a7a59d3d94e1303009bb4.tar.gz freebsd-ports-gnome-36b6317402db9377d49a7a59d3d94e1303009bb4.tar.zst freebsd-ports-gnome-36b6317402db9377d49a7a59d3d94e1303009bb4.zip |
japanese/ebnetd add user and group for daemon processes
PR: 195523
Submitted by: maintainer
-rw-r--r-- | GIDs | 1 | ||||
-rw-r--r-- | UIDs | 1 | ||||
-rw-r--r-- | japanese/ebnetd/Makefile | 16 | ||||
-rw-r--r-- | japanese/ebnetd/files/patch-ebnetd.conf.sample.in | 16 | ||||
-rw-r--r-- | japanese/ebnetd/pkg-plist | 2 |
5 files changed, 33 insertions, 3 deletions
@@ -302,5 +302,6 @@ puppetdb:*:985: kamailio:*:986: spark:*:987: mediabrowser:*:989: +ebnetd:*:999: nogroup:*:65533: nobody:*:65534: @@ -311,4 +311,5 @@ kamailio:*:986:986::0:0:kamailio daemon:/nonexistent:/usr/sbin/nologin spark:*:987:987::0:0:Apache Spark user:/nonexistent:/usr/sbin/nologin toxdht:*:988:65534::0:0:Tox DHT bootstrap user:/nonexistent:/usr/sbin/nologin mediabrowser:*:989:989::0:0:MediaBrowser:/nonexistent:/usr/sbin/nologin +ebnetd:*:999:999::0:0:EBNETD:/nonexistent:/usr/sbin/nologin nobody:*:65534:65534::0:0:Unprivileged user:/nonexistent:/usr/sbin/nologin diff --git a/japanese/ebnetd/Makefile b/japanese/ebnetd/Makefile index ca241b18ac8a..ab90cca80b03 100644 --- a/japanese/ebnetd/Makefile +++ b/japanese/ebnetd/Makefile @@ -3,7 +3,7 @@ PORTNAME= ebnetd PORTVERSION= 1.0 -PORTREVISION= 9 +PORTREVISION= 10 CATEGORIES= japanese ipv6 MASTER_SITES= ftp://ftp.sra.co.jp/pub/misc/eb/ @@ -18,16 +18,28 @@ GNU_CONFIGURE= yes CONFIGURE_ARGS= --localstatedir=${RUNDIR} --with-logdir=${LOGDIR} CONFIGURE_ENV= PERL=${PREFIX}/bin/perl +USERS= ${EBNETD_USER} +GROUPS= ${EBNETD_GROUP} + # Local variables LOGDIR= /var/log RUNDIR= /var/run +EBNETD_USER= ebnetd +EBNETD_GROUP= ebnetd USE_RC_SUBR= ebhttpd ebnetd ndtpd SUB_FILES= pkg-message -PLIST_SUB= EBNETD_RUNDIR=${RUNDIR}/${PORTNAME} +PLIST_SUB= EBNETD_RUNDIR=${RUNDIR}/${PORTNAME} \ + EBNETD_USER=${EBNETD_USER} \ + EBNETD_GROUP=${EBNETD_GROUP} INFO= ebnetd ebnetd-ja +post-patch: + ${REINPLACE_CMD} -e "s/%%EBNETD_USER%%/${EBNETD_USER}/" \ + -e "s/%%EBNETD_GROUP%%/${EBNETD_GROUP}/" \ + ${WRKSRC}/ebnetd.conf.sample.in + post-stage: ${MKDIR} -m 0755 ${STAGEDIR}${RUNDIR}/${PORTNAME} diff --git a/japanese/ebnetd/files/patch-ebnetd.conf.sample.in b/japanese/ebnetd/files/patch-ebnetd.conf.sample.in new file mode 100644 index 000000000000..86c63a6bdc45 --- /dev/null +++ b/japanese/ebnetd/files/patch-ebnetd.conf.sample.in @@ -0,0 +1,16 @@ +--- ebnetd.conf.sample.in.orig 2003-06-15 20:39:55.000000000 +0900 ++++ ebnetd.conf.sample.in 2014-11-30 18:17:51.227415186 +0900 +@@ -17,11 +17,11 @@ + + ### Owner of the server process. + ### (default: none) +-user ndtpuser ++user %%EBNETD_USER%% + + ### Group of the server process. + ### (default: none) +-group ndtpgrp ++group %%EBNETD_GROUP%% + + ### How many clients can be connected to the server at the same time. + ### (default: 1) diff --git a/japanese/ebnetd/pkg-plist b/japanese/ebnetd/pkg-plist index ec663f4cdc29..184e8b0d8c57 100644 --- a/japanese/ebnetd/pkg-plist +++ b/japanese/ebnetd/pkg-plist @@ -13,4 +13,4 @@ sbin/ebnupgrade sbin/ndtpcheck sbin/ndtpcontrol sbin/ndtpd -@dir(,,0755) %%EBNETD_RUNDIR%% +@dir(%%EBNETD_USER%%,%%EBNETD_GROUP%%,0755) %%EBNETD_RUNDIR%% |