aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorroam <roam@FreeBSD.org>2003-10-08 18:32:04 +0800
committerroam <roam@FreeBSD.org>2003-10-08 18:32:04 +0800
commit372d61319f8dabed97bc712ae8ac72b2a9442003 (patch)
treeb741f211fc4ac81b0bb5cf0ce71584a83f7439bb
parenteaaea5fd0294a90775504fc63590fccbc88d9037 (diff)
downloadfreebsd-ports-gnome-372d61319f8dabed97bc712ae8ac72b2a9442003.tar.gz
freebsd-ports-gnome-372d61319f8dabed97bc712ae8ac72b2a9442003.tar.zst
freebsd-ports-gnome-372d61319f8dabed97bc712ae8ac72b2a9442003.zip
Add mod_auth_remote 0.1 - an Apache module for authentication against
a remote web server/page. PR: 57656 Submitted by: Clement Laforet <sheepkiller@cultdeadsheep.org>
-rw-r--r--www/Makefile1
-rw-r--r--www/mod_auth_remote/Makefile32
-rw-r--r--www/mod_auth_remote/distinfo1
-rw-r--r--www/mod_auth_remote/pkg-descr10
-rw-r--r--www/mod_auth_remote/pkg-plist5
5 files changed, 49 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 2a0d8a99192e..f573e4612eb0 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -194,6 +194,7 @@
SUBDIR += mod_auth_pgsql
SUBDIR += mod_auth_pgsql2
SUBDIR += mod_auth_pwcheck
+ SUBDIR += mod_auth_remote
SUBDIR += mod_backhand
SUBDIR += mod_bandwidth
SUBDIR += mod_bf
diff --git a/www/mod_auth_remote/Makefile b/www/mod_auth_remote/Makefile
new file mode 100644
index 000000000000..e80ffe3f3dfa
--- /dev/null
+++ b/www/mod_auth_remote/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: mod_auth_remote
+# Date created: Sun Oct 5
+# Whom: Clement Laforet <sheepkiller@cultdeadsheep.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= mod_auth_remote
+PORTVERSION= 0.1
+CATEGORIES= www
+MASTER_SITES= http://sheepkiller.nerim.net/ports/${PORTNAME}/
+# Original location is here: http://puggy.symonds.net/~srp/stuff/
+
+MAINTAINER= sheepkiller@cultdeadsheep.org
+COMMENT= Allows users to authenticate on a remote web server
+
+BUILD_DEPENDS= ${LOCALBASE}/sbin/apxs:${PORTSDIR}/www/apache2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+APXS?= ${LOCALBASE}/sbin/apxs
+
+do-build:
+ @(cd ${WRKSRC} && ${APXS} -c ${PORTNAME}.c)
+
+do-install:
+ @(cd ${WRKSRC} && ${APXS} -A -i ${PORTNAME}.la)
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/readme.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/www/mod_auth_remote/distinfo b/www/mod_auth_remote/distinfo
new file mode 100644
index 000000000000..05826161a85f
--- /dev/null
+++ b/www/mod_auth_remote/distinfo
@@ -0,0 +1 @@
+MD5 (mod_auth_remote-0.1.tar.gz) = 2086ef91061f2b0539c133c8c4318595
diff --git a/www/mod_auth_remote/pkg-descr b/www/mod_auth_remote/pkg-descr
new file mode 100644
index 000000000000..a77aa3b365e5
--- /dev/null
+++ b/www/mod_auth_remote/pkg-descr
@@ -0,0 +1,10 @@
+mod_auth_remote allows you to authenticate users on one (or more) remote web
+server(s), using basic HTTP authentication.
+When a request comes in, mod_auth_remote obtains the client username &
+password from the client via basic authentication scheme.
+It then builds a HTTP header with authorization header built from the client's
+userid:passwd. mod_auth_remote then makes a HEAD request to the authentication
+server. On reciept of a 2XX response, the client is validated; for all other
+responses the client is not validated.
+
+WWW: http://puggy.symonds.net/~srp/stuff/
diff --git a/www/mod_auth_remote/pkg-plist b/www/mod_auth_remote/pkg-plist
new file mode 100644
index 000000000000..c69c83c731d2
--- /dev/null
+++ b/www/mod_auth_remote/pkg-plist
@@ -0,0 +1,5 @@
+libexec/apache2/mod_auth_remote.so
+@exec %D/sbin/apxs -e -a -n auth_remote %D/%f
+%%PORTDOCS%%%%DOCSDIR%%/readme.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@unexec echo "===> If you do not plan on reinstalling mod_auth_remote, you must manually remove"; echo "===> references to it in httpd.conf."