aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-01-20 14:05:28 +0800
committerwen <wen@FreeBSD.org>2011-01-20 14:05:28 +0800
commit374189df402e699631f65df8625e8f9f2e8117e4 (patch)
tree85bf0184cb24f85a1fbebd19c81903070d6ee714
parentba91ee52c1a01ff6f47a1cbe7e4ccab81d1ab885 (diff)
downloadfreebsd-ports-gnome-374189df402e699631f65df8625e8f9f2e8117e4.tar.gz
freebsd-ports-gnome-374189df402e699631f65df8625e8f9f2e8117e4.tar.zst
freebsd-ports-gnome-374189df402e699631f65df8625e8f9f2e8117e4.zip
Twofish is a 128-bit symmetric block cipher with a variable key
length (128, 192, or 256 bits) key, developed by Counterpane Labs. It is unpatented and free for all uses, as described at http://www.counterpane.com/twofish.html. It has been one of the five finalists for AES. This module is written in pure Perl, it should run everywhere where Perl runs. WWW: http://search.cpan.org/dist/Crypt-Twofish_PP/ PR: ports/154142 Submitted by: Konstantin Menshikov <kostjnspb@yandex.ru> Feature safe: yes
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Twofish_PP/Makefile25
-rw-r--r--security/p5-Crypt-Twofish_PP/distinfo2
-rw-r--r--security/p5-Crypt-Twofish_PP/pkg-descr10
-rw-r--r--security/p5-Crypt-Twofish_PP/pkg-plist12
5 files changed, 50 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 685b0482eaf0..a492853b313e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -479,6 +479,7 @@
SUBDIR += p5-Crypt-TripleDES
SUBDIR += p5-Crypt-Twofish
SUBDIR += p5-Crypt-Twofish2
+ SUBDIR += p5-Crypt-Twofish_PP
SUBDIR += p5-Crypt-UnixCrypt
SUBDIR += p5-Crypt-UnixCrypt_XS
SUBDIR += p5-Crypt-X509
diff --git a/security/p5-Crypt-Twofish_PP/Makefile b/security/p5-Crypt-Twofish_PP/Makefile
new file mode 100644
index 000000000000..5e85bb1a3cd5
--- /dev/null
+++ b/security/p5-Crypt-Twofish_PP/Makefile
@@ -0,0 +1,25 @@
+# New ports collection makefile for: p5-Crypt-Twofish_PP
+# Date created: 19 January 2010
+# Whom: Konstantin Menshikov <kostjnspb@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Twofish_PP
+PORTVERSION= 0.17
+CATEGORIES= security perl5
+MASTER_SITES= CPAN \
+ http://kostjn.spb.ru/freebsd/
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kostjnspb@yandex.ru
+COMMENT= The Twofish Algorithm in Pure Perl
+
+PERL_CONFIGURE= YES
+
+MAN3= Crypt::Twofish_PP.3 \
+ Crypt::Twofish_PP::Key16.3 \
+ Crypt::Twofish_PP::Key24.3 \
+ Crypt::Twofish_PP::Key32.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Twofish_PP/distinfo b/security/p5-Crypt-Twofish_PP/distinfo
new file mode 100644
index 000000000000..c2aa8a7bf740
--- /dev/null
+++ b/security/p5-Crypt-Twofish_PP/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Crypt-Twofish_PP-0.17.tar.gz) = e7e2736cd7f379227f818ea2e8e586594773eb4c2fd8ec5c8c4d9662003b8bab
+SIZE (Crypt-Twofish_PP-0.17.tar.gz) = 46306
diff --git a/security/p5-Crypt-Twofish_PP/pkg-descr b/security/p5-Crypt-Twofish_PP/pkg-descr
new file mode 100644
index 000000000000..de66ed1ad7e9
--- /dev/null
+++ b/security/p5-Crypt-Twofish_PP/pkg-descr
@@ -0,0 +1,10 @@
+Twofish is a 128-bit symmetric block cipher with a variable key
+length (128, 192, or 256 bits) key, developed by Counterpane Labs.
+It is unpatented and free for all uses, as described at
+http://www.counterpane.com/twofish.html. It has been one of the
+five finalists for AES.
+
+This module is written in pure Perl, it should run everywhere
+where Perl runs.
+
+WWW: http://search.cpan.org/dist/Crypt-Twofish_PP/
diff --git a/security/p5-Crypt-Twofish_PP/pkg-plist b/security/p5-Crypt-Twofish_PP/pkg-plist
new file mode 100644
index 000000000000..a7e49518f81a
--- /dev/null
+++ b/security/p5-Crypt-Twofish_PP/pkg-plist
@@ -0,0 +1,12 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt-Twofish_PP/.packlist
+%%SITE_PERL%%/Crypt/Twofish_PP.pm
+%%SITE_PERL%%/Crypt/Twofish_PP/Key16.pm
+%%SITE_PERL%%/Crypt/Twofish_PP/Key24.pm
+%%SITE_PERL%%/Crypt/Twofish_PP/Key32.pm
+%%SITE_PERL%%/LocaleData/de/LC_MESSAGES/Crypt-Twofish_PP.mo
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt-Twofish_PP
+@dirrmtry %%SITE_PERL%%/Crypt/Twofish_PP
+@dirrmtry %%SITE_PERL%%/Crypt
+@dirrmtry %%SITE_PERL%%/LocaleData/de/LC_MESSAGES
+@dirrmtry %%SITE_PERL%%/LocaleData/de
+@dirrmtry %%SITE_PERL%%/LocaleData