aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2017-06-24 05:17:52 +0800
committersunpoet <sunpoet@FreeBSD.org>2017-06-24 05:17:52 +0800
commit374feb8a8d837f1f03ca30dbb7a0d47a043be676 (patch)
tree82e9ec263fec624d8934359d5b42ae88db37b2af
parent0891bbed8b478d418c0f7f15f20808dfb17cd61c (diff)
downloadfreebsd-ports-gnome-374feb8a8d837f1f03ca30dbb7a0d47a043be676.tar.gz
freebsd-ports-gnome-374feb8a8d837f1f03ca30dbb7a0d47a043be676.tar.zst
freebsd-ports-gnome-374feb8a8d837f1f03ca30dbb7a0d47a043be676.zip
Add rubygem-peek 1.0.1
This is a profiling tool originally built at GitHub to help us get an insight into our application. Now, we have extracted this into Peek, so that other Rails application can experience the same benefit. Peek puts a little bar on top of your application to show you all sorts of helpful information about your application. From the screenshot above, you can see that Peek provides information about database queries, cache, Resque workers and more. However, this is only part of Peek's beauty. The true beauty of Peek lies in the fact that it is an extensible platform. If there are some performance metrics that you need but are not available on Peek, you can find it from the list of available Peek Views and integrate it into Peek. Even if you do not find what you want on Peek Views, you can always create your own. WWW: https://github.com/peek/peek
-rw-r--r--devel/Makefile1
-rw-r--r--devel/rubygem-peek/Makefile23
-rw-r--r--devel/rubygem-peek/distinfo3
-rw-r--r--devel/rubygem-peek/pkg-descr16
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index ea5e451b0111..6055c182445b 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -5499,6 +5499,7 @@
SUBDIR += rubygem-parser
SUBDIR += rubygem-patch_finder
SUBDIR += rubygem-pathutil
+ SUBDIR += rubygem-peek
SUBDIR += rubygem-piston
SUBDIR += rubygem-pkg-config
SUBDIR += rubygem-platform
diff --git a/devel/rubygem-peek/Makefile b/devel/rubygem-peek/Makefile
new file mode 100644
index 000000000000..f611d09fc79a
--- /dev/null
+++ b/devel/rubygem-peek/Makefile
@@ -0,0 +1,23 @@
+# Created by: Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= peek
+PORTVERSION= 1.0.1
+CATEGORIES= devel rubygems
+MASTER_SITES= RG
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Take a peek into your Rails application
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+RUN_DEPENDS= rubygem-concurrent-ruby>=0.9.0:devel/rubygem-concurrent-ruby \
+ rubygem-concurrent-ruby-ext>=0.9.0:devel/rubygem-concurrent-ruby-ext \
+ rubygem-railties5>=4.0.0:www/rubygem-railties5
+
+NO_ARCH= yes
+USE_RUBY= yes
+USES= gem
+
+.include <bsd.port.mk>
diff --git a/devel/rubygem-peek/distinfo b/devel/rubygem-peek/distinfo
new file mode 100644
index 000000000000..047f32e200a1
--- /dev/null
+++ b/devel/rubygem-peek/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1498222031
+SHA256 (rubygem/peek-1.0.1.gem) = 9641ed21323644646f13f65c116707e6462cf20b02259bb16925884835db28a5
+SIZE (rubygem/peek-1.0.1.gem) = 25600
diff --git a/devel/rubygem-peek/pkg-descr b/devel/rubygem-peek/pkg-descr
new file mode 100644
index 000000000000..fc65d2f486b2
--- /dev/null
+++ b/devel/rubygem-peek/pkg-descr
@@ -0,0 +1,16 @@
+This is a profiling tool originally built at GitHub to help us get an insight
+into our application. Now, we have extracted this into Peek, so that other Rails
+application can experience the same benefit.
+
+Peek puts a little bar on top of your application to show you all sorts of
+helpful information about your application. From the screenshot above, you can
+see that Peek provides information about database queries, cache, Resque workers
+and more. However, this is only part of Peek's beauty.
+
+The true beauty of Peek lies in the fact that it is an extensible platform. If
+there are some performance metrics that you need but are not available on Peek,
+you can find it from the list of available Peek Views and integrate it into
+Peek. Even if you do not find what you want on Peek Views, you can always create
+your own.
+
+WWW: https://github.com/peek/peek