aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2004-08-06 06:34:14 +0800
committermarcus <marcus@FreeBSD.org>2004-08-06 06:34:14 +0800
commit37af71efa9fe25e9ee117fa26d61a9adc3f8d40a (patch)
treed85f4bb9d0053bb12bf2a5fb23f6afbb254f6177
parent3b7f89049cea90e75413d6468965d2c19ff00758 (diff)
downloadfreebsd-ports-gnome-37af71efa9fe25e9ee117fa26d61a9adc3f8d40a.tar.gz
freebsd-ports-gnome-37af71efa9fe25e9ee117fa26d61a9adc3f8d40a.tar.zst
freebsd-ports-gnome-37af71efa9fe25e9ee117fa26d61a9adc3f8d40a.zip
Update to 0.8.3, and add faac and working xvid support.
Submitted by: Koop Mast <kwm@rainbow-runner.nl>
-rw-r--r--multimedia/gstreamer-plugins/Makefile46
-rw-r--r--multimedia/gstreamer-plugins/distinfo4
-rw-r--r--multimedia/gstreamer-plugins/files/patch-ext_theora_theoradec.c19
-rw-r--r--multimedia/gstreamer-plugins/files/patch-gst_interleave_interleave.c65
-rw-r--r--multimedia/gstreamer-plugins/files/patch-ltmain.sh51
-rw-r--r--multimedia/gstreamer-plugins/pkg-plist8
-rw-r--r--multimedia/gstreamer-plugins80/Makefile46
-rw-r--r--multimedia/gstreamer-plugins80/distinfo4
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ext_theora_theoradec.c19
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-gst_interleave_interleave.c65
-rw-r--r--multimedia/gstreamer-plugins80/files/patch-ltmain.sh51
-rw-r--r--multimedia/gstreamer-plugins80/pkg-plist8
12 files changed, 254 insertions, 132 deletions
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index faf49ccb7a05..f42a168752ff 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.2
-PORTREVISION= 4
+PORTVERSION= 0.8.3
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://gstreamer.freedesktop.org/src/gst-plugins/
@@ -31,7 +30,7 @@ USE_GNOME= gnomehack \
pkgconfig \
gconf2
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --disable-tests \
--disable-alsa \
--enable-cdrom \
@@ -42,18 +41,23 @@ CONFIGURE_ARGS= --disable-tests \
--disable-raw1394 \
--disable-v4l2 \
--disable-v4l \
+ --disable-osx_audio \
+ --disable-sunaudio \
--disable-dependency-tracking \
--enable-xshm \
+ --enable-x \
+ --enable-xvideo \
--enable-static
# list of plugins that need some work in one way or the other to work
# probable the lib needs to be ported, disable them for now.
-CONFIGURE_ARGS+=--disable-mas \
- --disable-faac \
+CONFIGURE_ARGS+=\
--disable-tarkin \
--disable-lcs \
--disable-mplex \
--disable-shout2 \
+ --disable-libvisual \
+ --disable-dirac \
--disable-librfb
CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
@@ -169,6 +173,11 @@ WITH_CDPARANOIA=yes
WITH_DTS=yes
.endif
+# faac
+.if exists(${LOCALBASE}/lib/libfaac.a)
+WITH_FAAC=yes
+.endif
+
# esound
.if (${HAVE_GNOME:Mesound}!="")
WITH_ESOUND=yes
@@ -460,6 +469,15 @@ CONFIGURE_ARGS+= --with-esd-prefix=${LOCALBASE} \
PLIST_SUB+= ESOUND=""
.endif
+# faac
+.ifndef(WITH_FAAC)
+CONFIGURE_ARGS+= --disable-faac
+PLIST_SUB+= FAAC="@comment "
+.else
+LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
+PLIST_SUB+= FAAC=""
+.endif
+
# faad
.ifndef(WITH_FAAD)
CONFIGURE_ARGS+= --disable-faad
@@ -873,14 +891,13 @@ PLIST_SUB+= XINE=""
.endif
# xvid
-#.ifndef(WITH_XVID)
+.ifndef(WITH_XVID)
CONFIGURE_ARGS+= --disable-xvid
PLIST_SUB+= XVID="@comment "
-#.undef WITH_XVID
-#.else
-#LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
-#PLIST_SUB+= XVID=""
-#.endif
+.else
+LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+PLIST_SUB+= XVID=""
+.endif
post-build:
.ifdef(EXTRA_BUILD_DIR)
@@ -896,7 +913,8 @@ post-install:
. endfor
.endif
# register plugins
- -@${X11BASE}/bin/gst-register-${GST_VERSION} 2>/dev/null
+ -@${X11BASE}/bin/gst-register-${GST_VERSION} \
+ --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
pre-everything::
.ifndef(WITH_AALIB)
@@ -934,6 +952,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_ESOUND to enable esound Audio plugin'
.endif
+.ifndef(WITH_FAAC)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_FAAC to enable faac Audio plugin'
+.endif
.ifndef(WITH_FAAD)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_FAAD to enable faad Audio plugin'
diff --git a/multimedia/gstreamer-plugins/distinfo b/multimedia/gstreamer-plugins/distinfo
index 2ab790307c7f..afb5a92766b0 100644
--- a/multimedia/gstreamer-plugins/distinfo
+++ b/multimedia/gstreamer-plugins/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.2.tar.bz2) = 1f46e3aa765659818f309ed5b64c9b88
-SIZE (gnome2/gst-plugins-0.8.2.tar.bz2) = 1978467
+MD5 (gnome2/gst-plugins-0.8.3.tar.bz2) = a46b562dbb8c51d7c3bc46a11df09220
+SIZE (gnome2/gst-plugins-0.8.3.tar.bz2) = 2001671
diff --git a/multimedia/gstreamer-plugins/files/patch-ext_theora_theoradec.c b/multimedia/gstreamer-plugins/files/patch-ext_theora_theoradec.c
new file mode 100644
index 000000000000..cd89a80d2d18
--- /dev/null
+++ b/multimedia/gstreamer-plugins/files/patch-ext_theora_theoradec.c
@@ -0,0 +1,19 @@
+--- ext/theora/theoradec.c.orig Wed Aug 4 16:29:13 2004
++++ ext/theora/theoradec.c Wed Aug 4 16:30:47 2004
+@@ -385,6 +385,7 @@
+ gboolean res = TRUE;
+ GstTheoraDec *dec;
+ GstFormat format;
++ GstEvent *real_seek;
+
+ dec = GST_THEORA_DEC (gst_pad_get_parent (pad));
+
+@@ -405,7 +406,7 @@
+ goto error;
+
+ /* then seek with time on the peer */
+- GstEvent *real_seek = gst_event_new_seek (
++ real_seek = gst_event_new_seek (
+ (GST_EVENT_SEEK_TYPE (event) & ~GST_SEEK_FORMAT_MASK) |
+ format, value);
+
diff --git a/multimedia/gstreamer-plugins/files/patch-gst_interleave_interleave.c b/multimedia/gstreamer-plugins/files/patch-gst_interleave_interleave.c
new file mode 100644
index 000000000000..573c81e11860
--- /dev/null
+++ b/multimedia/gstreamer-plugins/files/patch-gst_interleave_interleave.c
@@ -0,0 +1,65 @@
+--- gst/interleave/interleave.c.orig Thu Aug 5 14:49:14 2004
++++ gst/interleave/interleave.c Thu Aug 5 14:50:41 2004
+@@ -60,7 +60,8 @@
+ GstPad *srcpad;
+ GList *channels;
+
+- gint numchannels; /* Number of pads on the element */
++ gint numpads; /* Number of pads on the element */
++ gint numchannels; /* Actual number of channels */
+ gint channelcount; /* counter to get safest pad name */
+ gboolean is_int;
+
+@@ -96,7 +97,7 @@
+ "signed = (boolean) { true, false };"
+ "audio/x-raw-float, "
+ "rate = (int) [ 1, MAX ], "
+- "channels = (int) 1, "
++ "channels = (int) 1,"
+ "endianness = (int) BYTE_ORDER, "
+ "width = (int) 32," "buffer-frames = (int) [ 0, MAX ]")
+ );
+@@ -203,7 +204,11 @@
+ gst_pad_set_link_function (this->srcpad, interleave_link);
+ gst_pad_set_getcaps_function (this->srcpad, interleave_getcaps);
+
+- this->numchannels = 0;
++ this->numchannels = 1; /* Numchannels must start with 1, even if there are
++ no channels, as 0 channel audio is invalid
++ and it stops people linking the interleave sink
++ before the src */
++ this->numpads = 0;
+ this->channelcount = 0;
+ this->channels = NULL;
+ }
+@@ -232,7 +237,9 @@
+ gst_pad_set_getcaps_function (channel->sinkpad, interleave_getcaps);
+
+ this->channels = g_list_append (this->channels, channel);
+- this->numchannels++;
++ if (this->numpads > 0)
++ this->numchannels++;
++ this->numpads++;
+ this->channelcount++;
+
+ GST_DEBUG ("interleave added pad %s\n", name);
+@@ -261,7 +268,9 @@
+
+ p = p->next;
+ this->channels = g_list_remove_link (this->channels, p_copy);
+- this->numchannels--;
++ this->numpads--;
++ if (this->numpads > 0)
++ this->numchannels--;
+
+ g_list_free (p_copy);
+
+@@ -476,7 +485,7 @@
+
+ /* if in the future int gets a buffer-frames property, we should switch here
+ * on the type */
+- do_float_interleave ((gfloat **) data_in, this->numchannels,
++ do_float_interleave ((gfloat **) data_in, this->numpads,
+ (gfloat *) data_out, to_process_bytes / sizeof (gfloat));
+
+ /* clean up and push */
diff --git a/multimedia/gstreamer-plugins/files/patch-ltmain.sh b/multimedia/gstreamer-plugins/files/patch-ltmain.sh
deleted file mode 100644
index 3d50310f61a4..000000000000
--- a/multimedia/gstreamer-plugins/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Mon Oct 20 15:20:54 2003
-+++ ltmain.sh Fri Nov 14 18:06:07 2003
-@@ -1278,7 +1278,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1288,8 +1288,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3008,6 +3016,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5457,10 +5468,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/gstreamer-plugins/pkg-plist b/multimedia/gstreamer-plugins/pkg-plist
index 6ebfc05e32a1..d832c54554a2 100644
--- a/multimedia/gstreamer-plugins/pkg-plist
+++ b/multimedia/gstreamer-plugins/pkg-plist
@@ -40,6 +40,7 @@ lib/gstreamer-%%VERSION%%/libgstac3parse.so
lib/gstreamer-%%VERSION%%/libgstadder.so
lib/gstreamer-%%VERSION%%/libgstalaw.so
lib/gstreamer-%%VERSION%%/libgstalpha.so
+lib/gstreamer-%%VERSION%%/libgstalphacolor.so
%%ARTS%%lib/gstreamer-%%VERSION%%/libgstartsdsink.so
lib/gstreamer-%%VERSION%%/libgstasf.so
lib/gstreamer-%%VERSION%%/libgstaudioconvert.so
@@ -58,6 +59,7 @@ lib/gstreamer-%%VERSION%%/libgstchart.so
%%HERMES%%lib/gstreamer-%%VERSION%%/libgstcolorspace.so
lib/gstreamer-%%VERSION%%/libgstcutter.so
lib/gstreamer-%%VERSION%%/libgstdebug.so
+lib/gstreamer-%%VERSION%%/libgstdecodebin.so
lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
%%DTS%%lib/gstreamer-%%VERSION%%/libgstdtsdec.so
%%LIBDV%%lib/gstreamer-%%VERSION%%/libgstdvdec.so
@@ -66,6 +68,7 @@ lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
lib/gstreamer-%%VERSION%%/libgstefence.so
lib/gstreamer-%%VERSION%%/libgsteffectv.so
%%ESOUND%%lib/gstreamer-%%VERSION%%/libgstesd.so
+%%FAAC%%lib/gstreamer-%%VERSION%%/libgstfaac.so
%%FAAD%%lib/gstreamer-%%VERSION%%/libgstfaad.so
lib/gstreamer-%%VERSION%%/libgstfestival.so
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.so
@@ -104,6 +107,7 @@ lib/gstreamer-%%VERSION%%/libgstmpegaudio.so
lib/gstreamer-%%VERSION%%/libgstmpegaudioparse.so
lib/gstreamer-%%VERSION%%/libgstmpegstream.so
lib/gstreamer-%%VERSION%%/libgstmulaw.so
+lib/gstreamer-%%VERSION%%/libgstmultifilesink.so
lib/gstreamer-%%VERSION%%/libgstmultipart.so
%%NAS%%lib/gstreamer-%%VERSION%%/libgstnassink.so
lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
@@ -111,6 +115,7 @@ lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
lib/gstreamer-%%VERSION%%/libgstoverlay.so
%%OSS%%lib/gstreamer-%%VERSION%%/libgstossaudio.so
lib/gstreamer-%%VERSION%%/libgstpassthrough.so
+lib/gstreamer-%%VERSION%%/libgstplaybin.so
lib/gstreamer-%%VERSION%%/libgstplayondemand.so
%%PNG%%lib/gstreamer-%%VERSION%%/libgstpng.so
lib/gstreamer-%%VERSION%%/libgstqtdemux.so
@@ -189,7 +194,9 @@ libdata/pkgconfig/gstreamer-play-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-plugins-%%VERSION%%.pc
share/locale/af/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/az/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/cs/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/hu/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sr/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sv/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@@ -199,7 +206,6 @@ share/locale/uk/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/xoverlay
@dirrm include/gstreamer-%%VERSION%%/gst/video
@dirrm include/gstreamer-%%VERSION%%/gst/tuner
-@dirrm include/gstreamer-%%VERSION%%/gst/tag
@dirrm include/gstreamer-%%VERSION%%/gst/riff
@dirrm include/gstreamer-%%VERSION%%/gst/resample
@dirrm include/gstreamer-%%VERSION%%/gst/propertyprobe
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index faf49ccb7a05..f42a168752ff 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.8.2
-PORTREVISION= 4
+PORTVERSION= 0.8.3
CATEGORIES= multimedia audio
MASTER_SITES= ${MASTER_SITE_GNOME} \
http://gstreamer.freedesktop.org/src/gst-plugins/
@@ -31,7 +30,7 @@ USE_GNOME= gnomehack \
pkgconfig \
gconf2
USE_REINPLACE= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER=15
CONFIGURE_ARGS= --disable-tests \
--disable-alsa \
--enable-cdrom \
@@ -42,18 +41,23 @@ CONFIGURE_ARGS= --disable-tests \
--disable-raw1394 \
--disable-v4l2 \
--disable-v4l \
+ --disable-osx_audio \
+ --disable-sunaudio \
--disable-dependency-tracking \
--enable-xshm \
+ --enable-x \
+ --enable-xvideo \
--enable-static
# list of plugins that need some work in one way or the other to work
# probable the lib needs to be ported, disable them for now.
-CONFIGURE_ARGS+=--disable-mas \
- --disable-faac \
+CONFIGURE_ARGS+=\
--disable-tarkin \
--disable-lcs \
--disable-mplex \
--disable-shout2 \
+ --disable-libvisual \
+ --disable-dirac \
--disable-librfb
CONFIGURE_ENV= PKG_CONFIG=${PKG_CONFIG} \
@@ -169,6 +173,11 @@ WITH_CDPARANOIA=yes
WITH_DTS=yes
.endif
+# faac
+.if exists(${LOCALBASE}/lib/libfaac.a)
+WITH_FAAC=yes
+.endif
+
# esound
.if (${HAVE_GNOME:Mesound}!="")
WITH_ESOUND=yes
@@ -460,6 +469,15 @@ CONFIGURE_ARGS+= --with-esd-prefix=${LOCALBASE} \
PLIST_SUB+= ESOUND=""
.endif
+# faac
+.ifndef(WITH_FAAC)
+CONFIGURE_ARGS+= --disable-faac
+PLIST_SUB+= FAAC="@comment "
+.else
+LIB_DEPENDS+= faac.0:${PORTSDIR}/audio/faac
+PLIST_SUB+= FAAC=""
+.endif
+
# faad
.ifndef(WITH_FAAD)
CONFIGURE_ARGS+= --disable-faad
@@ -873,14 +891,13 @@ PLIST_SUB+= XINE=""
.endif
# xvid
-#.ifndef(WITH_XVID)
+.ifndef(WITH_XVID)
CONFIGURE_ARGS+= --disable-xvid
PLIST_SUB+= XVID="@comment "
-#.undef WITH_XVID
-#.else
-#LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
-#PLIST_SUB+= XVID=""
-#.endif
+.else
+LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+PLIST_SUB+= XVID=""
+.endif
post-build:
.ifdef(EXTRA_BUILD_DIR)
@@ -896,7 +913,8 @@ post-install:
. endfor
.endif
# register plugins
- -@${X11BASE}/bin/gst-register-${GST_VERSION} 2>/dev/null
+ -@${X11BASE}/bin/gst-register-${GST_VERSION} \
+ --gst-registry=${PREFIX}/share/gnome/cache/gstreamer-${GST_VERSION}/registry.xml 2>/dev/null
pre-everything::
.ifndef(WITH_AALIB)
@@ -934,6 +952,10 @@ pre-everything::
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_ESOUND to enable esound Audio plugin'
.endif
+.ifndef(WITH_FAAC)
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Define WITH_FAAC to enable faac Audio plugin'
+.endif
.ifndef(WITH_FAAD)
@${ECHO_MSG} '===>'
@${ECHO_MSG} '===> Define WITH_FAAD to enable faad Audio plugin'
diff --git a/multimedia/gstreamer-plugins80/distinfo b/multimedia/gstreamer-plugins80/distinfo
index 2ab790307c7f..afb5a92766b0 100644
--- a/multimedia/gstreamer-plugins80/distinfo
+++ b/multimedia/gstreamer-plugins80/distinfo
@@ -1,2 +1,2 @@
-MD5 (gnome2/gst-plugins-0.8.2.tar.bz2) = 1f46e3aa765659818f309ed5b64c9b88
-SIZE (gnome2/gst-plugins-0.8.2.tar.bz2) = 1978467
+MD5 (gnome2/gst-plugins-0.8.3.tar.bz2) = a46b562dbb8c51d7c3bc46a11df09220
+SIZE (gnome2/gst-plugins-0.8.3.tar.bz2) = 2001671
diff --git a/multimedia/gstreamer-plugins80/files/patch-ext_theora_theoradec.c b/multimedia/gstreamer-plugins80/files/patch-ext_theora_theoradec.c
new file mode 100644
index 000000000000..cd89a80d2d18
--- /dev/null
+++ b/multimedia/gstreamer-plugins80/files/patch-ext_theora_theoradec.c
@@ -0,0 +1,19 @@
+--- ext/theora/theoradec.c.orig Wed Aug 4 16:29:13 2004
++++ ext/theora/theoradec.c Wed Aug 4 16:30:47 2004
+@@ -385,6 +385,7 @@
+ gboolean res = TRUE;
+ GstTheoraDec *dec;
+ GstFormat format;
++ GstEvent *real_seek;
+
+ dec = GST_THEORA_DEC (gst_pad_get_parent (pad));
+
+@@ -405,7 +406,7 @@
+ goto error;
+
+ /* then seek with time on the peer */
+- GstEvent *real_seek = gst_event_new_seek (
++ real_seek = gst_event_new_seek (
+ (GST_EVENT_SEEK_TYPE (event) & ~GST_SEEK_FORMAT_MASK) |
+ format, value);
+
diff --git a/multimedia/gstreamer-plugins80/files/patch-gst_interleave_interleave.c b/multimedia/gstreamer-plugins80/files/patch-gst_interleave_interleave.c
new file mode 100644
index 000000000000..573c81e11860
--- /dev/null
+++ b/multimedia/gstreamer-plugins80/files/patch-gst_interleave_interleave.c
@@ -0,0 +1,65 @@
+--- gst/interleave/interleave.c.orig Thu Aug 5 14:49:14 2004
++++ gst/interleave/interleave.c Thu Aug 5 14:50:41 2004
+@@ -60,7 +60,8 @@
+ GstPad *srcpad;
+ GList *channels;
+
+- gint numchannels; /* Number of pads on the element */
++ gint numpads; /* Number of pads on the element */
++ gint numchannels; /* Actual number of channels */
+ gint channelcount; /* counter to get safest pad name */
+ gboolean is_int;
+
+@@ -96,7 +97,7 @@
+ "signed = (boolean) { true, false };"
+ "audio/x-raw-float, "
+ "rate = (int) [ 1, MAX ], "
+- "channels = (int) 1, "
++ "channels = (int) 1,"
+ "endianness = (int) BYTE_ORDER, "
+ "width = (int) 32," "buffer-frames = (int) [ 0, MAX ]")
+ );
+@@ -203,7 +204,11 @@
+ gst_pad_set_link_function (this->srcpad, interleave_link);
+ gst_pad_set_getcaps_function (this->srcpad, interleave_getcaps);
+
+- this->numchannels = 0;
++ this->numchannels = 1; /* Numchannels must start with 1, even if there are
++ no channels, as 0 channel audio is invalid
++ and it stops people linking the interleave sink
++ before the src */
++ this->numpads = 0;
+ this->channelcount = 0;
+ this->channels = NULL;
+ }
+@@ -232,7 +237,9 @@
+ gst_pad_set_getcaps_function (channel->sinkpad, interleave_getcaps);
+
+ this->channels = g_list_append (this->channels, channel);
+- this->numchannels++;
++ if (this->numpads > 0)
++ this->numchannels++;
++ this->numpads++;
+ this->channelcount++;
+
+ GST_DEBUG ("interleave added pad %s\n", name);
+@@ -261,7 +268,9 @@
+
+ p = p->next;
+ this->channels = g_list_remove_link (this->channels, p_copy);
+- this->numchannels--;
++ this->numpads--;
++ if (this->numpads > 0)
++ this->numchannels--;
+
+ g_list_free (p_copy);
+
+@@ -476,7 +485,7 @@
+
+ /* if in the future int gets a buffer-frames property, we should switch here
+ * on the type */
+- do_float_interleave ((gfloat **) data_in, this->numchannels,
++ do_float_interleave ((gfloat **) data_in, this->numpads,
+ (gfloat *) data_out, to_process_bytes / sizeof (gfloat));
+
+ /* clean up and push */
diff --git a/multimedia/gstreamer-plugins80/files/patch-ltmain.sh b/multimedia/gstreamer-plugins80/files/patch-ltmain.sh
deleted file mode 100644
index 3d50310f61a4..000000000000
--- a/multimedia/gstreamer-plugins80/files/patch-ltmain.sh
+++ /dev/null
@@ -1,51 +0,0 @@
---- ltmain.sh.orig Mon Oct 20 15:20:54 2003
-+++ ltmain.sh Fri Nov 14 18:06:07 2003
-@@ -1278,7 +1278,7 @@
- esac
- elif test "X$arg" = "X-lc_r"; then
- case $host in
-- *-*-openbsd* | *-*-freebsd*)
-+ *-*-openbsd* | *-*-freebsd4*)
- # Do not include libc_r directly, use -pthread flag.
- continue
- ;;
-@@ -1288,8 +1288,16 @@
- continue
- ;;
-
-+ -pthread)
-+ compile_command="$compile_command -pthread"
-+ finalize_command="$finalize_command -pthread"
-+ compiler_flags="$compiler_flags -pthread"
-+ continue
-+ ;;
-+
- -module)
- module=yes
-+ build_old_libs=no
- continue
- ;;
-
-@@ -3008,6 +3016,9 @@
- # problems, so we reset it completely
- verstring=
- ;;
-+ *-*-freebsd*)
-+ # FreeBSD doesn't need this...
-+ ;;
- *)
- verstring="0.0"
- ;;
-@@ -5457,10 +5468,12 @@
- fi
-
- # Install the pseudo-library for information purposes.
-+ if /usr/bin/false; then
- name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
- instname="$dir/$name"i
- $show "$install_prog $instname $destdir/$name"
- $run eval "$install_prog $instname $destdir/$name" || exit $?
-+ fi
-
- # Maybe install the static library, too.
- test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/multimedia/gstreamer-plugins80/pkg-plist b/multimedia/gstreamer-plugins80/pkg-plist
index 6ebfc05e32a1..d832c54554a2 100644
--- a/multimedia/gstreamer-plugins80/pkg-plist
+++ b/multimedia/gstreamer-plugins80/pkg-plist
@@ -40,6 +40,7 @@ lib/gstreamer-%%VERSION%%/libgstac3parse.so
lib/gstreamer-%%VERSION%%/libgstadder.so
lib/gstreamer-%%VERSION%%/libgstalaw.so
lib/gstreamer-%%VERSION%%/libgstalpha.so
+lib/gstreamer-%%VERSION%%/libgstalphacolor.so
%%ARTS%%lib/gstreamer-%%VERSION%%/libgstartsdsink.so
lib/gstreamer-%%VERSION%%/libgstasf.so
lib/gstreamer-%%VERSION%%/libgstaudioconvert.so
@@ -58,6 +59,7 @@ lib/gstreamer-%%VERSION%%/libgstchart.so
%%HERMES%%lib/gstreamer-%%VERSION%%/libgstcolorspace.so
lib/gstreamer-%%VERSION%%/libgstcutter.so
lib/gstreamer-%%VERSION%%/libgstdebug.so
+lib/gstreamer-%%VERSION%%/libgstdecodebin.so
lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
%%DTS%%lib/gstreamer-%%VERSION%%/libgstdtsdec.so
%%LIBDV%%lib/gstreamer-%%VERSION%%/libgstdvdec.so
@@ -66,6 +68,7 @@ lib/gstreamer-%%VERSION%%/libgstdeinterlace.so
lib/gstreamer-%%VERSION%%/libgstefence.so
lib/gstreamer-%%VERSION%%/libgsteffectv.so
%%ESOUND%%lib/gstreamer-%%VERSION%%/libgstesd.so
+%%FAAC%%lib/gstreamer-%%VERSION%%/libgstfaac.so
%%FAAD%%lib/gstreamer-%%VERSION%%/libgstfaad.so
lib/gstreamer-%%VERSION%%/libgstfestival.so
lib/gstreamer-%%VERSION%%/libgstffmpegcolorspace.so
@@ -104,6 +107,7 @@ lib/gstreamer-%%VERSION%%/libgstmpegaudio.so
lib/gstreamer-%%VERSION%%/libgstmpegaudioparse.so
lib/gstreamer-%%VERSION%%/libgstmpegstream.so
lib/gstreamer-%%VERSION%%/libgstmulaw.so
+lib/gstreamer-%%VERSION%%/libgstmultifilesink.so
lib/gstreamer-%%VERSION%%/libgstmultipart.so
%%NAS%%lib/gstreamer-%%VERSION%%/libgstnassink.so
lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
@@ -111,6 +115,7 @@ lib/gstreamer-%%VERSION%%/libgstnavigationtest.so
lib/gstreamer-%%VERSION%%/libgstoverlay.so
%%OSS%%lib/gstreamer-%%VERSION%%/libgstossaudio.so
lib/gstreamer-%%VERSION%%/libgstpassthrough.so
+lib/gstreamer-%%VERSION%%/libgstplaybin.so
lib/gstreamer-%%VERSION%%/libgstplayondemand.so
%%PNG%%lib/gstreamer-%%VERSION%%/libgstpng.so
lib/gstreamer-%%VERSION%%/libgstqtdemux.so
@@ -189,7 +194,9 @@ libdata/pkgconfig/gstreamer-play-%%VERSION%%.pc
libdata/pkgconfig/gstreamer-plugins-%%VERSION%%.pc
share/locale/af/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/az/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/cs/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/en_GB/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
+share/locale/hu/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/nl/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sr/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
share/locale/sv/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@@ -199,7 +206,6 @@ share/locale/uk/LC_MESSAGES/gst-plugins-%%VERSION%%.mo
@dirrm include/gstreamer-%%VERSION%%/gst/xoverlay
@dirrm include/gstreamer-%%VERSION%%/gst/video
@dirrm include/gstreamer-%%VERSION%%/gst/tuner
-@dirrm include/gstreamer-%%VERSION%%/gst/tag
@dirrm include/gstreamer-%%VERSION%%/gst/riff
@dirrm include/gstreamer-%%VERSION%%/gst/resample
@dirrm include/gstreamer-%%VERSION%%/gst/propertyprobe